• Welcome to the all-new Windows Central Forums! - We're still moving some things around, so you may see a few quirks here and there, but we're working on getting things fully completed as soon as possible. For now, take a look around, and if you run into any major issues, please let us know in this thread!

Windows 10 USB driver will not load fix.


New member
Jan 15, 2016
There's a ton of post about Windows 10 drivers not working out there. This one is different!
After the upgrade from windows 8.1, like most everyone else it seems, I struggled with drivers for older
devices and some newer ones.
In most cases I was successful by trying Windows 8, Windows 7 and even Vista drivers.
In other cases, not so much. In a couple of those cases here's what worked. (not the best solution, but something)
Here the scenario (I've seen this a lot and I bet you have too)
1. Plug in a USB device and windows reports something like "The drivers for this device are not installed. (Code 28)"
or "Windows cannot start this driver" Even though the correct device name is clearly detected.
A good example of this is my brand new LG Model L41C Android smartphone.
(I have downloaded and tried all the recent drivers from the LG site)

Here's my fix: (please share this with your friends)

1. Plug in the device, windows fails to load the driver.
2. Open up device manager.
3. Find the listing for the device (clearly marked with the dreaded yellow exclamation mark)
4 Right-Click and choose "Disable" (NOT Uninstall)
The device will still be in the list but sort of grayed-out
5. Leave Device Manager open and unplug the device. (it will disappear from the list)
6. Plug the device back in. It will re-appear but still disabled.
7. Right click on it and choose "Enable" Like magic the driver will load and function.

I've used this trick on several devices. Doesn't work all the time but sometimes it does.
This seems to rule out the problem being with the device driver itself since it will load and function after this trick.
I've also found that the same driver will load without this trick if the device happens to be plugged in at boot time.

One of the USB devices I use frequently is a USB-Serial converter.
I have several of these and I'm careful to get the ones based on the CP2102 chip.
I've had the best luck with the manufacturers drivers for these devices.
(if you have the PL2303 kind, I'm sorry, I feel your pain search for an old VISTA driver set and try to force it to load)

Anyway, several weeks ago I was happily transferring data with these devices and a notice popped up about a major
Windows 10 upgrade (sorry I forgot exactly what it was but it was labeled "Build {some bug number}" )
So I let it install, it took a long time so I went to bed.
The next day ALL of my USB-Serial converter devices would no longer work.
This is actually how I discovered this trick. I rebooted, and only the devices plugged in worked.
Another of the exact same kind when plugged in afterwards would not load the driver.
I fiddled around and discovered the Disable - unplug - plug - Enable trick but that's way too much trouble considering the frequency I use these devices. A lot of searching around the internet provided me with instruction on how to REVERSE the
Windows 10 update (I'm running Windows 10 Pro. the article suggested it might not be available for all versions of Win 10).

This restored the function for those devices but I still struggle with others.

As I mentioned before, I feel this is clearly NOT a driver issue but a Windows 10 change that invalidated a bunch of previously working device drivers.

I hope you find this useful and hope Microsoft will fix this soon.


New member
Jun 11, 2013
who knows, bugs are everywhere nowadays and people claim this is the best since sliced bread, when I started facing that problem my solution was to plug the device in another pc and if it automatically worked(like it should, like 8.1 7 and vista did) then I just traced the driver files, copied them to buggy pc and installed it manually, I can provide details if someone needs it let me know

Ram D

New member
Jun 20, 2016
I'd the exact same issue as yours (and I had the exact work that worked but was pain in the neck). I went through uninstalling and reinstalling roothub drivers, chipset drivers, power options, disabling fast boot and everything suggested everywhere. Nothing helped as you're describing above. Turns out, its neither a bug in Windows 10 or the USB drivers but VMware Horizon View Client which was automatically trying to map plugged in USB devices to the servers and was failing in the middle. It didn't matter whether I was connected or not or even had the VMW-HV client open. In your case, it might be something 3rd party like this, may be some VM/VDI related applications interfering with USB.

I used "procmon" to find out what is causing the issue. Uninstalled the *&$#%&(*@ thing and everything was ***** dory after that.