Windows 8.1 RTM Available for MSDN and TechNet Subscribers

Vistaus

New member
Jul 12, 2013
74
0
0
Visit site
The leaked version isn't even working. Followed all the steps needed to prepare the upgrade USB and when done, the RT just errors out when double-clicking setup.exe "wsdcore.dll is not for this version of Windows or contains an error. Right.
 

quantum tao

New member
Jan 9, 2013
341
0
0
Visit site
The leaked version isn't even working. Followed all the steps needed to prepare the upgrade USB and when done, the RT just errors out when double-clicking setup.exe "wsdcore.dll is not for this version of Windows or contains an error. Right.
works perfect for me.
 
Last edited:

Vistaus

New member
Jul 12, 2013
74
0
0
Visit site
Okay, isn't working FOR ME. Better? If you're so clever than maybe you can help me out solving it?
 
Last edited:

azcruz

Active member
Jul 29, 2013
3,417
0
36
Visit site
You did the dism steps for the boot.wim and install.wim? Assuming you got the ISO with the drivers folder. Yes?

Sent from my LT25i using Tapatalk 4
 

Derausgewanderte

New member
Dec 18, 2011
1,544
0
0
Visit site
Okay, isn't working FOR ME. Better? If you're so clever than maybe you can help me out solving it?
I've helped a number of other people getting this installed and I have no problem helping you. The steps in the link above are thorough. If you still get an error then it may be your ISO is corrupted or your current RT 8.0 has issues. I might try doing a refresh of the Surface with 8.0 and then do the upgrade next if you believe the iso is good. Let me know if you want to discuss this in pm.
 
Last edited:

azcruz

Active member
Jul 29, 2013
3,417
0
36
Visit site
I just did the upgrade last night from Preview to 8.1 RTM and there's nothing special with the steps if you have the ISO with drivers.

Sent from my LT25i using Tapatalk 4
 

Vistaus

New member
Jul 12, 2013
74
0
0
Visit site
I've helped a number of other people getting this installed and I have no problem helping you. The steps in the link above are thorough. If you still get an error then it may be your ISO is corrupted or your current RT 8.0 has issues. I might try doing a refresh of the Surface with 8.0 and then do the upgrade next if you believe the iso is good. Let me know if you want to discuss this in pm.

The ISO is good. It could be that my RT 8.0 has issues but I would find that very strange as I have the RT for about 3 weeks now (and I bought it new in store). Maybe I'll try a fresh install of 8.0
 

Derausgewanderte

New member
Dec 18, 2011
1,544
0
0
Visit site
The ISO is good. It could be that my RT 8.0 has issues but I would find that very strange as I have the RT for about 3 weeks now (and I bought it new in store). Maybe I'll try a fresh install of 8.0
still curious about your particular error in wsdcore.dll.
the iso with drivers correctly injected should be:
size on disk: 2.49 GB (2,679,341,056 bytes)
(note that this assumes that drivers have been correctly injected in both Index:1 and Index:2 of the boot.wim in addition to the install.wim (there are two partitions in there). )
Unfortunately I cannot find any wsdcore.dll file in the iso nor in the install.wim. There is however a wdscore.dll file. Did you mean to type that?
Here is a link to that file from a working iso. Please check if it matches the one in your iso. Please PM me if you decide to try another copy of an iso with drivers injected.
 

Members online

Forum statistics

Threads
322,484
Messages
2,242,089
Members
427,933
Latest member
sanju_dp