1. DocJelly's Avatar
    Hi there, I'm messing around with the Windows 10 Enterprise preview (build 9926) and seem to have run into something funny... my GPO WMI filters don't seem to want to apply... After searching around and finding out about gwmi in PowerShell, I've done some testing and it doesn't really seem to add up!

    powershell command:
    gwmi -Query 'SELECT Version, ProductType FROM Win32_OperatingSystem WHERE ((Version >= "6.2.%") AND (ProductType = "1"))'

    This query should return SOMETHING if it's true, or nothing, just return to the prompt it false.

    If I run this on a windows 8.1 install, it returns true. If I run this on a Windows 10 install, it returns false. Windows 10 seems to think that Version 10.0.9926 is NOT greater than or equal to 6.2.% :)

    Could someone else try running that query on a Windows 10 preview install from a powershell command promp and confirm that they get the same "false" response that I do?

    If I change it to Version >= "10" or "10.%" then it returns true... so the query is correct, it's just not evaluating Windows 10's version number to be greater than 6.2.% (Windows 8.1's version number)

    Or maybe I'm just taking crazy pills :)
    01-26-2015 04:00 PM
  2. David Feifer's Avatar
    Same thing here. Ran in both ps and ps ise as admin appeared to run and just went back to command prompt.
    01-26-2015 04:21 PM
  3. DocJelly's Avatar
    Ack. lost my reply because I don't have enough points to include the link to the blog post where I discovered gwmi :)

    according to that blog post that I cannot link to in a reply, , if it returns ANYTHING, that means it's $true, but if it returns nothing/blank/null just the command prompt again, that means it's $false.

    So Version 10.0.9926 is less than 6.2.% according to Windows 10 :)
    01-26-2015 04:45 PM
  4. joshuaaluke's Avatar
    It's because the value is evaluated as text. Just like in Excel when you sort numbers as text - 10 is lower than 6 because it starts over when it gets back to 1. An "or" statement is required.
    02-09-2015 09:16 AM
  5. jnjroach's Avatar
    Where are you attempting to apply the GPO? If it is from an AD environment, have you imported the ADMX files for Windows 10?
    02-09-2015 10:00 AM

Similar Threads

  1. 0x80073cf1 in Store trying to update mail and people hub
    By vincentw56 in forum Windows 10 Insider Preview
    Replies: 9
    Last Post: 02-04-2015, 04:07 PM
  2. Default Music and Podcast Apps for Phone Windows 10
    By boomerz in forum Windows 10 Mobile Insider Preview
    Replies: 4
    Last Post: 01-26-2015, 11:44 PM
  3. How do you remove the lastest update on the windows nokia phone?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 01-26-2015, 04:16 PM
  4. Surface pulls in over one billion in revenue for Microsoft as sales increase by 24%
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 01-26-2015, 03:50 PM
  5. When is the 'HP basic keyboard' going to be compatible with Windows 10?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 01-26-2015, 03:31 PM
LINK TO POST COPIED TO CLIPBOARD