1. PXgamer's Avatar
    So about a month ago, I got Windows 10 on my Lumia 920, and ever since then it's gone steadily downhill.

    First, it keeps freezing and theres lots of other glitches. But, last night, it suddenly turned off with no warning. I put it on to charge, and it "charged" overnight. This morning I woke up and it was still showing the NOKIA logo.

    I soft reset it, it buzzed and showed the NOKIA logo. No change, just stayed like that. I hard reset it, and it buzzed and showed the NOKIA logo again. I thought it had worked (it's still charging)... 2 hours later, it's back to the NOKIA logo. I soft reset, and it shows the low battery/charging warning.

    So, it should be charging... 3 hours later, it's still doing the same thing. I can't detect it with Nokia Care Suite, or Windows Phone Recovery Tool as it just keeps rebooting.

    Any help would be greatly appreciated, if not I guess I have to take it to Tesco repairs.

    Thanks,
    PXgamer
    06-17-2015 06:03 AM

Similar Threads

  1. Replies: 14
    Last Post: 06-21-2015, 04:28 PM
  2. New build 10136 bricks my lumia 1320
    By congthanhgiong in forum Windows 10 Mobile Insider Preview
    Replies: 7
    Last Post: 06-17-2015, 09:29 AM
  3. How do I print a received sms?
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 06-17-2015, 05:19 AM
  4. Why can't I upgrade to build 10130 from 10074 ?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 06-17-2015, 04:27 AM
  5. now I face a big problem in my lumia 535 when charged
    By Tushar Kanti Das1 in forum Microsoft Lumia 535
    Replies: 1
    Last Post: 06-17-2015, 04:23 AM
LINK TO POST COPIED TO CLIPBOARD