1. Chandrasekhar mahakulkar's Avatar
    i am using lumia 520 and have windows 10 (last version) Now i am trying to download new version ie 10166 but not getting download it showing me message ie "your mobile is on battery saving mode please turn it off and downloading will start" but it dosnt work. If downloading start somehow it get stop at 4% every time.....I hae tried many ways but it is not working
    07-13-2015 08:33 AM
  2. Harrie-S's Avatar
    Connect it to a charger and leave it connected.
    07-13-2015 09:19 AM
  3. tut1234's Avatar
    I successfully installed 10166 on my 520 yesterday. One thing I noticed was, the phone was not charging while it was updating, even though the charger was connected. You should fully charge your phone before starting the upgrade.
    07-13-2015 09:59 AM
  4. variableme's Avatar
    I tried leaving it on charge overnight but it still didn't download. Sucks.
    07-29-2015 02:00 AM
  5. I3unny's Avatar
    I successfully installed 10166 on my 520 yesterday. One thing I noticed was, the phone was not charging while it was updating, even though the charger was connected. You should fully charge your phone before starting the upgrade.
    How is it working on your 520?
    07-29-2015 02:07 AM
  6. MysticForce's Avatar
    I tried on L630 and also I have 10149 update but I can't update phone up to 10166.
    07-29-2015 02:27 AM
  7. tut1234's Avatar
    How is it working on your 520?
    It's ok for my daily driver. I make calls, text, use Here+, music player, calendar and hey Angry Birds is working. I have several games and news apps and they work. It's a little slow at times and this morning I had to reboot it. Some people were having problems with Store, but it works for me, though I have not purchased anything, just reloaded what I own. I have been leaving on the charger with the wifi on at night, just to see if it picks up any updated apps. As someone mentioned, history is not working, so you don't really know if it got anything. Camera button brings up video, this is annoying. I don't use skype, xbox, or cortana.

    If you update, just be patient, there are a lot of apps updating in the background and it takes a while. Be sure to do a soft reset.
    07-29-2015 09:12 AM
  8. I3unny's Avatar
    It's ok for my daily driver. I make calls, text, use Here+, music player, calendar and hey Angry Birds is working. I have several games and news apps and they work. It's a little slow at times and this morning I had to reboot it. Some people were having problems with Store, but it works for me, though I have not purchased anything, just reloaded what I own. I have been leaving on the charger with the wifi on at night, just to see if it picks up any updated apps. As someone mentioned, history is not working, so you don't really know if it got anything. Camera button brings up video, this is annoying. I don't use skype, xbox, or cortana.

    If you update, just be patient, there are a lot of apps updating in the background and it takes a while. Be sure to do a soft reset.
    Thanks. I am also going to install 10166 on my 520 then :D
    07-29-2015 09:36 AM
  9. tut1234's Avatar
    Thanks. I am also going to install 10166 on my 520 then :D
    There has been a discussion about whether a hard reset is needed on not. The first time I updated to 10166, I did a hard reset right after and did not restore from backup, this works.
    Then I went back to 8.1 and updated again to 10166 and did not hard reset. It worked for awhile, but was acting funny.
    So, I did a backup at that point, a hard reset and restored my backup. That is how it is now and it is stable.
    Good luck.
    07-29-2015 10:34 AM
  10. Mad Cabbie's Avatar
    There has been a discussion about whether a hard reset is needed on not. The first time I updated to 10166, I did a hard reset right after and did not restore from backup, this works.
    Then I went back to 8.1 and updated again to 10166 and did not hard reset. It worked for awhile, but was acting funny.
    So, I did a backup at that point, a hard reset and restored my backup. That is how it is now and it is stable.
    Good luck.
    I had the same 'odd' behaviour when not hard resetting. Very strange things were afoot. I guess there maybe some app compatability issues etc, once hard reset I behaved rather well, apart from the notifications...
    07-29-2015 12:42 PM

Similar Threads

  1. Windows 10 Cant boot after Phone Reset
    By windowsenth in forum Windows 10 Mobile Insider Preview
    Replies: 6
    Last Post: 07-13-2015, 01:13 PM
  2. How do you purchase an app with child's account on Windows Phone?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-13-2015, 01:08 PM
  3. Problems on 10166, Lumia 820
    By BlackD0127 in forum Windows 10 Mobile Insider Preview
    Replies: 0
    Last Post: 07-13-2015, 08:20 AM
  4. Xbox executives pay their respects to Nintendo's Satoru Iwata
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-13-2015, 08:20 AM
  5. Windows Phone Store: The Clone Wars
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-13-2015, 08:00 AM
LINK TO POST COPIED TO CLIPBOARD