1. Zain Syed's Avatar
    I'm having a very weird problem even on the latest build of WM10. Every couple of days or so my phone becomes totally non-responsive. I soft reset it to notice that after the Nokia screen the phone just goes blank like before. I have to do a hard reset using the buttons to get back to everything but it becomes too cumbersome. I'm not sure why this is happening and honestly because it is the only phone I have I can't experiment it with the apps and check out certain apps. Searched everywhere I could but couldn't find anyone else having this problem. So I have decided to go back to WM 8.1 every time after I try out the latest WM10 as the issue resurrects back in every build I've tried out.
    10-07-2015 03:33 PM
  2. ven07's Avatar
    You're right, this is the first time I'm hearing of this issue :/ The best thing to do, since this is your only phone, is to stick with 8.1 for now and check out the next build
    10-07-2015 03:47 PM
  3. Lions fan's Avatar
    Having some similar issues, phone becomes very slow and sometimes the ringer sounds and vibrate do not work and have to restart phone.
    10-07-2015 05:17 PM
  4. Peter Turnansky's Avatar
    I have the same issue.Phone is laggy, slow and sometimes reboot unexpectedly and battery drain is huge.
    10-08-2015 08:15 AM
  5. pankaj981's Avatar
    Well this is sort of..expected. It's not only your 920 but the build is actually unstable on other phones too (read around the forums). And that's expected from a pre-release build. I had it on my 920 for a week and decided to roll back. The build is slow but usable on my 830 and on the 1520 is fast (but unstable) but on the 920 it was unusable due to lockups and slow responsiveness.
    ven07 likes this.
    10-08-2015 08:28 AM
  6. mikepalma's Avatar
    Same on 1520
    10-09-2015 02:18 AM
  7. pcoutinho's Avatar
    Same with my 925.

    The worst build ever, with an exponencial non response behaviour over time.
    mikepalma likes this.
    10-09-2015 02:57 AM
  8. Zain Syed's Avatar
    Alright. I don't want this issue to persist on any model when it actually comes out and was hoping there was a listening ear to this.
    10-14-2015 02:30 PM

Similar Threads

  1. Replies: 1
    Last Post: 10-07-2015, 04:56 PM
  2. Where is the store update history?
    By MKairys in forum Windows 10
    Replies: 2
    Last Post: 10-07-2015, 03:45 PM
  3. Why aren't my 8.1 Outlook url links clickable?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-07-2015, 03:29 PM
  4. Lumia 950 is not an AT&T exclusive in the US, but will other carriers sell it?
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-07-2015, 03:00 PM
  5. how to upgrade my windows 8.1 phone to windows 10
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 10-07-2015, 02:43 PM
LINK TO POST COPIED TO CLIPBOARD