The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. dKp1977's Avatar
    Hey guys,

    so I've just received my Lumia 950XL today and am in the middle of setting it up. I noticed though that my purchase history in the Store app is pretty much empty. It's only showing the already preinstalled apps, but not those I have purchased/installed throughout the years. I remember I had this issue once on one of the Insider builds running on my 1520, but I can't remember how I got rid of it. Most likely a hard reset did the trick.
    Does anybody possibly know any other way how to get the Store app show my real purchase history again? Or is hard reset the way to go?

    Thanks in advance for any help. :)
    12-04-2015 12:44 PM
  2. Indistinguishable's Avatar
    When you say "Purchase History" you're talking about "My Library" right? That's where all of your apps, & games will be listed whether they're installed on your device or not.
    12-04-2015 01:20 PM
  3. dKp1977's Avatar
    When you say "Purchase History" you're talking about "My Library" right? That's where all of your apps, & games will be listed whether they're installed on your device or not.

    That's exactly what I'm talking about. Sorry that I confused the name. Anyways, on my 950XL it's not showing my real library, it's almost empty. My 1520 is showing my entire library though.
    12-04-2015 01:21 PM
  4. Indistinguishable's Avatar
    Is the store app up to date? Have you tried a soft reset? That often fixes most store issues.
    12-04-2015 01:23 PM
  5. dKp1977's Avatar
    Is the store app up to date? Have you tried a soft reset? That often fixes most store issues.

    Yeah, it installed an update for the store app with the first bunch of updates for the preinstalled apps. I've checked the store for further updates multiple times afterwards, but there are none. Soft reset didn't fix it either. :/
    12-04-2015 01:27 PM
  6. Indistinguishable's Avatar
    Hmm... And you definitely have the 950XL added as one of your devices, right?

    20151204113745.jpg
    12-04-2015 01:38 PM
  7. dKp1977's Avatar
    Hmm... And you definitely have the 950XL added as one of your devices, right?



    It did that on its own. I performed a hard reset in the meantime. Funny enough, I logged in with my Microsoft account during the setup process and it was accepted as usual. But as soon as WM10 was ready, there was no trace of that account anywhere. Outlook mail, calendar, store, Cortana... None were connected to my account. It was even missing from the account settings. And when trying to tap "login with your Microsoft account", nothing happened.


    I'm currently performing another hard reset. I'm not giving up yet. ;)



    [Edit]

    That last hard reset fixed it. Yay! \o/
    Last edited by dKp1977; 12-04-2015 at 02:12 PM.
    12-04-2015 01:44 PM

Similar Threads

  1. Block Number feature not working in messaging
    By someone2639 in forum Windows 10 Mobile Insider Preview
    Replies: 3
    Last Post: 12-10-2015, 07:14 AM
  2. 5 intriguing apps for Windows 10: December 4, 2015
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-04-2015, 12:20 PM
  3. Windows 10 Mobile Apps
    By SilasDelgado in forum Applications
    Replies: 0
    Last Post: 12-04-2015, 11:55 AM
  4. The Daily Mail has a Windows 10 Mobile app to keep you informed from anywhere
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-04-2015, 11:42 AM
  5. How do I back up the contacts in People on my Nokia Lumia 625?
    By Windows Central Question in forum Nokia Lumia 625
    Replies: 1
    Last Post: 12-04-2015, 11:15 AM
LINK TO POST COPIED TO CLIPBOARD