The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. brokenwindows's Avatar
    I have a legit Win 7 laptop. I made a Win 10 reservation a few weeks back. Today, I went to microsoft[DOT]com/en-us/software-download/windows10 to download the "Media creation tool". I chose the 64-bit version because my laptop is 64-bit. The first 100 minutes was Downloading. Next 15 minutes was Verifying Download. Third stage was something about media center.

    And then I got to a choice of a) Upgrade your PC now or b) Prepare USB drive (or something like this).
    I chose Option A. It got to 3% when I got this error message:
    Something happened
    Setup has failed to initialize the working directory
    See attached screenshot.

    I thought to myself, "Well, the Windows 10 installation files are now on my hard drive. I won't have to wait 2 hours again." Well, I'm wrong. I double-clicked the Media Creation Tool exe file again, and it's back to downloading Windows 10 from 1% again!

    Oh no! What's wrong?
    Attached Thumbnails windows_10_setup_has_failed_to_initialize_working_directory.png  
    07-29-2015 08:46 PM
  2. Stealth777's Avatar
    Same here downloaded to usb and saved and I get the "setup has failed to initialize the working directory" I even ran the install now and got "setup has failed to initialize the working directory" someone please help us with this :)
    07-30-2015 12:44 PM
  3. Stealth777's Avatar
    Check your Hard Drive space ! if you don't have enough space for the unpacking of the files it will give this error. I think I found my problem was I only had 300 or less MB left , mine is a dell venue 8 pro tablet.
    07-30-2015 02:44 PM
  4. Virender Singh's Avatar
    You have to do two thikngs
    1. Make sure there is enough space
    2. Run the media creation tool or any related .exe file with admin Access. You can do it by right clicking on the file and "Open as Admin"

    Ideally the media creation tool should be able to get admin access once you click on it. It seems its not doing it for some systems.

    Thanks
    Virender Singh
    07-31-2015 09:42 PM
  5. Stealth777's Avatar
    Thank you , I figured it out yesterday that I didn't have enough space on hard drive so I cleaned it out and windows 10 installed just fine 😉
    07-31-2015 10:06 PM
  6. N y c k y's Avatar
    I'm having the same problem, I've been trying to upgrade a Windows 8.1 SL through Media Creation Tool. I also tried to 'Run s admin', but it still gives me the 'Something happened' msg. This is PC still have 867MB of free space in ROM. I hope you guys have a workaround for this.
    07-31-2015 11:16 PM
  7. Nicolas V's Avatar
    The tool worked for me after being logged in admin account.:wink
    08-01-2015 12:46 AM
  8. N y c k y's Avatar
    The tool worked for me after being logged in admin account.:wink
    I'm not very sure what you mean by that, sorry.
    There is only one account (user) in registered in the PC that I want to upgrade. (Which I assume would be the admin)
    I also opened the Media Creation Tool 'as administrator'.

    I don't quite know why am I keep having this problem. Thanks BTW.
    08-01-2015 03:12 AM
  9. Stealth777's Avatar
    Check your c:/ drive you have to have about 10gb of free space
    08-01-2015 12:06 PM
  10. zayler's Avatar
    Hey, i also have Dell venue 8 pro, but i have 32GB version, and as of now i dont really see how i could acquire 10GB of free space, i have 32GB microSD card inside which has the space. Any ideas?
    08-02-2015 06:51 PM
  11. Stealth777's Avatar
    I first cleaned out hard drive , right click on c:\ drive and then click properties and do a disk cleanup. And I also went into program and features and deleted all the programs I did not need. Back up all your stuff on your extra storage drive first. I even went into uninstall updates and deleted updates without restarting PC. Then try again.
    08-02-2015 09:08 PM

Similar Threads

  1. Why has my modern set up host stopped working?
    By Windows Central Question in forum Ask a Question
    Replies: 17
    Last Post: 02-03-2018, 01:24 AM
  2. Windows 10 changed all my document folders to read only and I can't reverse this
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 08-25-2015, 04:03 AM
  3. My touch-pad doesn't work or scroll for Windows 10?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-02-2015, 01:32 PM
  4. Windows 10 "Play to" Missing
    By FearL0rd in forum Windows 10
    Replies: 6
    Last Post: 07-31-2015, 10:04 PM
  5. Windows 10 start menu won't work!!!!??
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 07-31-2015, 05:16 PM
LINK TO POST COPIED TO CLIPBOARD