1. Windows Central Question's Avatar
    Since installing Windows 10 - previously on Windows 7 - all dates in Excel have turned into the American date format i.e. previously 12/08/15 in a cell displayed as 12th August 2015. Now it displays correctly but the cell contents have changed, so, in previous example, the cell now contains 08/12/15. How can I put this right? I have gone into anything I could see re language and have ensured it is English (United Kingdom) but this hasn't made any difference.
    08-12-2015 12:23 PM
  2. JD_Palmer said: Best Answer

    The best (and complete) solution is to install the "English (United Kingdom)" language pack.

    This can be found by going to: Control Panel [make sure you select 'view by: Small icons' in the top right so you can see all items] then select 'Language'. Here you will see the default "English (United States)" option with "enabled" against it and should see the "English (United Kingdom)" option below. [If not you should be able to find it via the 'add a language' button] Click on options and then the "Download and install language pack button"

    Just wait for it to install then highlight the recently installed option and click the 'move up' button so that this becomes your default. It should display "Will be enabled on next sign-in". It will do exactly that, after a reset it will be enabled and should be your default.

    This will then give you the wider variety of date options i.e. dd/MM/yy and d/M/yy that (as mentioned above) is not an option otherwise.

    Hope this helps :)
  3. tangledW's Avatar
    Freeeeeeeeeeeeedom!
    08-12-2015 12:28 PM
  4. Mike Jojn Hall's Avatar
    I've got exactly the same problem and it's bloody annoying. Annoying enough in fact that my other PCs will not be upgrading until it is solved.

    In fact the problem is more general: dates of emails in Live Mail and dates modified in whatever File Manager is now called have also switched to the mm/dd/yyyy format. This suggests some really crap testing by Microsoft.

    Anyone got a solution?
    08-13-2015 04:57 AM
  5. Mike Jojn Hall's Avatar
    To reply to myself since I realised that the general nature of the problem meant it must be due to an incorrect setting.

    Got to Settings/Time & Language/Date & Time/Formats/Change Date and Time Formats and change the short and long date formats to ones starting with "d".

    Microsoft should have got this setting right during conversion and should have given us more formats starting with "d", given that there are four short formats starting with "M". In fact, there should be UK versions of all these four USA formats, d/M/yy for example.
    rhapdog likes this.
    08-13-2015 06:06 AM
  6. JD_Palmer's Avatar
    The best (and complete) solution is to install the "English (United Kingdom)" language pack.

    This can be found by going to: Control Panel [make sure you select 'view by: Small icons' in the top right so you can see all items] then select 'Language'. Here you will see the default "English (United States)" option with "enabled" against it and should see the "English (United Kingdom)" option below. [If not you should be able to find it via the 'add a language' button] Click on options and then the "Download and install language pack button"

    Just wait for it to install then highlight the recently installed option and click the 'move up' button so that this becomes your default. It should display "Will be enabled on next sign-in". It will do exactly that, after a reset it will be enabled and should be your default.

    This will then give you the wider variety of date options i.e. dd/MM/yy and d/M/yy that (as mentioned above) is not an option otherwise.

    Hope this helps :)
    rhapdog likes this.
    08-20-2015 02:44 PM
  7. Ball Park's Avatar
    Windows 10 changed the wonderful custom format of excel in windows 7 mmm-yy to a useless device. Before feb 13 showed as Feb 13 and was a great help. Now feb 13 yields Feb 15. The custom formats are separate from the date formats so why must windows 10 assume yy can only mean 15? Windows 10 only accepts 15 for yy: mar 07 gives Mar 15 etc. How many million people need to have a reliable way to enter dates in columns of financial records? My guess is at least as many British who prefer to use British date conventions.
    08-24-2015 02:44 AM
  8. Roving Press books's Avatar
    Thank you very much for the fix - it was driving me crazy!
    Took me a while to find the language download, as it was in 'Settings' rather than ' Control Panel'.
    11-04-2015 10:07 AM
  9. GHRobinson's Avatar
    Turn date format back to British usage
    11-06-2015 02:21 PM
  10. Uttoxeter's Avatar
    Thanks for the tip to make sure that the English ( United Kingdom) Language is set as default.
    I was having major issues using our Sage Accounts software - it really got confused with the limited date format options.
    12-15-2015 08:19 AM
  11. rossostu's Avatar
    how do i get my english date format back. This windows 10 is no good, Give me my windows 7 back
    03-15-2016 03:39 PM

Similar Threads

  1. Replies: 1
    Last Post: 01-28-2016, 01:59 PM
  2. AT&T Push of Windows 10 to L830
    By cre8tivspirit in forum Nokia Lumia 830
    Replies: 20
    Last Post: 09-01-2015, 02:48 AM
  3. Why doesn't my audio work after installing Windows 10?
    By Windows Central Question in forum Windows 10
    Replies: 2
    Last Post: 08-17-2015, 07:08 AM
  4. Replies: 1
    Last Post: 08-12-2015, 12:23 PM
  5. 'What's behind the Lenovo Y?' Videos tease us before the reveal on Sept. 2
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 08-12-2015, 12:11 PM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.