The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
09-26-2015 01:46 AM
54 123
tools
  1. Sakdichote Totiam's Avatar
    Change it back to PEG
    Have you gone through all the menus and sub menus of your BIOS ? (not just advanced bios settings, all of them) and check if there is an option to disable internal graphics ?
    Yes, I've gone through each and every one of them. Okay, back to PEG now.
    09-22-2015 07:45 AM
  2. Daniel Gilbert M's Avatar
    do not goto control panel and right click properties on 630

    could you post a screenshot of the window you get when

    right click on desktop
    display settings
    advanced display settings
    display adapter properties

    you will get a window similar to this
    amd.jpg
    09-22-2015 07:56 AM
  3. Sakdichote Totiam's Avatar
    do not goto control panel and right click properties on 630

    could you post a screenshot of the window you get when

    right click on desktop
    display settings
    advanced display settings
    display adapter properties

    you will get a window similar to this
    Click image for larger version. 

Name:	amd.jpg 
Views:	44 
Size:	57.7 KB 
ID:	112685
    It's the middle window, there. I posted it before, just saying.
    gpudetails.jpg
    Daniel Gilbert M likes this.
    09-22-2015 08:10 AM
  4. Sakdichote Totiam's Avatar
    wp_20150922_19_55_22_pro.jpg
    It should be in there right? Advanced BIOS Features, right? Well, I can't find it there, nor in Standard CMOS Features, nor in MB Intelligent Tweaker. PC Health Status has only temperature warning and fan settings, and Power Management Setup only has things like voltage settings, and whatnot.
    09-22-2015 08:32 AM
  5. Daniel Gilbert M's Avatar
    Ahh i didn't see the middle window before (seems like you edited and added it later)

    Anyways I think the GT-630 is taking up an extra 2GB from your RAM (that setting is managed by the OS) making it a total of 4GB of graphics memory (shared + dedicated).

    The video memory manager of Windows will give priority to putting things in dedicated video memory until you run out. After that it will use the shared memory. (this is decided by the OS).
    The reason it is called 'shared memory' is that it is available to either (RAM or GPU) , when they need it.

    I don't think you would be able to turn that off.


    Yup it should have been there inside that menu (BIOS).
    Sakdichote Totiam likes this.
    09-22-2015 08:59 AM
  6. Sakdichote Totiam's Avatar
    Thank you, though.
    Daniel Gilbert M likes this.
    09-22-2015 09:09 AM
  7. Krystianpants's Avatar
    If it's a pci graphics card you want it set to PCI anyways. chances are the motherboard may still have an hdmi port for intel graphics, or amd graphics in your case. Since you do have a shared memory card that is definitely the issue. Now you can disable shared memory in bios if there's an option. If not you can type msconfig in run or cortana and then go to boot, advanced options and see if maximum memory is checked. Not sure if unchecking will solve the issue as bios would take priority likely, just an idea. Usually it's unchecked.
    Sakdichote Totiam likes this.
    09-22-2015 01:17 PM
  8. pankaj981's Avatar
    Anyways I think the GT-630 is taking up an extra 2GB from your RAM (that setting is managed by the OS) making it a total of 4GB of graphics memory (shared + dedicated).
    This may not be completely right though the OS does reserve memory for other peripherals on the machine. A card that has 2GB dedicated memory won't consume 2GB of RAM memory from the OS. For example, I have a 1GB DDR3 GT520 on my desktop and even though the Direct X properties shows 1.6GB video memory, W10 System properties still shows 4GB available on a 4GB configuration. Another example would be the 3GB GTX670M on my MSI GT60, if I check the Direct X properties it shows about 5GB available for video but on W10 system properties, it does show 11.9GB available out of the total 12GB. 2GB memory consumption for a dedicated video card is kind of weird, not for on-board shared graphics though.
    09-22-2015 01:48 PM
  9. neo158's Avatar
    Some javascript elements on that site doesn't work on Edge, but if you try it on IE it will detect the correct OS type. It's an Edge problem.

    As for the usable RAM issue, again like others said some of it may be allocated to integrated video memory, which you can disable in the BIOS or set a lower allocation. Another issue could be that your motherboard OEM has not set Memory Mapping option enabled (very common in first releases BIOS), see if you could find this option in the BIOS. Also update your BIOS to the latest firmware possible, sometimes it adds options that aren't there before.

    Oh and for the Windows.old folder, that's just your previous Windows version before you upgraded to Windows 10 so it will allow you to roll back to that version if you wanted to. If you delete this folder it'll obviously delete that backup, and there's a proper way of deleting it via Disk Cleanup > Clean up system files.
    That's exactly what happened with me on that site. OP I went to that same website in Edge and it showed the exact same thing for me, I have a 64-bit version of Windows 10 but that site shows it as 32-bit so I wouldn't worry. As others have said you need to disable the on board graphics in the UEFI/BIOS and that will give you the full 6GB of RAM.

    The only other thing I can think of, I'm not saying you have done this, is that a PAE kernel hack has been applied to a 32-bit version of Windows 10 which may be the reason it thinks you have a 64-bit OS but only 4GB of usable memory.
    Daniel Gilbert M likes this.
    09-22-2015 04:32 PM
  10. Krystianpants's Avatar
    This may not be completely right though the OS does reserve memory for other peripherals on the machine. A card that has 2GB dedicated memory won't consume 2GB of RAM memory from the OS. For example, I have a 1GB DDR3 GT520 on my desktop and even though the Direct X properties shows 1.6GB video memory, W10 System properties still shows 4GB available on a 4GB configuration. Another example would be the 3GB GTX670M on my MSI GT60, if I check the Direct X properties it shows about 5GB available for video but on W10 system properties, it does show 11.9GB available out of the total 12GB. 2GB memory consumption for a dedicated video card is kind of weird, not for on-board shared graphics though.
    It is highly dependent on configuration. In scenarios where an extra stick of ram is used outside of the dual DIMM configuration, it is likely because it was added for additional shared memory. Remember memory runs more efficiently if both slots are paired correctly in a grouping. But since extra ram is provided in a single slot configuration it is likely to do it. And msconfig lets you change it. You can either set the amount of memory used manually and then make sure the boot is still set to "normal" instead of selective, or uncheck the maximum memory, though this may set it back if it's left out. I had this happen on an old laptop.
    09-23-2015 11:38 AM
  11. mijacs's Avatar
    The NVIDIA control panel should tell you.
    1. Open the NVIDIA control panel
    2. Click on system information (lower left)
    3. Scroll the details pane down to see the System video memory.
    My desktop shows 0MB if you are curious.
    Sakdichote Totiam likes this.
    09-23-2015 11:42 AM
  12. pankaj981's Avatar
    It is highly dependent on configuration. In scenarios where an extra stick of ram is used outside of the dual DIMM configuration, it is likely because it was added for additional shared memory. Remember memory runs more efficiently if both slots are paired correctly in a grouping. But since extra ram is provided in a single slot configuration it is likely to do it. And msconfig lets you change it. You can either set the amount of memory used manually and then make sure the boot is still set to "normal" instead of selective, or uncheck the maximum memory, though this may set it back if it's left out. I had this happen on an old laptop.
    Interesting, I didn't know the msconfig setting.
    09-23-2015 06:03 PM
  13. Krystianpants's Avatar
    Interesting, I didn't know the msconfig setting.
    1443098167928.jpg
    09-24-2015 07:37 AM
  14. Sakdichote Totiam's Avatar
    If it's a pci graphics card you want it set to PCI anyways. chances are the motherboard may still have an hdmi port for intel graphics, or amd graphics in your case. Since you do have a shared memory card that is definitely the issue. Now you can disable shared memory in bios if there's an option. If not you can type msconfig in run or cortana and then go to boot, advanced options and see if maximum memory is checked. Not sure if unchecking will solve the issue as bios would take priority likely, just an idea. Usually it's unchecked.
    It is unchecked. The problem still persists.

    You can either set the amount of memory used manually and then make sure the boot is still set to "normal" instead of selective, or uncheck the maximum memory, though this may set it back if it's left out. I had this happen on an old laptop.
    It was set to selective, I'm changing it to normal now. *Update: just did that, nothing changed.

    The NVIDIA control panel should tell you.
    1. Open the NVIDIA control panel
    2. Click on system information (lower left)
    3. Scroll the details pane down to see the System video memory.
    My desktop shows 0MB if you are curious.
    It looks like this. That total available graphics memory though.
    nvctrlpanel.jpg
    Last edited by Sakdichote Totiam; 09-24-2015 at 09:37 AM.
    09-24-2015 09:20 AM
  15. Sakdichote Totiam's Avatar
    I'm going to try out Q-Flash now and I'll see if the option to configure internal graphics, or memory will show up in the BIOS configuration, and if not, then I guess I'll be clean installing the OS pretty soon. As before I reset the PC, the RAM was actually available for use for the whole 6 GB. My thanks to everyone for your eager display of kind spirits!
    09-24-2015 09:44 AM
  16. Krystianpants's Avatar
    SAkidichote, check it and put in your 6 gigs, but make sure after changing that the main page says "normal" for boot start up as it may change it to selective.
    Sakdichote Totiam likes this.
    09-24-2015 10:16 AM
  17. alb3530's Avatar
    I'm going to try out Q-Flash now and I'll see if the option to configure internal graphics, or memory will show up in the BIOS configuration, and if not, then I guess I'll be clean installing the OS pretty soon. As before I reset the PC, the RAM was actually available for use for the whole 6 GB. My thanks to everyone for your eager display of kind spirits!
    Just out of curiosity, could you please post screenshots of your:

    Windows Task Manager "Performance" tab when in "Memory" graphs

    CPU-Z's Memory tab

    CPU-Z's SPD tab (for each slot)

    (CPU-Z is a well-known third part utility)
    Also, how is your memory physically distributed (slots, sizes, etc...)



    Best regards
    09-24-2015 11:13 AM
  18. pankaj981's Avatar
    Click image for larger version. 

Name:	1443098167928.jpg 
Views:	25 
Size:	49.3 KB 
ID:	112827
    Isn't that setting only to configure startup memory consumption? As in the OS still uses the entire memory after booting up.
    09-24-2015 11:49 AM
  19. Krystianpants's Avatar
    Isn't that setting only to configure startup memory consumption? As in the OS still uses the entire memory after booting up.
    Nah it's the full thing. Typically windows will detect it correctly. Found a nice tutorial online for the Original poster.

    Set Maximum Amount of Memory Usable by Windows -
    Sakdichote Totiam likes this.
    09-24-2015 12:35 PM
  20. Sakdichote Totiam's Avatar
    I download the latest bios update from the manufacturer's site, I'm certain that I chose the correct model, which was A55M-DS2. I then extracted into a USB Flash drive, and restarted the PC to try Q-Flash in the BIOS, What I got was "BIOS ID check error." So that is no longer an option, at least for now.


    Just out of curiosity, could you please post screenshots of your:

    Windows Task Manager "Performance" tab when in "Memory" graphs

    CPU-Z's Memory tab

    CPU-Z's SPD tab (for each slot)
    Okay, here.
    cpuz.jpgtaskman.jpg
    09-24-2015 12:56 PM
  21. Sakdichote Totiam's Avatar
    So, from those screenshots, I take it I misremembered that I had 6 GB of RAM installed when actually it was 8 all alongwow this makes it even worse now that it should've displayed 8 GB, instead it displayed 6 GB, and to add salt to injury only 4 GB is available.

    Now I truly think that it's finally the time I consider clean re-installing Windows. Do you guys agree? Yes, I'm asking. I'm hesitant.
    09-24-2015 01:12 PM
  22. alb3530's Avatar
    So, from those screenshots, I take it I misremembered that I had 6 GB of RAM installed when actually it was 8 all along—wow this makes it even worse now that it should've displayed 8 GB, instead it displayed 6 GB, and to add salt to injury only 4 GB is available.
    Correct, CPU-Z is detecting your memory as 2 x 4GB modules, what should give you 8GB available.This indicates you have 2 physical 4GB modules installed.

    Now I truly think that it's finally the time I consider clean re-installing Windows. Do you guys agree? Yes, I'm asking. I'm hesitant.
    Simple test before reinstalling (what I think would NOT work): start the machine from installation media, and instead clicking on install windows, click "repair computer"

    Then, "Troubleshoot" > "Advanced Options" > "Command Prompt"

    Type:

    taskmgr

    and press enter.

    It should open a "legacy" task manager (Windows 7-like), and you can find the available memory (in Mega Bytes) from there.

    capture.png

    That is, if your BIOS can't show the installed RAM (what most BIOSes can do)

    Have you tried typical troubleshooting steps to fix RAM issues, like exchanging memory modules between slots, test modules individually or cleaning contacts?


    Best regards
    09-24-2015 01:30 PM
  23. Sakdichote Totiam's Avatar
    Simple test before reinstalling (what I think would NOT work): start the machine from installation media, and instead clicking on install windows, click "repair computer"
    I, too, do not think that this will work you know, it's not like I messed around the system files so to restore, but for your peace of mind, I am willing to try.

    Have you tried typical troubleshooting steps to fix RAM issues, like exchanging memory modules between slots, test modules individually or cleaning contacts?
    I'll try switching, and I'll also try a rubber, before the above method, of course.
    09-25-2015 02:50 AM
  24. Daniel Gilbert M's Avatar
    Have you tried changing memory configuration settings in advanced chipset features in BIOS ? ..
    I think you need to have bank interleaving and channel interleaving enabled.
    And there is one more option called DCT mode which needs to be set in ganged mode or unganged mode (try booting up with both).
    09-25-2015 04:14 AM
  25. Sakdichote Totiam's Avatar
    Have you tried changing memory configuration settings in advanced chipset features in BIOS ? ..
    I think you need to have bank interleaving and channel interleaving enabled.
    And there is one more option called DCT mode which needs to be set in ganged mode or unganged mode (try booting up with both).
    There's no options for memory configuration in my BIOS menu.
    09-25-2015 04:26 AM
54 123

Similar Threads

  1. Is there any chances that CLASH OF CLAN will comes to windows phone ?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 09-21-2015, 04:57 AM
  2. Replies: 1
    Last Post: 09-21-2015, 04:54 AM
  3. Having trouble with Skype? Microsoft is aware and working on the issue
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-21-2015, 04:30 AM
  4. Replies: 1
    Last Post: 09-21-2015, 03:59 AM
  5. Why am I not able to send messages?
    By Sengrik Sangma in forum Ask a Question
    Replies: 0
    Last Post: 09-21-2015, 03:31 AM
LINK TO POST COPIED TO CLIPBOARD