1. wapoz's Avatar
    Was working perfectly before I had to exchange the 2520 it was attached to for other issues. Now it no longer charges, or registers with My brothers 2520 or my own. Searched bing/google but found no answers or similar problems. Suggestions?
    02-26-2014 12:03 PM
  2. EzraWard's Avatar
    At the risk of sounding silly, have you turned on the sound of the tablet, and then attached and re-attached the tablet several times to see if it's connecting? You can even wiggle the tablet a little when it's clicked in. I've had problems where the connectors weren't lined up. I know what I said was extremely basic, but I guess this is a start.
    02-27-2014 02:04 PM
  3. wapoz's Avatar
    Tried everything short of doing a full refresh on both my brothers and my own tablet. It just no longer registers with either tablet. I gave up and returned it yesterday evening, since it was still within 14 days. Looking back, I think it may have been some sort of power surge issue that fried the keyboard , since I had to exchange his tablet out the day before due to the power button and accelerometer no longer working.
    02-27-2014 02:17 PM
  4. meathead88's Avatar
    So I received my keyboard yesterday which is great buy I can't get its battery to charge. The tablet battery is at 100% and the keyboard's remains at 54% and always says (not charging).
    03-09-2014 09:37 AM
  5. meathead88's Avatar
    So I received my keyboard yesterday which is great buy I can't get its battery to charge. The tablet battery is at 100% and the keyboard's remains at 54% and always says (not charging).
    I read some other threads about how picky the connection is between the keyboard and tablet. I reseated the table a couple times now it works :)
    I do have a skinomi skin on it that I'm removing now. That 1/10 mm must make a difference:(
    03-09-2014 10:30 AM
  6. RJ2001's Avatar
    Went searching for a solution for this today and ran across this for the Surface 2, seems to also work fine for the Lumia powered keyboard. How to Fix Surface Pro 2 “Plugged In, Not Charging” Error

    Instead of shutting down I did this while in desktop mode (thought it would do a hard reset ), instead the Power down option comes up, I held it for about 30 more seconds after that, when I let go I heard the disconnect and reconnect of the keyboard. When I pushed the power screen up so it wouldn't shutdown I noticed the battery icon in the task bar was a dark grey color and after clicking on it both the keyboard and tablet batteries said 0% and not charging. I then disconnected the power cable and plugged it back in, my tablet was already 100% charged so the keyboard immediately started charging.

    About 1 minute after I began typing a response to you when I noticed the battery again said plugged in but not charging. So I canceled my post, walked away and when I came back I noticed the battery icon was changing as if something was charging. To my surprise the status changed to "plugged in, charging" and the Keyboard battery went from 15% (where its been since yesterday) to now 36%. Just now again while typing (I think it doesn't like me typing this :smile ), it stopped charging again, disconnected and reconnected the charging cable and it went back to charging.

    I have three of these keyboards so later I'll try one of the others to see if its just this one, would be sad though since this is my second one and its only 2 weeks old today. The last one the guides that keep the tablets in place broke out (they are plastic, yeah) and one of the pins the spring stopped working so it doesn't connect to the tablet's connector, so half the keyboard doesn't work. I wonder if the 12 month warranty on these covers all these issues.

    P.S. been 10 minutes since I started to retype this and its still charging, at 51% now.
    03-16-2014 12:05 PM
  7. mfleszar's Avatar
    My power keyboard shipped with some battery life. However, after accidentally fully draining both batteries I had the same issue: "Battery #2: 0% available (plugged in, not charging". The fix kindly described by RJ2001 worked for me! With the tablet plugged in and in the keyboard dock, I held down power and volume-up for about 15 seconds. Upon releasing the buttons the keyboard noise was heard and the battery symbol in the system tray goes gray. I let the tablet sit for a few minutes, and the icon was still grey. I then unplugged the power and replugged the power. After again letting the computer sit for a little while, the power keyboard battery will start to charge. Note: I had to do this about 3 times to get it to work...if you hold the power button down for too long the tablet will simply turn off.

    I'd been looking for a fix to this for several weeks. Thanks for the help!
    03-28-2014 01:35 PM
  8. Andrew Green1's Avatar
    I have the same problem on my 2520 and can't fix it. The only thing that happens when I press the power and volume button is that it turns off. There is no "keyboard noise" - I don't know what that's meant to be, is it the docking/undocking noise?
    12-13-2014 06:44 AM
  9. Rodelion's Avatar
    I had this problem, and tried many things... then I found this, which was an instant fix:

    1. Connect charger on the keyboard unit with the computer on, and the keyboard attached.
    2. Undock the keyboard ("Safely remove hardware and eject media" > "Eject docking station", on my machine). Physically undock as well :)
    3. Remove charger from keyboard.
    4 Re-attach the charger to the keyboard.
    5. Dock the screen.

    Pretty good chance that for some of you this will work, and the keyboard is now charging. Good luck!
    01-25-2015 11:33 AM
  10. grazy1982's Avatar
    This appears to be quite an old thread but mines been doing this for a while. But it actually says charging but stays at 0%. To get it to dock I sometimes have to wet the pins otherwise it doesn't recognise it

    Any suggestions?
    10-30-2015 01:34 PM
  11. cobyna's Avatar
    My Nokia power key board is having the same issue. I have two keyboards and both have the same issue. No responsiveness . I just tried the two finger solution described above and not the battery on the keyboard is at least charging. I will it go here and see how this goes. Still no docking or undocking noises.
    11-04-2015 04:01 PM
  12. Superhessu's Avatar

    Tried all the previous suggestions for fix, but with no luck.
    But then I thought of something else.
    I had also the problem that the keyboard was not regocnized by the device. For that problem there were instructions somewhere that remove the keyboard driver, then after reboot connect it again to the device. That worked for me for the keyboard, but still the battery was not charging. It was available, but not charging.
    Then I noticed that there are two battery drivers in the device manager called "Microsoft ACPI-Compliant Control Method Battery". One of these you could not remove, but the other one was removable. So I disconnected the powerkeyboard, then uninstalled one the battery drivers, booted the device and then connected the powerkeyboard.
    And yes, finally both the keyboard is working and also the powerkeyboard battery is charging.
    Maybe this could help you also, if you have the powerkeyboard battery available, but not charging.
    03-05-2016 01:52 AM
  13. Ross Hilton's Avatar
    This isnt a Nokia problem, nor is it a battery problem.

    Its a Microsoft driver issue.

    The APCI Control Method Battery Driver supplied by Microsoft for Windows RT is dated June 2006 (63 9600 16384). It predates Windows RT.

    (The Windows 10 driver is dated November 2015. I have not tried to migrate this driver...)

    The problem with this old driver is it requires "some" charge in the battery to "see" it. And it wont charge unless it "sees" it. If you let the keyboard go flat, it refuses to charge. This is a common problem with battery management drivers - look up the Acer 1 problem as an example.

    The battery management software reports empty when there is still sufficient charge to be recognised, allowing it to be recharged. But if, as many people do, they leave the keyboard off in an uncharged state for lengthy periods of time, this residual charge will be lost. If the battery completely empties - it will not recharge.

    So why do these quick fixes work?

    Repeatedly getting the driver to "look" for the battery actually puts a little charge in it each time. This builds up until the battery has sufficient charge to be seen.

    Another brutal option would be to force charge the recalcitrant battery in some way, but I would advise against it.
    Alaa Shalaby likes this.
    06-28-2016 09:10 PM
  14. Alaa Shalaby's Avatar
    How I can recharge it again.., to make it seen again
    07-07-2016 11:02 PM
  15. RJ2001's Avatar
    I no longer have my 2520, but before I traded it in I found opening the keyboard and pulling oy the two internal connectors and pushing them back in did the trick every time. Make sur the cables are flat and fully pushed in. Also check out my earlier post that should help too.
    08-09-2016 07:59 PM
  16. anon(10043517)'s Avatar
    My first keyboard charged ok, but the tablet stopped recognising it as a USB device after about 9 months. Tried all the known suggestions for fixing this issue but eventually bought a new one (when you still could!). Few years later, the replacement one has stopped charging, tried all the advice on this thread to no avail and in a moment of inspiration, remembered the original one was in the attic. Swapped the batteries over, and despite years of inactivity, it was recognised and started charging immediately.
    02-06-2017 12:24 PM
  17. negative1ne's Avatar
    well, i thought my first one died out. so i bought another one.

    turns out, just re-installing the drivers seems to fix the issue. so now i have 2 power covers.

    it's still a little flaky on charging, but hey it works.

    (by the way, this is for a surface pro 1)

    02-14-2017 05:14 PM
  18. Treesa2022's Avatar
    Easy fix and very common for this keyboard. Open the back starting around side with usb plugs...small flat screwdriver. You will see larger black flex cable taped down right side...remove tape...and unlock the cable by releasing the two white clips on either side of cable. Remove and the put it back in...and lock it by closing the white clips. Retape if you want to secure. You can put the tablet back in while back is off to make sure it works.
    08-26-2017 10:11 PM
  19. steka's Avatar
    I had this problem for years - until tonight! I thought it was time to win or loose this contest forever! So, I ripped off the back of the keyboard (according to previous description above) and removed the battery. I started a power supply, set it to 7.4 VDC and limit the current to about 0.5 A. Then I removed - gently - the middle plastic lid of the battery (cutting some tape etc.). Here beneath is found four battery pads where I connected + and - from the power supply to two of these pads. I connected - to the pad that is shorted to the black connector wires, and + to the opposite diagonally placed pad. The two other is just shorted in between to make a series connection of the two batteries. I let the charge of the batteries proceed until I could read about 6 V across the batteries. Now I reconnected the battery to the keyboard, and - Viola - the 2nd battery was finally taking charge! Still showing 0%, but anyway "Charging". After a while the % started to increase and all seemed being solved! Just a tip if trying this, when refitting the battery, just check that all flat cables are fitted in their respectively connector. Do this by pushing some keys and swipe the mouse pad and find there's any response before putting the keyboard back on again. It's just so irritating to be forced to remove the back once again...
    So, as someone above described, it really seems like the Windows driver for the battery don't let the 2nd battery be charged if it's drained too much!

    03-07-2018 06:27 PM
  20. ClairelyClaire's Avatar
    Do you know if a higher voltage would be safe to use? Does the dock only draw ~7.5V from the tablet?
    04-20-2018 05:45 PM

Similar Threads

  1. Charge your phone wirelessly with the Nokia DT-910, available on Amazon for 33.95
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 2
    Last Post: 03-08-2014, 04:57 PM
  2. Charge Port Wear
    By Tom Gjonaj in forum Windows Phones
    Replies: 8
    Last Post: 02-27-2014, 12:16 PM
  3. Wireless Charging Issue Fixed! (I Think)
    By tallarob in forum Windows Phones
    Replies: 3
    Last Post: 02-26-2014, 08:17 PM
  4. DT-900 and DT901 Charging Observation
    By primortal in forum Windows Phones
    Replies: 4
    Last Post: 02-26-2014, 03:02 PM