1. Rafael Yousuf's Avatar
    Hi, i had a problem with my phone that i had to hard reset it. Now when it starts it asks me to sign in to my microsoft account i tap on it and it says failed to connect, try again. I have connected my phone to my Wi-Fi network and this still keeps coming up. I ended up pressing skip thinking that after the phone starts i will be able to sign in to my account from "Settings -> Accounts". So that worked and i signed in but it asked me to backup not to restore my prev. data.

    Is there a way to force my phone to restore from the prev. backup because i don't want to go over the trouble of setting it up the way it was
    08-03-2014 06:15 AM
  2. BRC1711's Avatar
    I had the same problem I had to restore it with mobile data.

    Posted via Windows Phone Central App
    08-03-2014 06:28 AM
  3. Rafael Yousuf's Avatar
    Tried that didn't work, but after 6 hard resets it finally worked.
    TIP: DO NOT TURN OFF WIFI SENSE WHEN FIRST SETTING YOUR PHONE
    08-03-2014 06:42 AM

Similar Threads

  1. Have to force 4g
    By trekgraham in forum Carrier Discussion Lounge
    Replies: 2
    Last Post: 08-03-2014, 10:52 AM
  2. Cyan TMO for unlocked 1520?
    By Byrese in forum Nokia Lumia 1520
    Replies: 4
    Last Post: 08-03-2014, 10:36 AM
  3. Getting Error(8018830f) while updating CYAN in 625
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-03-2014, 04:26 AM
  4. Stuck in downgrading wp8.1 to wp8
    By Ahmad Fauzan Rustan in forum Ask a Question
    Replies: 4
    Last Post: 08-03-2014, 02:09 AM
LINK TO POST COPIED TO CLIPBOARD