1. jojoe42's Avatar
    Sometimes when I click on an album or song to play in the default music+videos app, it will skip the song and say "sorry, we cannot play this file on your phone", yet when I dismiss the message and press play, it will play!! Songs are in WMA Lossless, and I've been using MPATool to fill in missing album artwork if it makes a difference.
    xandros9 likes this.
    03-13-2014 03:28 AM
  2. Laura Knotek's Avatar
    That's really odd. Does it happen with the same songs all the time, or is it totally random?
    03-13-2014 03:39 AM
  3. SagarSadbhaiya's Avatar
    its random.. happens with me also sometimes...
    03-13-2014 06:50 AM
  4. xandros9's Avatar
    Same, most of my collection is MP3, so I dont think format matters
    03-13-2014 07:17 AM
  5. jojoe42's Avatar
    That's really odd. Does it happen with the same songs all the time, or is it totally random?
    Totally random. One day it's Dire Straits the other it's The Strokes
    xandros9 likes this.
    03-13-2014 01:46 PM
  6. Muessig's Avatar
    I've not experienced this, what are you using to sync your music over?
    03-13-2014 02:07 PM
  7. radmanvr's Avatar
    I have experienced this. What I have done is just restart the song again
    jojoe42 likes this.
    03-13-2014 02:10 PM
  8. Christian Holmstedt's Avatar
    its random.. happens with me also sometimes...
    Same here when playing files stored on the phone.
    03-13-2014 02:39 PM
  9. xandros9's Avatar
    I've not experienced this, what are you using to sync your music over?
    I just copied my music with Explorer, no syncing software

    I have experienced this. What I have done is just restart the song again
    yup, i just close the dialog and go back, then voila

    i thought it was some DRM glitch or something, but I don't really know
    03-13-2014 02:41 PM
  10. extrikate's Avatar
    Sometimes when I click on an album or song to play in the default music+videos app, it will skip the song and say "sorry, we cannot play this file on your phone", yet when I dismiss the message and press play, it will play!! Songs are in WMA Lossless, and I've been using MPATool to fill in missing album artwork if it makes a difference.
    I had this problem with about 50 songs from my library. After talking to MS support, we found the problem. All of the songs having issues were WMA w/ DRM that were purchased through the Zune marketplace. Normally, these files would have been updated when the DRM for Zune was changed but the problem was I purchased them under an account that was merged into my current account. Since the old account no longer existed, the files couldn't update the license info. MS issued me a store credit to repurchase the affected files.
    03-13-2014 09:03 PM
  11. jojoe42's Avatar
    I had this problem with about 50 songs from my library. After talking to MS support, we found the problem. All of the songs having issues were WMA w/ DRM that were purchased through the Zune marketplace. Normally, these files would have been updated when the DRM for Zune was changed but the problem was I purchased them under an account that was merged into my current account. Since the old account no longer existed, the files couldn't update the license info. MS issued me a store credit to repurchase the affected files.
    All my songs have been taken off CDs ripped through iTunes, and also songs from the iTunes store (and don't have copyright protection on them, yeah I'm an apple convert) - never bought anything off the store yet
    03-13-2014 09:46 PM
  12. jojoe42's Avatar
    I've not experienced this, what are you using to sync your music over?
    I'm using the Windows Phone App on Windows 7 mainly, but occasionally I'll directly copy in a song or two through Windows Explorer
    03-13-2014 09:47 PM
  13. extrikate's Avatar
    Also, music purchased through iTunes prior to the DRM change in late 2009 were specifically encoded to only play on Apple devices. Depending on how you are converting them, they may retain the encoded protection.
    03-13-2014 10:41 PM
  14. James8561's Avatar
    happens to me as well. I have files in mp3 and m4a formats from iTunes, Amazon, and other sources. seem to happen randomly now and then. definitely OS bug as this only happens in update 3.
    03-14-2014 12:33 AM
  15. Guzzler3's Avatar
    Ran into this issue a couple of times myself. I was able to determine that the meta data in the MP3's were causing the issue.

    How I fixed it, was to use MP3Tag, and Windows Media Player to rewrite the meta data.
    This was for MP3's only!!! As I don't have any other formats.

    First I used MP3Tag to update as much of my meta data on my files as accurately as possible on my computer. Then used Windows Media Player, Tools, Options, Library, "Automatic media information updates for files, Retrieve additional information from the Internet, Overwrite all media information" selected. Then let it go do it's thing (it may take several hours).

    I then deleted all the MP3's off my phone, then copied things back from my computer to the phone. This fixed two issues, "sorry, we cannot play this file on your phone", and duplication.

    Now, I do recommend that you backup your music collection before letting Windows Media Player do it's thing, as you may not like the new meta data it puts in. You can always go back, with the backups.
    03-14-2014 10:54 AM
  16. Teja Swaroop1's Avatar
    Hi,
    I too faced the same problem and I searched many websites for the solution but couldn't find any, but today, when I opened my playlist, it started working...and not only the playlist, all the songs in the library also started working.
    I think the music player got stuck at the playlist. So, try opening your playlist once and then try the other songs. You should get it as I've got now. :)
    Harrie-S likes this.
    02-08-2015 11:54 PM
  17. agd87's Avatar
    its random.. happens with me also sometimes...
    Me too.
    03-01-2015 11:27 AM

Similar Threads

  1. using windows phone on ubuntu pc
    By anoop s in forum Windows Phone 8
    Replies: 4
    Last Post: 10-04-2014, 11:17 AM
  2. Phone won't sync all Gmail contacts
    By lathamc in forum Windows Phone 8
    Replies: 3
    Last Post: 04-02-2014, 12:47 AM
  3. I Receive an SD Card error Everytime I turn my phone On...
    By WINDOW LOVIN in forum Windows Phone 8
    Replies: 11
    Last Post: 03-19-2014, 02:37 PM
  4. Next WhatsApp update on Windows Phone will also bring individual backgrounds for contacts
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 4
    Last Post: 03-19-2014, 09:57 AM
  5. Certain Songs Unavailable?
    By Dex Da Rex in forum Groove Music
    Replies: 1
    Last Post: 03-18-2014, 06:13 PM
LINK TO POST COPIED TO CLIPBOARD