1. ghyjh's Avatar
    Hi,
    Yesterday my phone stopped charging, after getting very hot. Now when I plug it into a charger, it flashes the O2 screen, then the battery depleted logo (without the charging icon) and turns off.
    I have tried multiple wall chargers and none seem to work, if I leave it plugged in, it doesn't charge just gets hot again. Is there a solution to this?
    Thanks

    Joe
    10-22-2013 04:31 AM
  2. constantinosmi's Avatar
    Is this the logo you get when you plug it in?
    185116failed2.jpg
    10-22-2013 04:54 AM
  3. ashokparchuri's Avatar
    I am having the same problem. When I connect the charger it just flashes the red battery screen.
    10-30-2013 02:44 PM
  4. Pulserider's Avatar
    Hi,
    Yesterday my phone stopped charging, after getting very hot. Now when I plug it into a charger, it flashes the O2 screen, then the battery depleted logo (without the charging icon) and turns off.
    I have tried multiple wall chargers and none seem to work, if I leave it plugged in, it doesn't charge just gets hot again. Is there a solution to this?
    Thanks

    Joe

    Did you remove the battery and insert it again?
    11-01-2013 07:07 AM

Similar Threads

  1. Mic and Remote Skip Headphone Adapter for Nokia
    By lolakr in forum Other Operating Systems
    Replies: 2
    Last Post: 12-08-2013, 09:00 AM
  2. charging not connecting
    By Ovais Amin in forum Windows Central Archive
    Replies: 1
    Last Post: 12-07-2013, 05:48 PM
  3. MS Office and subfolder issue
    By Optiplex330 in forum Windows Apps
    Replies: 3
    Last Post: 11-02-2013, 04:32 AM
  4. I just got my Surface/pro 2 and I ... (fill in the blank)
    By Great deal in forum Microsoft Surface Pro
    Replies: 66
    Last Post: 11-01-2013, 09:26 AM
  5. Help with Live Tile and Facebook
    By cristianocr7 in forum Other Operating Systems
    Replies: 2
    Last Post: 10-21-2013, 06:59 PM
LINK TO POST COPIED TO CLIPBOARD