1. soul347's Avatar
    Hi everyone,

    To go straight to the point, my Lumia 920 after just a few months of use had this problem where opening almost anything such as settings, messaging, phone calls, etc. would bring me to a screen that says "loading...", then would just kick me back to the start menu, making the phone useless and unusable. I've tried doing a soft reset as well as a hard reset several times (via button combo) since I couldn't do it through settings. The problem still persists.

    Now here is what puzzled me further: I was able to flash my phone to the old Amber firmware that I found online, and everything worked flawlessly, but as soon as I updated my phone via settings to Lumia Black, the same old problem came back.

    Any possible solutions would be greatly appreciated!
    06-26-2014 08:02 AM
  2. soul347's Avatar
    Any takers?
    06-27-2014 04:20 PM
  3. xandros9's Avatar
    Huh, have you tried flashing and updating another ROM?
    06-27-2014 05:21 PM
  4. Derausgewanderte's Avatar
    that is perplexing. Have you tried to upgrade to 8.1 Dev Preview? I am afraid another ROM will get you to the same result since you already flashed back.
    I'd contact Nokia
    06-27-2014 06:05 PM
  5. MDK22's Avatar
    You may have a rogue app in there - suspects w/b the last couple (5) apps you downloaded.
    06-27-2014 06:19 PM
  6. soul347's Avatar
    that is perplexing. Have you tried to upgrade to 8.1 Dev Preview? I am afraid another ROM will get you to the same result since you already flashed back.
    I'd contact Nokia
    I did try to update to the 8.1 preview straight from Amber, but it turns out it won't let me go to 8.1 unless I first go to Lumia Black! I wonder if there is a way to bypass it and go straight or flash straight to 8.1? I could try contacting Nokia, but I fear I will be charged even more than what the phone is worth since I'm out of warranty.

    @MDK22 - It is a clean flash. There are practically no apps on it and I didn't install anything.
    Derausgewanderte likes this.
    06-27-2014 07:28 PM
  7. Derausgewanderte's Avatar
    unfortunately, there is no ROM yet for 8.1. Only way is to update via Preview for Developers app....
    sorry, out of ideas. Good luck. Sounds like a flash memory issue. As a last resort I'd take it apart, check all the cables and connections and put it back together. Sometimes these things may work (even though you will never know why it actually started working again ;) ).
    06-27-2014 08:01 PM

Similar Threads

  1. Lumia 820 Problems
    By rohit111 in forum Ask a Question
    Replies: 4
    Last Post: 07-10-2014, 12:41 PM
  2. Twitter App problem, help!
    By SoullessOnyx in forum Other Operating Systems
    Replies: 2
    Last Post: 06-26-2014, 07:14 AM
  3. what is next in sequence for lumia 930?
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 06-26-2014, 06:34 AM
  4. unlocking at & t nokia lumia 920
    By secman91 in forum Ask a Question
    Replies: 2
    Last Post: 06-26-2014, 06:30 AM
  5. Store issue in Lumia 720
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 06-26-2014, 02:18 AM
LINK TO POST COPIED TO CLIPBOARD