1. ricrocks12's Avatar
    Is there any reason certain apps give me network error (TubeCast) while others also seem slow over Wi-Fi when I'm holding my Lumia 640, yet apps start working once I lay it on a flat surface?
    08-11-2015 09:54 PM
  2. vipme's Avatar
    yes, there is, noise in signal depends on wave propagation plane
    change the position of your wi-fi antenna from horizontal to vertical, or some other angle you find better, or u might be having up to 40% noise in signal
    libra89 likes this.
    08-11-2015 10:13 PM
  3. Rooks308's Avatar
    I'm having similar issues, but it isn't related to being on a flat surface. I am going to start another thread on this topic in a moment but I found that by turning off bluetooth my wifi speeds are 27.82 mbps and with bluetooth on are 1.8 mbps.

    I already turned off Wifi Calling on T-Mobile because that ALSO kills wifi speed on this phone. I'm starting to wonder if the phone internals were not designed well or if I just have a dud.
    08-16-2015 06:31 PM
  4. etad putta's Avatar
    ATT 640 here. About the same speeds with bluetooth on or off. Roughly 15 to 17 mbps flat or upright.
    Guytronic likes this.
    08-16-2015 08:23 PM
  5. Diamond67's Avatar
    When my Lumia 640 wlan is activated and the phone is connected to my wlan router, the devices normally handshake at the speed of 72.2 Mbps, which gives you download speed almost approx. 50 Mbps when you test it with Speedtest app.

    Just tested the download speed with bluetooth activated as well. Maybe there is a tiny drop, but not very much. Download speed is 40+ Mbps.
    08-20-2015 01:21 PM
  6. Rooks308's Avatar
    This makes me wonder. Could you check something for me? When you have bluetooth on does your phone connect to anything?

    Two things happen when I have bluetooth on. It automatically connects to my Misfit Flash (which the Windows App doesn't even support yet) and I lose the keyboard completely. I cannot get the keyboard back unless I disable bluetooth.

    So I'm wondering if the folks with no issues have their phones connected to anything via bluetooth or if it is on, but not connected. That might help me (and hopefully Microsoft if anybody is watching) figure this out.
    08-21-2015 08:54 AM

Similar Threads

  1. Just saw this review of the 640 xl
    By Grimwar in forum Windows Phones
    Replies: 2
    Last Post: 08-20-2015, 12:40 PM
  2. Replies: 4
    Last Post: 08-16-2015, 04:25 PM
  3. My Nokia Lumia 635 Bricked While Using Windows 10 Preview?
    By Windows Central Question in forum Windows Phones
    Replies: 1
    Last Post: 08-11-2015, 10:28 PM
  4. Why won't my Lumia 640 XL pair with my car's Bluetooth?
    By Windows Central Question in forum Windows Phones
    Replies: 0
    Last Post: 08-11-2015, 07:50 PM
  5. Why won't Windows 10 let my laptop find my wifi?
    By WPCentral Question in forum Windows 10
    Replies: 1
    Last Post: 08-11-2015, 07:50 PM
LINK TO POST COPIED TO CLIPBOARD