1. Arlan Henry's Avatar
    My Lumia 1520 will barely be recognized by my laptop. If it registers, it'll be for a second and then driver errors. MTP USB device always gives problems, and troubleshooting no longer resolves the issue.

    I have tried uninstalling from the device manager and reinstalling, troubleshooting through devices and printers etc.. No resolution. I have downloaded drivers from online, no dice. Using different USB ports, different cables, and different machines yield the same result.

    Any suggestions?

    Any advice?
    Rosebank likes this.
    09-28-2015 03:30 AM
  2. Vic Nair's Avatar
    Had the same issue the other day, just reinstall the same driver using files available in the computer, select the certificate available and voila; you are good to go.
    09-28-2015 04:12 AM
  3. RumoredNow's Avatar
    I use this tool to delete the USB driver: View any installed/connected USB device on your system

    Wipe out anything marked Nokia or Lumia and when you plug the phone in next it installs a fresh set of drivers.
    Arlan Henry likes this.
    09-28-2015 07:01 PM
  4. Arlan Henry's Avatar
    Thanks. I'll check this out and see if I works.
    10-01-2015 01:53 PM
  5. Arlan Henry's Avatar
    I followed your instructions, uninstalled everything labelled "Nokia" or "Lumia" as well as all the other devices which weren't currently connected. I turned the phone off, then plugged it in to the PC.




    10-01-2015 03:41 PM
  6. RumoredNow's Avatar
    You may have a bad port. Seek a qualified tech to assess this.

    10-03-2015 10:50 PM
  7. Arlan Henry's Avatar
    Finally worked (momentarily) on another device.
    10-23-2015 09:56 PM
  8. scotsmantom's Avatar
    I have a 1520 which works fine but my 1020 had same prob and i tried EVERYTHING. Finally took it to my Nokia approved repairer who in 24 hrs put a new "back" on with new USB port and its fine again. But not going to go back to WM 10 builds yet until Steve Litchfield says it's ready.
    RumoredNow likes this.
    10-24-2015 01:39 AM
  9. Arlan Henry's Avatar
    Thanks for the insight.
    10-24-2015 09:37 AM
  10. Arlan Henry's Avatar
    I finally pinpointed the issue. If the sd card is removed from the phone, this issue resolves itself.

    Soon as I put the SD card into the phone, all of a sudden Instead of the the name of my Lumia appearing under Portable Devices, the name switches to MTP USB device and then the error presents itself.

    I'm using a Samsung 128GB micro SD card and I've noticed that above 70GB capacity, it gets corrupted (usually around the 80GB mark). Scanning for errors or running chkdsk /f removes approx 10GB of corruption bringing me back down to the 70GB neighbourhood.

    But the phone is recognized with the memory card by my other system and I'm able to sideload apps etc.

    This is frustrating.
    12-14-2015 11:09 PM
  11. Rosebank's Avatar
    I am having this issue but removing the sd card does not work for me, ??
    10-12-2016 09:10 AM

Similar Threads

  1. Thinkig about getting The Surface 2 just a few questions please
    By miguel11691 in forum Microsoft Surface Laptop
    Replies: 4
    Last Post: 10-05-2015, 04:51 PM
  2. Is it useful to update the windows 10 download tool?
    By Fidodido1966 in forum Windows 10
    Replies: 3
    Last Post: 09-29-2015, 07:14 AM
  3. Replies: 0
    Last Post: 09-28-2015, 03:25 AM
  4. Surface Pro 3 gets discounted in the UK again
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 09-28-2015, 03:11 AM