1. Sedp23's Avatar
    Just bought a unlocked 640 XL from the Microsoft store. Just had a quick question because my tmobile 640 never did this

    I bought the 640 XL RM -1064 model unlocked

    When using data while on a phone call on the XL on tmobile I notice the signal drops to HSPA+ or even 3G.

    Is this normal? My 640 always stayed on LTE during phone calls if I was using my data. The

    voice calls still say HD on the phone dialer

    Everything else seems to be working as usual.
    05-14-2016 05:50 AM
  2. Chintan Gohel's Avatar
    Just bought a unlocked 640 XL from the Microsoft store. Just had a quick question because my tmobile 640 never did this

    I bought the 640 XL RM -1064 model unlocked

    When using data while on a phone call on the XL on tmobile I notice the signal drops to HSPA+ or even 3G.

    Is this normal? My 640 always stayed on LTE during phone calls if I was using my data. The

    voice calls still say HD on the phone dialer

    Everything else seems to be working as usual.
    Over here if I'm browsing using LTE and a phone comes in, my speed drops to 2G. So I think it depends on the carrier
    Sedp23 likes this.
    05-14-2016 11:19 AM
  3. Sedp23's Avatar
    Over here if I'm browsing using LTE and a phone comes in, my speed drops to 2G. So I think it depends on the carrier

    Thanks so it seems normal

    Sent from mTalk
    05-14-2016 04:08 PM
  4. xandros9's Avatar
    With exceptions, phones drop to 2G/3G in order to make phone calls. Some don't, but most do.
    Chintan Gohel and Sedp23 like this.
    05-14-2016 06:22 PM
  5. Robert Tullos's Avatar
    Try going to APN settings and edit your currently loaded APN. Set your MMSC port to 80. I think that's the one. You shoudnt drop down after that, and you likely will see a boost in data speed.
    06-01-2016 12:58 AM

Similar Threads

  1. Logitech K480 Bluetooth Keyboard ( Work Office like a laptop on your phone )
    By Greywolf1967 in forum General Phone Discussion
    Replies: 3
    Last Post: 09-23-2016, 09:43 AM
  2. Replies: 8
    Last Post: 06-01-2016, 10:18 AM
  3. No Leaks No Rumours No Lumia
    By Farhan Alistar in forum General Phone Discussion
    Replies: 2
    Last Post: 05-16-2016, 06:11 AM
  4. Lumia 640 XL Build Quality Issues...
    By vikrant1982 in forum Windows Phones
    Replies: 6
    Last Post: 05-14-2016, 07:41 PM
  5. login fails with Microsoft password
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-14-2016, 03:07 AM
LINK TO POST COPIED TO CLIPBOARD