1. JFD303's Avatar
    I recently got a Nokia Lumia 640 - actually I got 3.

    I am in Australia, on the Optus network, with a brand new 4g capable SIM.

    I noticed that at least once every 30 seconds my phone was losing connection to the Optus network - it would go from 5 bars reception to no service, then back to 5 bars after 1 or 2 seconds.

    I took the phone to the Optus shop (it's a prepaid Optus handset).

    They swapped the SIM for another one. It made no difference.

    I read on the forums that instead of allowing automatic network selection, the problem would be solved if I manually selected the Optus network. I tried that too, it made no difference.

    What does work is changing the maximum connection speed down from 4g to 3g. As soon as I do that, the disconnects stop.

    It's definitely a hardware or software bug and its frustrating. I have purchased a 4g phone, but it only works correctly in 3g...

    I tried all 3 of my brand new handsets and all 3 have the same identical issue.

    I have run all the updates for the phone, and have upgraded to Windows 10. None of that solved the problem.

    Only setting the phone to 3g maximum connection works.

    Any thoughts ?

    PS: I would say that for $99 AUD you get a lot of phone for your money. Pity its only working in 3g though...
    11-15-2016 02:11 AM
  2. libra89's Avatar
    This is strange. The only thing I can possibly think of is to see if you have Lumia 640 or the Lumia 640 LTE model. Can you go to settings->about (or settings->system->about if on Windows 10 Mobile) to share which one you have?

    The regular 640 does not allow for 4G speeds.
    Additionally, check out this link to see the difference between the two models: Difference between Microsoft Lumia 640 and 640 LTE ? - Microsoft Community
    11-15-2016 08:03 AM
  3. IamWinFan2's Avatar
    another issue could be APN settings. I had similar issue when I left the APN settings to default. Try entering APN setting manually.
    11-28-2016 04:04 PM

Similar Threads

  1. Nokia Lumia 1020 Charging Alternatives?
    By erichobo in forum Ask a Question
    Replies: 3
    Last Post: 11-16-2016, 05:07 PM
  2. how to download in my lumia 1020 this w10 build 10586
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-15-2016, 03:45 AM
  3. Lumia N625 hanged while resets
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 11-15-2016, 02:14 AM
  4. Lumia 950XL Does Not Show on Windows Explorer 10 Since Build 14965.1001
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 11-14-2016, 08:37 PM
  5. Replies: 0
    Last Post: 11-14-2016, 07:45 PM
LINK TO POST COPIED TO CLIPBOARD