1. Michael Alan Goff's Avatar
    This is something that might seem weird.

    I was looking up something, forget what, and the optimize disk option comes up. Then t sys it needs optimization. But isn't that the defragment thing and isn't it terribly bad to defragment SSD? Or did they add something special to Windows RT for that sort of thing?

    I'd rather not mess up My new computer if I can get away with it.
    07-18-2013 06:49 AM
  2. DenniSundaY's Avatar
    If computers running on Windows and use a SSD i thought windows didn't show that option. I am also not sure if "disk optimization" is defragmenting. But I don't think it is defragmentation since it is indeed a Surface RT and also running windows RT (zo mot made for HDD) so maybe it only a sort of indexing. I think it is safe to click on :P
    07-18-2013 07:26 AM
  3. martinmc78's Avatar
    I have had mine "optimized" about 3 times now - never caused any issues.
    07-18-2013 07:30 AM
  4. Michael Alan Goff's Avatar
    So it isn't defrag?

    Any noticeable improvements afterwards?
    07-18-2013 08:27 AM
  5. martinmc78's Avatar
    Not 100% sure to be honest. Think it does the same sort of job though.

    You get a small memory increase due it removing temporary files and such. Cant say I ever noticed an increase in speed, but I did get a lot less hangs on apps loading after it was done.
    07-18-2013 08:39 AM
  6. Michael Alan Goff's Avatar
    Not 100% sure to be honest. Think it does the same sort of job though.

    You get a small memory increase due it removing temporary files and such. Cant say I ever noticed an increase in speed, but I did get a lot less hangs on apps loading after it was done.
    That is enough reason for me.
    07-18-2013 08:44 AM
  7. Dos101's Avatar
    It's not defraging it, it's running the trim command TRIM - Wikipedia, the free encyclopedia

    Windows 8 does a good job of detecting if a drive is an SSD or not, so yes, run it. If you run it and it doesn't say "xx% trimmed", then you might have a problem.
    xandros9 likes this.
    07-18-2013 09:16 AM
  8. Michael Alan Goff's Avatar
    Just tried it, now it says Optimization not available.
    07-18-2013 09:35 AM
  9. Dos101's Avatar
    Just tried it, now it says Optimization not available.
    Which drive are you selecting in the "Defragment and Optimize Drives" application?
    07-18-2013 09:48 AM
  10. Michael Alan Goff's Avatar
    Which drive are you selecting in the "Defragment and Optimize Drives" application?
    screenshot-1-.jpg
    07-18-2013 10:20 AM
  11. Dos101's Avatar
    Did you try rebooting?
    07-18-2013 10:25 AM
  12. Michael Alan Goff's Avatar
    I will check that right now.

    Edit: Afraid it did no good.
    07-18-2013 10:31 AM
  13. Michael Alan Goff's Avatar
    Would the fact that I'm running 8.1 make any difference?
    07-19-2013 01:00 PM
  14. Dos101's Avatar
    It shouldn't, I'm running 8.1 on my Surface RT and my laptop (which also has an SSD) and have no issues optimizing drives. Just out of curiosity are you able to run Disk Cleanup? I wonder if running it then trying to optimize the drive would fix the issue (a longshot but worth a try).
    07-19-2013 02:39 PM
  15. Michael Alan Goff's Avatar
    It shouldn't, I'm running 8.1 on my Surface RT and my laptop (which also has an SSD) and have no issues optimizing drives. Just out of curiosity are you able to run Disk Cleanup? I wonder if running it then trying to optimize the drive would fix the issue (a longshot but worth a try).
    Just ran it, optimization still not available. Still never run.
    07-20-2013 11:38 AM
  16. jhoff80's Avatar
    Have you potentially disabled any system services in the past, namely the "Optimize drives" one?
    07-20-2013 11:53 AM
  17. Michael Alan Goff's Avatar
    Nope. And when I go to the action center to start automatic maintenance... it then makes the status of the process say "running".

    I don't get it.

    How can it be running if it says it's not available?
    07-20-2013 11:58 AM
  18. kevm14's Avatar
    I am having the same problem with an Asus Vivotab RT running the 8.1 upgrade. Optimization not available. Asus tech support told me they "could not duplicate" and told me to reset. I don't remember if this was available before I upgraded to 8.1. Sadly, under 8.0, I made a USB recovery key then deleted the recovery data. So my key is for original RT. Now it won't let me reset saying the media inserted is not valid.
    01-11-2014 01:06 PM

Similar Threads

  1. RT or Not to RT
    By garak0410 in forum Windows RT
    Replies: 20
    Last Post: 07-25-2013, 03:50 PM
  2. Ideas to Save Windows RT
    By ShaunKL in forum Windows RT
    Replies: 35
    Last Post: 07-23-2013, 01:39 PM
  3. Next Gen Surface Tablet Specs
    By IMStrugglin in forum Microsoft Surface for Windows 8 Pro
    Replies: 4
    Last Post: 07-17-2013, 05:15 PM
  4. Help needed to restore purchase history
    By mmarksx19 in forum Windows Phone 8
    Replies: 1
    Last Post: 07-17-2013, 10:02 AM
  5. Surface Mini in the fall?
    By smoledman in forum Upcoming & Rumored Phones
    Replies: 1
    Last Post: 07-17-2013, 12:34 AM
LINK TO POST COPIED TO CLIPBOARD