Welcome to the Windows Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 20 of 20
  1. lemixtape88's Avatar
    Member

    Posts
    10 Posts
       #1  
    I have installed Gmail as an EAS (Exchange) account on my Windows Phone 8 HTC 8X. When I try to do a server on the server, I get the following error message:

    Can't connect
    We weren't able to connect to the network. If you have good reception, the problem may be at the other end. Wait a little while and try again.
    This happens both in WiFi and 4G. I have set it up so it syncs email, contacts and calendar and to download email from the past 7 days. Any clues on how to enable server search from the built-in mail app in this scenario?
  2. Richhy's Avatar
    Member

    Posts
    23 Posts
    #2  
    I have the exact same problem. Would like to know if there is a fix as well.
  3. tebugg's Avatar
    Member

    Posts
    363 Posts
    Global Posts
    366 Global Posts
    #3  
    have you put in m.google.com in the settings to point to google mobile? i know this has to be put in manually.
  4. androidtoWM's Avatar
    Member

    Posts
    354 Posts
    #4  
    This happened to me when i set my gmail account as an exchange account. if you choose Google mail while setting it up, it works.
  5. androidtoWM's Avatar
    Member

    Posts
    354 Posts
    #5  
    Quote Originally Posted by tebugg View Post
    have you put in m.google.com in the settings to point to google mobile? i know this has to be put in manually.
    does this work with exchange setup ?
  6. rider2040's Avatar
    Member

    Posts
    210 Posts
    #6  
    I have Gmail setup as an exchange account on my 920 and I have no problem searching for mail on the server.
  7. androidtoWM's Avatar
    Member

    Posts
    354 Posts
    #7  
    Quote Originally Posted by rider2040 View Post
    I have Gmail setup as an exchange account on my 920 and I have no problem searching for mail on the server.
    do you sync your entire email or just one/two week(s) ?
  8. lemixtape88's Avatar
    Member

    Posts
    10 Posts
       #8  
    I have used the m.google.com server when setting up my account. If i want to sync my calendar, contacts and mail, then I have to use the Exchange set up right? Using only the gmail option, only my email will be synced?

    I do not want to store my entire gmail archive as this would be too much data for my 8X. So, does anyone know how to sync emails, contacts and calendar from Google AND being able to search for messages on the server?
  9. rider2040's Avatar
    Member

    Posts
    210 Posts
    #9  
    Quote Originally Posted by androidtoWM View Post
    do you sync your entire email or just one/two week(s) ?
    I have it set to download email from the last month.
  10. androidtoWM's Avatar
    Member

    Posts
    354 Posts
    #10  
    Quote Originally Posted by rider2040 View Post
    I have it set to download email from the last month.
    i tried it again with these settings (exchange + as mail arrives + sync emails from the past month) , it gives me the same error as in OP whenever i search something on the server.


    i wonder if this has something to do with the way gmail is setup on the web.
  11. androidtoWM's Avatar
    Member

    Posts
    354 Posts
    #11  
    i've POP and IMAP enabled on the web.
  12. rider2040's Avatar
    Member

    Posts
    210 Posts
    #12  
    Quote Originally Posted by androidtoWM View Post
    i tried it again with these settings (exchange + as mail arrives + sync emails from the past month) , it gives me the same error as in OP whenever i search something on the server.


    i wonder if this has something to do with the way gmail is setup on the web.
    the other two settings I have are:
    Server: m.google.com
    Check server requires SSL
  13. rider2040's Avatar
    Member

    Posts
    210 Posts
    #13  
    I just remembered that when I originally setup my phone, I only had my Gmail account sync mail, so it defaulted to the imap settings. A couple days later, I went in to sync settings and checked contacts and it changed to exchange. I'm not sure if this has anything to do with why it works for me, but you might try deleting your account and starting from scratch making the same steps I did.
    Thanked by:
  14. lemixtape88's Avatar
    Member

    Posts
    10 Posts
       #14  
    So, using the mail app from WP8, you can search on the server for messages that are 2 years old even though you only downloaded the last week of emails on your phone? Can you test it to make sure it works before we all delete our Exchange account?
    Thank you for your help!
  15. rider2040's Avatar
    Member

    Posts
    210 Posts
    #15  
    Quote Originally Posted by lemixtape88 View Post
    So, using the mail app from WP8, you can search on the server for messages that are 2 years old even though you only downloaded the last week of emails on your phone? Can you test it to make sure it works before we all delete our Exchange account?
    Thank you for your help!
    So, I just searched for and found an email from July 2007.

    Here's what I did: Gmail tile > menu > folders > show all folders > All Mail > search icon > type search term > search more in Google Mail

    PS - I'm using a Lumia 920 on ATT in the US if that makes any difference.
  16. rider2040's Avatar
    Member

    Posts
    210 Posts
    #16  
    Oh, one last thing. I did all of this setup in early November. I got my phone one day after launch. This was before google announced that they weren't going to support EAS any more. When did you first set up your phone? I wonder if google is already not supporting setup of exchange on new devices??
  17. AR2186's Avatar
    Member

    Posts
    634 Posts
    #17  
    Taking your advice I was able to configure it to work properly. Delete the email account from the phone, then go to Add An Account and set up your account as a "Google" account without checking the Contacts or Calendars box (this makes the connection an IMAP implementation). Once you have done that, go back and check the boxes for contacts and calendar (this converts it to an EAS implementation). This seems to trick the system into allowing search, as I had previously been unable to search at all.
  18. lemixtape88's Avatar
    Member

    Posts
    10 Posts
       #18  
    Thank you for the help. I will try that as soon as I find a good WiFi connection as I am on a trip. I guess Google really does not like people on WP8. If I do this, will I have to relink all of my contacts on Gmail with the other accounts (Facebook, Linked, etc) or will it remember the accounts that were tied together in the People hub? Once again, thank you for your help!
  19. androidtoWM's Avatar
    Member

    Posts
    354 Posts
    #19  
    Quote Originally Posted by rider2040 View Post
    I just remembered that when I originally setup my phone, I only had my Gmail account sync mail, so it defaulted to the imap settings. A couple days later, I went in to sync settings and checked contacts and it changed to exchange. I'm not sure if this has anything to do with why it works for me, but you might try deleting your account and starting from scratch making the same steps I did.
    woohoo this works.

    thanks
  20. AR2186's Avatar
    Member

    Posts
    634 Posts
    #20  
    It seems to have kept my contacts linked.

Similar Threads

  1. Mail search on server
    By gfunk84 in forum Windows 8
    Replies: 3
    Last Post: 11-16-2012, 09:36 PM
  2. Replies: 0
    Last Post: 09-29-2011, 10:37 AM

Posting Permissions