1. Mmazeo's Avatar
    I'm on an unlimited data plan with T Mobile. Suddenly today my phone just stopped working on the T Mobile data signal. It's only working on wifi. My wife's iPhone on the same plan is working fine. I've gone over my settings and am pretty sure nothing was altered.

    Anyone have an idea of what I can do? Thanks.
    08-22-2017 09:36 PM
  2. libra89's Avatar
    I'm on an unlimited data plan with T Mobile. Suddenly today my phone just stopped working on the T Mobile data signal. It's only working on wifi. My wife's iPhone on the same plan is working fine. I've gone over my settings and am pretty sure nothing was altered.

    Anyone have an idea of what I can do? Thanks.
    I have a question for you.

    First, is your Idol 4s the T-Mobile variant or the unlocked one?

    I wonder if something else is going on T-Mobile's network for Windows Phones, since you haven't been the only one to have issues with it today.
    RumoredNow likes this.
    08-22-2017 10:13 PM
  3. Mmazeo's Avatar
    T-Mo variant. Very frustrating.
    08-23-2017 09:47 AM
  4. libra89's Avatar
    Ahh that sucks. I was going to share a thread where someone posted a tip about this but it didn't work. Is your sim really old? Maybe you can try contacting T-Mobile to do a refresh? Sometimes having a more recent sim can help. If your sim isn't old though, maybe contacting them could help.
    RumoredNow likes this.
    08-23-2017 09:57 AM
  5. RumoredNow's Avatar
    Call customer care and get escalated to a real tech. Request that you get a reprovision and also request that they ensure your IMEI is in their database so it receives full services.
    libra89 likes this.
    08-23-2017 12:43 PM
  6. tgp's Avatar
    I was going to share a thread where someone posted a tip about this but it didn't work.
    I recently read a post about this too, but I forgot if it was here on WC or on Reddit, or somewhere else. Either way, the fix didn't work for very long.
    libra89 likes this.
    08-23-2017 02:26 PM
  7. libra89's Avatar
    I recently read a post about this too, but I forgot if it was here on WC or on Reddit, or somewhere else. Either way, the fix didn't work for very long.
    It was probably the same thread here, which I think was about a 1520.
    tgp likes this.
    08-23-2017 02:54 PM
  8. tgp's Avatar
    It was probably the same thread here, which I think was about a 1520.
    Yes I remember it was a 1520.
    libra89 likes this.
    08-23-2017 02:55 PM
  9. mark233's Avatar
    I'm on an unlimited data plan with T Mobile. Suddenly today my phone just stopped working on the T Mobile data signal. It's only working on wifi. My wife's iPhone on the same plan is working fine. I've gone over my settings and am pretty sure nothing was altered.

    Anyone have an idea of what I can do? Thanks.
    If you haven't looked already...make sure cellular data is on (via notification center)... also try this--shut off phone, remove SIM and replace SIM tray, boot up phone. Once it's booted up, power off. Reinstall SIM and restart. See if that does anything.
    RumoredNow and libra89 like this.
    08-23-2017 07:17 PM
  10. Mmazeo's Avatar
    T-Mobile tech support was very helpful and patient. Guy figured out that under Sim Setting, the Internet APN and MMS APN were wiped clear, gone. He talked me through how to set them up again and it's back to working.
    08-23-2017 08:52 PM
  11. mark233's Avatar
    T-Mobile tech support was very helpful and patient. Guy figured out that under Sim Setting, the Internet APN and MMS APN were wiped clear, gone. He talked me through how to set them up again and it's back to working.
    Great! Glad the issue was resolved.
    libra89 likes this.
    08-24-2017 04:44 AM
  12. libra89's Avatar
    T-Mobile tech support was very helpful and patient. Guy figured out that under Sim Setting, the Internet APN and MMS APN were wiped clear, gone. He talked me through how to set them up again and it's back to working.
    Glad to hear it!
    mark233 likes this.
    08-24-2017 07:46 AM
  13. nate0's Avatar
    That happened to me once. Did a soft reset and my apn settings came back.
    mark233 and RumoredNow like this.
    08-24-2017 04:55 PM

Similar Threads

  1. Nokia dt-903 wireless charger and windows 10 mobile
    By stickyshocker in forum Windows 10 Mobile
    Replies: 2
    Last Post: 10-28-2017, 10:49 AM
  2. Replies: 7
    Last Post: 09-06-2017, 09:12 PM
  3. Any issues with latest update? (2017.08.)
    By Nektarin87 in forum Windows 10 Mobile
    Replies: 1
    Last Post: 08-22-2017, 10:58 PM
  4. No issues at all?
    By excalibur1814 in forum Microsoft Surface Pro (2017)
    Replies: 3
    Last Post: 08-22-2017, 12:36 PM
  5. Why the death of Windows 10 Mobile may be a good thing
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 08-21-2017, 12:20 PM
LINK TO POST COPIED TO CLIPBOARD