1. daniel329's Avatar
    Hey everyone! I'm almost a daily reader but a fairly new poster. Looking forward to more interaction. :)

    I have an unlocked Lumia Icon that I received directly from Nokia. I put a Simple Mobile SIM into it and I am encountering some bugs. First of all it does recognize the SIM and even says "Simple Mobile" below the signal indicator. The issue is that even though the device stats on H+ it cycles through 3G, E, and then says no service. It probably spends 70% of its time on no service and the rest cycling through the signal indicators. Even weirder is that I can almost always send/receive data when it is on "no service." It is as if the signal bars just don't work. I am running 8.1 latest build (as of today). I would appreciate any help I can get!
    Thanks :)
    06-16-2014 12:43 PM
  2. ssapre's Avatar
    Go to Settings > Cellular + Sim > Sim Settings and check changing Highest connection speed to 3G & LTE. I used it on one of the AT&T MVNOs, saw the network coming out bad (in the signal icon) but never had issues like missing any calls or dropping out of calls.
    06-16-2014 12:51 PM
  3. daniel329's Avatar
    Go to Settings > Cellular + Sim > Sim Settings and check changing Highest connection speed to 3G & LTE. I used it on one of the AT&T MVNOs, saw the network coming out bad (in the signal icon) but never had issues like missing any calls or dropping out of calls.
    I have tried this to no avail. It still cycles between signals. :(
    06-17-2014 01:05 PM
  4. Brandon McLean's Avatar
    You've set the highest connection speed to 3G? I had the same issue with my Icon when I got it last week. It only works when set to 3G. However, I needed to put in my carriers APN info as well to get data to work. Maybe you should try that too.
    06-18-2014 04:44 PM

Similar Threads

  1. The one thing I hate about Lumia 1520 !!
    By Kinan Hloubi in forum Windows Phone 8
    Replies: 8
    Last Post: 07-10-2014, 06:34 PM
  2. Replies: 5
    Last Post: 06-22-2014, 11:01 AM
  3. Threat to Lumia equivalents!! Micromax joined WP :-)
    By Ashish Gupta888 in forum Upcoming & Rumored Phones
    Replies: 8
    Last Post: 06-22-2014, 10:51 AM
  4. Lumia 925 QI charging
    By Psyk00 in forum Nokia Lumia 925
    Replies: 5
    Last Post: 06-19-2014, 07:50 AM
  5. Create Album on Lumia Phones
    By rahuljain257 in forum Nokia Lumia 925
    Replies: 1
    Last Post: 06-16-2014, 09:38 AM
LINK TO POST COPIED TO CLIPBOARD