1. WPCentral Question's Avatar
    I've using net10 for more than a year with an iphone 4s. I decided to change to a Samsung Galaxy S5 a month ago. I've tried many apn and to call customer service but no change. My service is super slow and i dont know why. I just bought my data plan, and the service speed has been the same since the moment i actived the phone. Can anyone please help me
    06-25-2014 07:21 PM
  2. worldspy99's Avatar
    I've using net10 for more than a year with an iphone 4s. I decided to change to a Samsung Galaxy S5 a month ago. I've tried many apn and to call customer service but no change. My service is super slow and i dont know why. I just bought my data plan, and the service speed has been the same since the moment i actived the phone. Can anyone please help me
    I think you need to post this over in AndroidCentral. Thanks.
    06-25-2014 07:32 PM
  3. xandros9's Avatar
    Make sure the bands of the phone line up with the bands of the network, many phones, for example, cannot get 3G on T-Mobile in areas T-Mo hasn't refarmed their network.

    But you posted in a forum dedicated to Windows Phone devices, you will likely receive better help over at our sister site, Android Central, since the S5 is an Android device.
    Laura Knotek likes this.
    06-25-2014 08:49 PM

Similar Threads

  1. Steam In-home streaming not functional on SP3, Wifi issues
    By fc000 in forum Microsoft Surface Pro 3
    Replies: 9
    Last Post: 08-18-2014, 02:00 PM
  2. e-mail sync issue
    By amit_nb in forum Nokia Lumia 925
    Replies: 2
    Last Post: 06-26-2014, 06:10 AM
  3. Nokia MixRadio Issues...
    By thatuxguy in forum Microsoft Surface for Windows RT
    Replies: 1
    Last Post: 06-26-2014, 04:07 AM
  4. Anyone else have call quality issues with Icon?
    By hepi in forum Nokia Lumia Icon
    Replies: 6
    Last Post: 06-25-2014, 09:40 PM
  5. Replies: 1
    Last Post: 06-24-2014, 09:45 PM
LINK TO POST COPIED TO CLIPBOARD