1. Windows Central Question's Avatar
    Hi Guys,

    So I installed Win 10 Tech preview on Lumia 520. Everything is fine/acceptable except for my mobile phone does not see 2G/3G whatever network. It works with the Wifi though. Is there any solution for this? I played with the Settings but it still does not work.

    Thanks in advance.
    02-18-2015 08:53 AM
  2. Harrie-S's Avatar
    Rolling back
  3. Harrie-S's Avatar
    Rolling back
    RumoredNow likes this.
    02-18-2015 09:07 AM
  4. taymur's Avatar
    i have the same issue on my 630, any ideas what is happening exactly?
    03-24-2015 09:14 AM
  5. RumoredNow's Avatar
    i have the same issue on my 630, any ideas what is happening exactly?
    Is your 630 Dual SIM? If I remember correctly, Dual SIM is not supported in the Tech Preview.
    03-24-2015 12:24 PM
  6. taymur's Avatar
    Is your 630 Dual SIM? If I remember correctly, Dual SIM is not supported in the Tech Preview.
    ​aaaah, thats it. thanks. love this community.

    Thought something went wrong with the update :D
    RumoredNow likes this.
    03-25-2015 02:59 AM

Similar Threads

  1. Replies: 8
    Last Post: 03-02-2015, 05:32 PM
  2. L520,india,no denim ?
    By gowthamaura in forum Nokia Lumia 520
    Replies: 5
    Last Post: 02-18-2015, 08:51 AM
  3. What is Wrong with the Windows Store?
    By Zachary Boddy in forum Ask a Question
    Replies: 1
    Last Post: 02-18-2015, 07:42 AM
  4. ativating code for lumia 625
    By WPCentral Question in forum Ask a Question
    Replies: 4
    Last Post: 02-18-2015, 07:40 AM
  5. Farmville 2: Country Escape - life in the boondocks for Windows Phone and Windows 8
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-18-2015, 07:30 AM
LINK TO POST COPIED TO CLIPBOARD