1. Windows Central Question's Avatar
    Windows 10 Home.
    This is driving me crazy. The following programs keep running and running and running; my Avast icon in the tray will just not stop spinning as it keeps scanning these programs.
    BackgroundTransferHost.exe
    Rundll.exe
    BackgroundTransferHost.exe
    Rundll.exe ad infinitum.

    I have turned off most notifications but nothing helps. What's going on?
    08-11-2015 04:34 AM
  2. eatinborscht's Avatar
    I'd like to know the answer too as I am having the same problem.

    P.S. I did disable sharing windows update with everyone (this option is turned on by default)
    08-12-2015 02:39 AM
  3. Topshoeter's Avatar
    I did too, and every other notification. This can't be good for my SSD.
    08-12-2015 08:21 AM
  4. Topshoeter's Avatar
    I found this solution on the net and it works for me. It seems to be caused by TimeBroker.
    Start regedit.exe and navigate to the following entry:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000003
    Change the 3 to a 4 with edit.
    Result:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000004

    4 is Disabled, 3 is Manual and 2 is Automatic startup.
    Exit regedit and reboot your system.
    It doesn't seem to have any adverse effect and everything seems to be working correctly.
    08-16-2015 10:24 AM
  5. CeImor's Avatar
    The BackgroundTransferHost ist used by Apps to download/upload data in the background or even in connected Standby. In contrast to that WWAHost is downloading data that the app is immediately using/displaying to the user. Your Antivirus software wants to probably scan the downloaded data. It shouldn't run all the time in Background, it runs only when an App is using it.
    You can look up what App is using the BackgroundTransferHost with a program called "Process Explorer" (mousing over process -> Package / properties -> working directly).
    It's best to always look for the cause instead of trying to get rid of the resulting "symptoms".
    Hope that helps.
    08-18-2015 09:04 PM
  6. u00959901's Avatar
    This does not turn off timebroker at all. Still runs I manually turn it off and in a while it is back running in Task Manager.
    01-22-2017 12:58 PM
  7. Citta Huang's Avatar
    I found this solution on the net and it works for me. It seems to be caused by TimeBroker.
    Start regedit.exe and navigate to the following entry:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000003
    Change the 3 to a 4 with edit.
    Result:
    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000004

    4 is Disabled, 3 is Manual and 2 is Automatic startup.
    Exit regedit and reboot your system.
    It doesn't seem to have any adverse effect and everything seems to be working correctly.
    After few months searching solution, finally I can use win 10 without consuming bandwith.

    Thank you and Best Regards.
    02-03-2017 04:53 AM

Similar Threads

  1. Stop iTunes on start up
    By johnson_patrickw in forum Windows 10
    Replies: 10
    Last Post: 07-15-2016, 12:41 PM
  2. Can I get some help with Maps and locations?
    By drjackool in forum Windows Phone 8.1
    Replies: 1
    Last Post: 08-11-2015, 06:39 AM
  3. Why doesn't my WiFi work after upgrading to Windows 10?
    By Windows Central Question in forum Windows 10
    Replies: 0
    Last Post: 08-11-2015, 01:21 AM
  4. Replies: 0
    Last Post: 08-10-2015, 11:22 PM
LINK TO POST COPIED TO CLIPBOARD