Why does BackgroundTransferHost.exe keep starting and stopping ad infinitum?

  • Thread starter Windows Central Question
  • Start date
W

Windows Central Question

Windows 10 Home.
This is driving me crazy. The following programs keep running and running and running; my Avast icon in the tray will just not stop spinning as it keeps scanning these programs.
BackgroundTransferHost.exe
Rundll.exe
BackgroundTransferHost.exe
Rundll.exe ? ad infinitum.

I have turned off most notifications but nothing helps. What's going on?
 

Topshoeter

New member
Aug 12, 2015
4
0
0
Visit site
I found this solution on the net and it works for me. It seems to be caused by TimeBroker.
Start regedit.exe and navigate to the following entry:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000003
Change the 3 to a 4 with edit.
Result:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000004

4 is Disabled, 3 is Manual and 2 is Automatic startup.
Exit regedit and reboot your system.
It doesn't seem to have any adverse effect and everything seems to be working correctly.
 

CeImor

New member
Aug 18, 2015
1
0
0
Visit site
The BackgroundTransferHost ist used by Apps to download/upload data in the background or even in connected Standby. In contrast to that WWAHost is downloading data that the app is immediately using/displaying to the user. Your Antivirus software wants to probably scan the downloaded data. It shouldn't run all the time in Background, it runs only when an App is using it.
You can look up what App is using the BackgroundTransferHost with a program called "Process Explorer" (mousing over process -> Package / properties -> working directly).
It's best to always look for the cause instead of trying to get rid of the resulting "symptoms".
Hope that helps.
 

Citta Huang

New member
Feb 3, 2017
1
0
0
Visit site
I found this solution on the net and it works for me. It seems to be caused by TimeBroker.
Start regedit.exe and navigate to the following entry:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000003
Change the 3 to a 4 with edit.
Result:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\TimeBroker] "Start"=dword:00000004

4 is Disabled, 3 is Manual and 2 is Automatic startup.
Exit regedit and reboot your system.
It doesn't seem to have any adverse effect and everything seems to be working correctly.

After few months searching solution, finally I can use win 10 without consuming bandwith.

Thank you and Best Regards.
 

Members online

No members online now.

Forum statistics

Threads
324,228
Messages
2,245,194
Members
428,180
Latest member
TheStivo