1. stentorkc's Avatar
    I have Lumia 630, and I wanted to reset my phone because of some headphones bug. But mid recovery in Windows recovery tool the USB didn't connect anymore for some unknown reason. Now the screen is red, and when I connect it to PC its always connecting and disconnecting (USB device not recognized). What should I do? Please help me.
    05-16-2016 02:36 PM
  2. AndyCalling's Avatar
    Originally posted by stentorkc
    I have Lumia 630, and I wanted to reset my phone because of some headphones bug. But mid recovery in Windows recovery tool the USB didn't connect anymore for some unknown reason. Now the screen is red, and when I connect it to PC its always connecting and disconnecting (USB device not recognized). What should I do? Please help me.
    I have not managed to do this with a phone, but I have with a stick PC firmware (so similar difficulties resolving things). I think you know where this is going. If you cannot reliably access the phone, so maintain a USB connection, you are out of options.

    All I can suggest is:

    1) Make sure the USB lead is good, and try another port. Avoid USB3 ports as they can have a variety of drivers from different manufacturers. USB2 ports are more uniform. Don't use a hub.

    2) Try a hard reset by holding down the buttons, as detailed here: http://www.resethard.com/nokia/lumia-630/

    3) Contact Microsoft for service :(~ Sorry.
  3. AndyCalling's Avatar
    Originally posted by stentorkc
    I have Lumia 630, and I wanted to reset my phone because of some headphones bug. But mid recovery in Windows recovery tool the USB didn't connect anymore for some unknown reason. Now the screen is red, and when I connect it to PC its always connecting and disconnecting (USB device not recognized). What should I do? Please help me.
    I have not managed to do this with a phone, but I have with a stick PC firmware (so similar difficulties resolving things). I think you know where this is going. If you cannot reliably access the phone, so maintain a USB connection, you are out of options.

    All I can suggest is:

    1) Make sure the USB lead is good, and try another port. Avoid USB3 ports as they can have a variety of drivers from different manufacturers. USB2 ports are more uniform. Don't use a hub.

    2) Try a hard reset by holding down the buttons, as detailed here: http://www.resethard.com/nokia/lumia-630/

    3) Contact Microsoft for service :(~ Sorry.
    RumoredNow likes this.
    05-16-2016 02:48 PM
  4. stentorkc's Avatar
    I tried again and It worked. Thanks for your time :)
    RumoredNow likes this.
    05-16-2016 05:24 PM

Similar Threads

  1. My Luma 520 will turn on and you see the Nokia logo and it goes to a black screen?
    By Windows Central Question in forum Nokia Lumia 520
    Replies: 1
    Last Post: 05-20-2016, 11:57 AM
  2. Replies: 5
    Last Post: 05-20-2016, 09:33 AM
  3. Surface Phone to have Amoled screen! Yay!
    By AndyCalling in forum Upcoming & Rumored Phones
    Replies: 13
    Last Post: 05-17-2016, 06:59 PM
  4. ONEDRIVE - how to log out on Surface
    By Paul Land1 in forum Microsoft Surface 2
    Replies: 1
    Last Post: 05-17-2016, 02:45 AM
  5. Telegram Messenger for Windows Phone and desktop adds text editing features and more
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 05-16-2016, 12:11 PM
LINK TO POST COPIED TO CLIPBOARD