1. Windows Central Question's Avatar
    Hi!
    I am just working with a Windows Mobile 6.5 device and I have some issues connecting to the Internet.

    When I reach a webpage it shows a message:
    The certificate was issued by a company you have not chosen to trust.
    The certificate date is valid.
    The certificate has a valid name matching the name of the page you are trying to view.

    Do you want to proceed?
    Yes No

    As I click Yes, it continues to show arbitrarily this message.
    I have checked with another device and they have the same Certificates and Expiration dates for all.

    Right now I don't know where to find, as I have not find anything on the Internet about this issue.

    Please, could you help me to resolve this issue? Thanks in advance.
    09-22-2016 05:19 AM
  2. xandros9's Avatar
    I'm not sure, maybe you need to install a more recent certificate for the page's signer?
    09-22-2016 08:31 AM
  3. Chintan Gohel's Avatar
    Hi!
    I am just working with a Windows Mobile 6.5 device and I have some issues connecting to the Internet.

    When I reach a webpage it shows a message:
    The certificate was issued by a company you have not chosen to trust.
    The certificate date is valid.
    The certificate has a valid name matching the name of the page you are trying to view.

    Do you want to proceed?
    Yes No

    As I click Yes, it continues to show arbitrarily this message.
    I have checked with another device and they have the same Certificates and Expiration dates for all.

    Right now I don't know where to find, as I have not find anything on the Internet about this issue.

    Please, could you help me to resolve this issue? Thanks in advance.
    it could also be because your device is no longer supported?

    If you need additional help or have more questions or details to share, please join the site so you can reply in this thread. See this link for instructions on how to join Windows Central.
    09-25-2016 07:44 AM
  4. operagust's Avatar
    Hi,
    Did you manage to fix your issue? I am facing the same issue on a MC9200 device.
    04-30-2018 10:17 AM
  5. MrockNroll's Avatar
    Check with fatclue as he was a very active 6.5 windows mobile user.
    04-30-2018 10:47 AM
  6. operagust's Avatar
    Thanks for the hint. I will send him a PM.
    In the meantime while doing some research I have found that Windows embedded handheld (former windows mobile) 6.5 does not accept certificates issues with hash algorithm sha2.
    https://support.microsoft.com/en-us/...t-support-sha2
    This could be a possible root cause I guess.
    04-30-2018 12:01 PM
  7. fatclue_98's Avatar
    Hi,
    Did you manage to fix your issue? I am facing the same issue on a MC9200 device.
    WM 6.5 builds below 28205 do not auto-update certs. Without SHA-256 certs, many websites won't load and Exchange is out the door. Unless your device has an updated ROM, you're out in the cold. Check Zebra's support page and see if there's an updated ROM available. Motorola no longer handles EDAs.

    https://www.zebra.com/us/en/support-...ld/mc9200.html
    04-30-2018 12:09 PM
  8. MrockNroll's Avatar
    Thanks fatclue_98 your a huge help to windows mobile users here.:-) Just curious about Win mobile 6.5 going forward, as iam still a happy user of Win 10 mobile looking forward to Andromeda's debut this year. However plan "B" could be to drop back to Win mobile 6.5 is this still possible ? MrockNroll.
    04-30-2018 12:57 PM
  9. operagust's Avatar
    My MC9200 device has Windows Embedded Handheld 6.5 classic (build 29366.5.3.12.48). What I have also noticed is that I can access without any issues a website (https) which has a certificate generated with SHA1. The ones that I can't access have certificates generated with SHA256.
    I have read that SHA256 is not supported on WEH 6.5? Is that true?
    I was thinking to export the certificate and importing manually on the device using the following steps:
    1.Using a desktop computer, open the certificate properties , and on the Details tab of the certificate, select Copy to File.

    2. Follow through the wizard, and select the DER Encoded binary X.509 (.cer) format.

    3. Click browse and specify a path and filename to save the certificate.

    4. Click on the Next button and click on Finish.
    04-30-2018 01:19 PM
  10. fatclue_98's Avatar
    I’m not 100% sure about Classic. Do you have any options for downloading 6.5.3? It was never released to the public but chefs grabbed the ROMs and took the good bits and pieces. I had the ES400 but it was 6.5.3 Professional (touchscreen) and Symbol (Zebra) had updated ROMs up until last year. It might be time to finally move on .
    04-30-2018 01:58 PM
  11. operagust's Avatar
    Thanks fatclue for your advice, but upgrade is not an option and especially with an unofficial version.

    I have managed to install the certificates into the device but the error still persists. If I go to Start->System->Settings->Certificates I can see them in the intermediate tab (not in the root tab). I am wondering if I need to do a different export of the certificates on the WebServer.

    Steps for importing the certificate:
    1.Copy the certificate file to your Windows Mobile 6 device using Windows Mobile Device Center
    2.Tap "Start", "Programs" and "File Explorer".
    3.Tap the certificate file that you want to import.
    4.Receive this message "One ore more certificates were installed successfully" and press ok.
    05-01-2018 10:43 AM
  12. operagust's Avatar
    Guys I have made it.It works now.

    So the solution is to generate the certificates on the server using the tool mentioned here.
    https://blogs.msdn.microsoft.com/win...r-v2-released/
    I have copied the certificates (root and leaf as two certificates are generated) into the device, install them (post #11 ) and now no warning message is displayed.
    05-08-2018 10:00 AM
  13. ethangsum's Avatar
    Guys I have made it.It works now.

    So the solution is to generate the certificates on the server using the tool mentioned here.
    https://blogs.msdn.microsoft.com/win...r-v2-released/
    I have copied the certificates (root and leaf as two certificates are generated) into the device, install them (post #11 ) and now no warning message is displayed.

    Damn...Looks like page doesn't exist anymore (the download page I mean)
    08-31-2018 03:40 PM

Similar Threads

  1. how do I load music I have on another drive
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 09-25-2016, 08:16 AM
  2. How to fix wide spaced desktop icons after Windows 10 update!?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 09-25-2016, 08:14 AM
  3. Replies: 3
    Last Post: 09-25-2016, 07:08 AM
  4. How to restore data from app's backup?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-24-2016, 01:04 PM
  5. 950xl brightness issue.. Got it after last update
    By Sniper_Merc in forum Microsoft Lumia 950 XL
    Replies: 1
    Last Post: 09-21-2016, 06:37 PM
LINK TO POST COPIED TO CLIPBOARD