1. jolin1's Avatar
    I purchased a MACHXO2 - 1200ze evaluation board a few days ago. I started with designing and programming simple projects as blinking leds, which worked perfectly. After that at the same day I tried to synthesize and program a greater project. The synthezition process passed without any errors and xcf file was produced. At the next step I tried to program the device (I use diamond 3.1). The programming process took for more than 30 minutes and wasn't finished so I quit the program and restarted my computer. Then when I tried again to connect the device and program, the device wasn't recognized at all by windows. Not at the device manager an not in devices and printers. And when I tried to program again an error was showed:

    Failed to Open FTDI USB port. Make sure to select the right cable type. If you have not installed the FTDI Windows USB Driver, follow the instructions in the Programmer Help topic: "Installing/Uninstalling Parallel Port Driver and USB Driver". If you have installed the driver, if you recently plugged in the cable, please wait a few seconds and try again. This will give the operating system time to recognize the cable. ERROR: pgr_program failed. ERROR - Programming failed.

    Although the drivers of the FTDI are installed and it worked before. I chose cable: HW-USBN-2B (HW-USBN-2B - Lattice Semiconductor Corporation - In-Circuit Programmers, Emulators, and Debuggers - Kynix Semiconductor) and port: FTUSB-0. I tried it on different computers (with drivers installed) and the same error was produced. I also tried different USB slots in my computer, replaced the USB cable with another, made reset to the computer and nothing helped. At the next day I asked my friend who purchased the same board a year ago. I programmed the simple blinking led project, and it worked fine (the led actually blinked). Then I tried to program the bigger project. The same thing happend: it took a lot of time to download and then I quit the program. After that I tried to program again even that simple blinking led project, and the same error message showed. Actuallty the devise wasn't recognized at all. Now both kits don't work.

    Did anyone encounter such a problem? I'm lost and can't progress with my project :'(
    03-27-2017 10:23 PM

Similar Threads

  1. Total Wireless - Can We Do It?
    By hopmedic in forum Carrier Discussion Lounge
    Replies: 1
    Last Post: 08-29-2017, 06:21 PM
  2. Updating an unlocked att 640 go phone to Windows 10
    By tomseys in forum Microsoft Lumia 640
    Replies: 13
    Last Post: 04-18-2017, 06:16 PM
  3. How to change the shortcut arrow icon in Windows 10
    By James Falconer in forum Windows 10 How-to Guides
    Replies: 5
    Last Post: 03-28-2017, 01:08 PM
  4. Microsoft hit with $5 million lawsuit over Windows 10 upgrades
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 2
    Last Post: 03-28-2017, 10:29 AM
  5. Windows Central Podcast 42: RTM is here
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 03-27-2017, 03:30 PM
LINK TO POST COPIED TO CLIPBOARD