1. slooksterpsv's Avatar
    Hello, I still utilize my Blu Win HD LTE and found something really odd with it. It may be related to the other bug posts, but I'll just advise what happened.

    Yesterday when the build showed up for the Alcatel, I went and turned on my Blu, reverted back to production (from the insider app) and left the phone plugged in for 4 hours. When I went to bed, I switched the Alcatel to the charger and used the Blu to read up on some news before going to sleep. I'd been using it about 30 min. when I was notified that the battery was low (20%). I don't remember if it said it was fully charged on the screen, but the green LED light was on saying it was fully charged.

    This concerns me because the battery shouldn't all the sudden dip that fast or be that short. Battery usage shows everything less than 1%. I'm kind of glad I got the Alcatel. I'm letting it charge all day while I'm at work and see if it does it again. =/ Anything similar to this happening with others? It may be related to the other threads.
    02-24-2016 07:22 AM
  2. RMT1979's Avatar
    I have random charge issues with mine it is just under 3 months old and once or twice a week the battery just seems to drain very quickly for no apparent reason. On Sunday gone it was on charge all day until around 3pm when i unplugged it and left it on the side on standby later that night I checked it before bed (7 hours or so) and the battery warning came on saying battery critically low and the icon was blinking as they do when they are flat. I charged it again that night and have used it frequently at work this week as normal and it is lasting fine. The usage status said the phone app was at 100% even though it was not used at all?? Another problem is terrible ghosting on the screen it gets really bad when I open an app I can clearly still see the start screen and even as I'm typing now I have multiple lines of various shades of black white and grey vertically down the screen. Not sure why or if it is related but worth a mention anyway in case anybody else has had anything similar?
    02-24-2016 02:16 PM
  3. slooksterpsv's Avatar
    I have random charge issues with mine it is just under 3 months old and once or twice a week the battery just seems to drain very quickly for no apparent reason. On Sunday gone it was on charge all day until around 3pm when i unplugged it and left it on the side on standby later that night I checked it before bed (7 hours or so) and the battery warning came on saying battery critically low and the icon was blinking as they do when they are flat. I charged it again that night and have used it frequently at work this week as normal and it is lasting fine. The usage status said the phone app was at 100% even though it was not used at all?? Another problem is terrible ghosting on the screen it gets really bad when I open an app I can clearly still see the start screen and even as I'm typing now I have multiple lines of various shades of black white and grey vertically down the screen. Not sure why or if it is related but worth a mention anyway in case anybody else has had anything similar?
    Thank you for sharing. Have you noticed the capacitor touch elements on the screen for the touch input - look like an H (a whole bunch of H )? Usually I can only see it in fluorescent or sunlight light, but it is kind of annoying. Instead of just a regular black or dark gray screen when its off, I see all of these H's going across the screen like so:
    H H H H H H H H
    H H H H H H H H
    .....continue

    Not feeling too strongly about Blu. It doesn't feel as cheap as the Alcatel does, no offense, I love my Alcatel, but it feels cheap to a degree.
    02-24-2016 03:39 PM
  4. RMT1979's Avatar
    Hi I haven't noticed that issue you mention with the HHH on my screen I guess that this is just the deal with these entry level devices, they have decent reviews but they do feel rather cheap in comparison to my Lumia 730 & 830 which are solid. I'm not much of a techy but I very much doubt its the software as 8.1 is bomb proof, amazon has discontinued these HD LTE's at least here in the UK so no chance of any support there and I'm not sure if blu has any UK support if not I'll just live with it after all the phone was only 59.99 so still a good deal even if it does have its moments 👍
    02-24-2016 04:01 PM
  5. slooksterpsv's Avatar
    Hi I haven't noticed that issue you mention with the HHH on my screen I guess that this is just the deal with these entry level devices, they have decent reviews but they do feel rather cheap in comparison to my Lumia 730 & 830 which are solid. I'm not much of a techy but I very much doubt its the software as 8.1 is bomb proof, amazon has discontinued these HD LTE's at least here in the UK so no chance of any support there and I'm not sure if blu has any UK support if not I'll just live with it after all the phone was only 59.99 so still a good deal even if it does have its moments
    Odd... its not on there. Hmm... I was thinking at MWC, they were going to release some new phones, but maybe not. Hopefully its still on track for W10 though.
    I'll see if I can get a picture of it and show you; it's cool, but... makes the product look like a "test" unit.
    02-24-2016 05:19 PM
  6. RMT1979's Avatar
    Yeah nice one see if you can grab a screen shot. Good point about windows 10 it will be interesting to see if that helps at all when it arrives. How do you find the camera? Another issue I've noticed but forgot to mention is that the main camera is always out of focus and constantly trying to refocus while taking a shot, it can't focus in and hold the image steady while you snap so I'm having to take multiple shots and delete the blurry ones until I get something that's ok. Other than the above points it's still a decent phone!
    slooksterpsv likes this.
    02-25-2016 12:25 AM
  7. RumoredNow's Avatar
    the main camera is always out of focus and constantly trying to refocus while taking a shot, it can't focus in and hold the image steady while you snap so I'm having to take multiple shots and delete the blurry ones

    I always had good luck with point and shoot on this phone using Camera360 Sight. Great focus lock. YMMV.
    slooksterpsv likes this.
    02-25-2016 11:32 AM
  8. RMT1979's Avatar
    Nice one thanks for the tip! Just installed and it takes far better shots than the stock camera app
    RumoredNow likes this.
    02-25-2016 02:37 PM
  9. RumoredNow's Avatar
    Now you'll be ready to post here: http://forums.windowscentral.com/blu...in-hd-lte.html

    ProShot is also groovy on HD LTE...
    02-25-2016 04:38 PM
  10. Captain Fancypants's Avatar
    Battery issue seems to be triggered by over charging action, and can be fixed quite easily. I learn this a couple of days ago from a thread here, which I can't find now.

    There is a hidden button between the volume and power, and you can see it once you pop the back case off. With the phone powered OFF, you hold the secret button down for longer than 30 seconds, and then power it up again. If you have a battery app, launch it and the power level reading should reset to the correct amount, and from there on out the battery issue should be cured, at least until you overcharge again. Something like that anyways. Hope it helps!

    Oh I see the original link now
    http://forums.windowscentral.com/blu...-new-post.html
    03-23-2016 09:15 PM
  11. shamemny's Avatar
    I have Blu Win HD LTE, updated to win 10 phone last month, since then battery drain out. Full charge last 3 to 4 hours, all background apps are turned off. Before upgrade, used to charge phone every other day for an hour. After update, need to charge every few hours. Anyone has similar issue?
    04-10-2016 10:12 AM
  12. DaHardhouse's Avatar
    I followed Captain Fancypants' post and it worked like a charm. Now the battery charge indicator goes up and light turns green when it reaches 100%. No battery drain problems either.
    04-27-2016 12:30 PM
  13. Ammie From The Hell's Avatar
    Battery issue seems to be triggered by over charging action, and can be fixed quite easily. I learn this a couple of days ago from a thread here, which I can't find now.

    There is a hidden button between the volume and power, and you can see it once you pop the back case off. With the phone powered OFF, you hold the secret button down for longer than 30 seconds, and then power it up again. If you have a battery app, launch it and the power level reading should reset to the correct amount, and from there on out the battery issue should be cured, at least until you overcharge again. Something like that anyways. Hope it helps!

    Oh I see the original link now
    http://forums.windowscentral.com/blu...-new-post.html
    thanks a lot. you saved me!
    05-05-2016 12:33 PM

Similar Threads

  1. Post your battery saving tips/suggested modifications
    By Joseph Buhagiar in forum Microsoft Lumia 950 XL
    Replies: 22
    Last Post: 03-04-2016, 06:03 AM
  2. Edge Battery Drain Measurements
    By Stephen McNulty in forum Microsoft Lumia 950
    Replies: 0
    Last Post: 02-24-2016, 06:54 AM
  3. Post-Reset Update Issues
    By Johnston212 in forum Microsoft Surface 3
    Replies: 2
    Last Post: 02-24-2016, 12:46 AM
  4. Lumia 830 battery draining really fast
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-23-2016, 08:39 PM
  5. Update Issue?
    By rgc6789 in forum The Xbox Lounge
    Replies: 0
    Last Post: 02-23-2016, 04:33 PM
LINK TO POST COPIED TO CLIPBOARD