1. Lumiagurl920's Avatar
    Hi everyone. I got a Microsoft Band for Christmas and am having some issues with it. First of all, heart rate, step counter, calories etc...all work fine. I opened the band and set it up through the Health app on my Lumia 920 which runs the Cyan update. It syncs to the app without any issues buy Cortana, texts, emails, etc...do not work. I checked the Bluetooth settings and they are all on. In my phone, it lists the device as paired. Of you click it, it says connected for a second or two before switching back to paired. I erased the band from my phone, deregistered it and restored factory settings on the band. After this I reinstalled it but had the same problems. I love my band but I really need the texts and such. I really don't want to update to the developer preview either. What can I do? It syncs fine in the app so it can't be broken...thanks
    12-26-2014 12:20 AM
  2. 11B1P's Avatar
    With it switching back to "paired" it sounds like the Band is not turned on. Is the Band charged?

    I'm sure you've done this, but, in the MS Health app, in the top right corner, there is pic of a Band. Touch it and select Manage Tiles. Scroll down through the tiles and make the ones you want notices from, are turned on.

    Another thing to try, is turn your phone off and then back on.

    I just opened mine on Christmas morning, too. I'm using mine on an Icon, my wife is using hers on an iPhone 5c. So far, ours are working with no issues.
    12-26-2014 02:05 AM
  3. Lumiagurl920's Avatar
    Hi thanks for the reply. I charged it before pairing it, but its acting like its not even there. Its wierd because it connects and syncs fine to the app but not with the system itself. Also, I have it set for haptic alerts and everything I want alerts for is on. If you press Cortana she tells you make sure Bluetooth is on and your band is close by. Both are on and my phone is on my hand and the band is on my wrist...:(
    12-26-2014 09:49 AM
  4. Lumiagurl920's Avatar
    One random text message came through today from a friend but it still wont stay connected to Bluetooth. Anyone have suggestions?
    12-26-2014 01:59 PM
  5. JasonSCarter's Avatar
    Cyan works with the band, but in my 920 I had to install developer preview to get and update to make it work better. Try that.
    12-26-2014 02:20 PM
  6. 11B1P's Avatar
    I know this sounds silly, but is your phone in Quiet Hours? I just noticed my Band was not connected and had a little trouble "connecting" to my phone. I had to turn Bt off and then back on and it is staying connected now.
    12-26-2014 02:56 PM
  7. Lumiagurl920's Avatar
    What issues did u experience before the update
    12-27-2014 12:16 AM
  8. Lumiagurl920's Avatar
    Tried it. No luck 😞
    12-27-2014 12:17 AM
  9. wpfan1995's Avatar
    Microsoft Band works great on Windows Phone 8.1(Lumia Cyan).
    If you're still on Windows Phone 8(Lumia Black),you will face the problem because Microsoft Band uses Bluetooth 4.0LE which is in the Cyan update.
    I'm afraid to say but you need to join Preview of Developer's program if your phone still runs on Windows Phone 8.0
    12-27-2014 12:36 AM
  10. Lumiagurl920's Avatar
    I have 8.1 cyan.
    12-27-2014 01:02 AM
  11. 11B1P's Avatar
    Microsoft Band works great on Windows Phone 8.1(Lumia Cyan).
    If you're still on Windows Phone 8(Lumia Black),you will face the problem because Microsoft Band uses Bluetooth 4.0LE which is in the Cyan update.
    I'm afraid to say but you need to join Preview of Developer's program if your phone still runs on Windows Phone 8.0
    Not quite accurate. DP does not bring BT4.0LE to the phone. That is one of the features that was stripped out of the DP. The only way to get BT 4.0LE is on Cyan or later. I'm running an Icon, that is on DP, but no Cyan.
    12-27-2014 03:08 AM
  12. Lumiagurl920's Avatar
    Another wierd thing I noticed is that I don't have a Cortana tile on my band. I go to the app and it isn't there to activate either. I can hold the button to bring her up but then it just says Bluetooth is not connected...
    12-28-2014 12:05 AM
  13. 11B1P's Avatar
    On your phone, go to Settings > Applications > Cortana. Is Cortana turned on?
    01-01-2015 11:26 PM
  14. Lumiagurl920's Avatar
    Yes it is, but I see no signs of a Cortana tile on the band or in the Microsoft Health app. If I hold the one button down she listens for a second and then asks to check the Bluetooth. Todays update did nothing for me. Granted I have been getting a few texts inconsistently before the update, but its random really. I contacted Microsoft and they said I had to wait for the denim update. Do ppl with the denim update have any issues? Everything else works fine otherwise. I'm enjoying all the other features
    01-07-2015 11:25 PM
  15. Derausgewanderte's Avatar
    What you experienced happens to me once in a while. I tap paired and it reads connected for a few seconds before it goes back to paired. In that state 3rd party apps such as pimp my band give error messages that band cannot be found.

    What helped for me everytime this happened is to turn off Bluetooth, wait a few seconds and turn it back on. Then the band stays connected for a few days before the problem comes back again.

    Hope that helps.

    Ps: On a L830 with denim. I have no issues with Cortana.
    01-07-2015 11:36 PM
  16. d0m1's Avatar
    Lumiagurl920: See my post here, on a new Lumia 630 with 8.1 Cyan I had massive bluetooth problems with my band, then I've installed DP like on my lumia 1020 and as soon as I've installed the DP it worked like a charm, no more bluetooth connection problems! Also with DP you get the Action Center Tile on the Band so you can access literally all notifications from your WP Device.
    01-08-2015 12:48 AM
  17. locokip's Avatar
    I know it's been almost a year since this original post, but I just wiped my L920 after a failed attempt to upgrade to Windows 10 for Phone and I started having the exact same issue with BT pairing for a second or two then dropping off. It sync'd with MS Health App and Fan Band etc, but as soon as it was done doing it's business, it dropped off again. No notifications, alerts, texts, etc. So, I read all the posts, rejoined the DP and upgraded to 8.1 Update (8.10.14219.341). Still same problem. Tried deleting and unpairing a handful of times. Still no luck. I read your post about Cortana. I did see Cortana on my Band though and through the Health App. As soon as I tried to use Cortana through my Band (I asked it to set an alarm for 5 minutes from now) it paired right up with the phone and started working again. It's been an hour now and she's still paired. Receiving texts and notifications as well. I'll cross my fingers, but maybe folks with the same issue can try this and see if it fixes their problem.

    Thanks,

    LocoKip
    08-17-2015 12:51 AM

Similar Threads

  1. lumia 1520 Denim 4K video recording issues
    By xerox13ster in forum Windows Phones
    Replies: 19
    Last Post: 06-08-2015, 03:12 PM
  2. Unable to receive files over Bluetooth
    By vEEP pEEP in forum Other Brands
    Replies: 7
    Last Post: 01-01-2015, 02:52 PM
  3. Replies: 7
    Last Post: 12-30-2014, 09:24 PM
  4. Lumia 1020 having some issues.
    By dmak91 in forum Windows Phones
    Replies: 3
    Last Post: 12-27-2014, 07:26 AM
  5. On my fourth handset and a minor issue
    By Westarmy in forum Windows Phones
    Replies: 5
    Last Post: 12-25-2014, 12:57 PM
LINK TO POST COPIED TO CLIPBOARD