1. edwark's Avatar
    Hi I tried to put a new screen on my HTC 8X,

    I built it back up but it wont turn on, it does however get power when I place it on charge but only vibrates & screen comes on for 3 seconds.

    Have I damaged something or have I just wired it incorrectly ?

    Thanks
    08-29-2013 03:51 PM
  2. DBDev's Avatar
    It could be either of them, but unfortunately I can't tell you which. Did you replace it because it was smashed? Because in that case maybe something else broke when you smashed it.
    08-29-2013 03:55 PM
  3. BIGPADDY's Avatar
    When you replaced the screen, did you also replace the digitalized (I think that what it called) with it?
    08-29-2013 03:56 PM
  4. edwark's Avatar
    Yeh replaced the complete unit. It did work with the broken screen but not now?

    Help!!!!!!!!!!
    08-29-2013 04:06 PM
  5. abek0's Avatar
    If the lcd is not coming on at all, make sure its plugged in all the way and the right way and the jawbone connector is snapped down. If that isn't the problem, maybe the part you got is defective, which is not uncommon. I've fixed this phone plenty of times already and I'm an electronics technician. Another possibility is that you blew a resistor on the board which could have possibly fried. You might have, but you'll never know because they are tiny. Its a tedious job. I would bring it to your local electronics repair shop that is repretable to check it out. Worst case, you put it back together and make it look never opened and send it back to htc for a warranty.
    Sent from my HTC6990LVW using Board Express
    08-29-2013 11:43 PM
  6. xandros9's Avatar
    this reminds me of something that happened to me a couple days ago.

    So I got my hands on a Treo 650, courtesy a fellow webOS nation member.

    I took it apart to clean and reassembled it to find out that the screen didn't work. After a couple tries, i was sad and proclaimed the display dead. I picked up another on eBay to plunder for parts, and the screen from that one seemed to have broke too. I was at a loss, wondering how it/I could have broken two displays?

    Went on youtube, maybe someone had this problem before, and lo and behold, there was a comment on one video: "Excellent. I thought my new screen wasn't working but this showed me that the ribbon cable needs a bit of a push." I had nothing to lose so I gave the ribbon connector a hefty push and *click*.

    I now (awkwardly) have two fully functional Treos.
    08-30-2013 10:43 AM
  7. edwark's Avatar
    Thanks guys I will give it another go. Think I might just give up I'm that sick :-(
    08-30-2013 11:13 AM
  8. illitero's Avatar
    I'm having the same issue after disassembly. Mine vibrates, displays the HTC/Beats screen, then restarts. It wouldn't make sense to have a loose connection affect it if it's turning on, but I'll jump in there again and see what I can do... I'll update in a few minutes.
    08-30-2013 02:28 PM
  9. illitero's Avatar
    I'm having the same issue after disassembly. Mine vibrates, displays the HTC/Beats screen, then restarts. It wouldn't make sense to have a loose connection affect it if it's turning on, but I'll jump in there again and see what I can do... I'll update in a few minutes.
    Nope, just a loopin' waste of my enthusiasm. A huge bummer. Won't go into bootloader or recovery at all. I'm very certain I didn't damage anything; disassembly was rough without a heatgun, but not anything violent or careless was done.

    Phone suddenly died, I wondered if something came dislodged after flexing it earlier in the day. So I took it apart, put it back together, realized it was just dead, and now this. I understand any Nokia WP device has issues with total drain and need left on the charger for a while, but mine's been sitting for a few hours at this point with a TouchPad charger that pushes a bit more juice.
    08-30-2013 02:38 PM
  10. abek0's Avatar
    If you're having a boot load problem, then usually that's a software issue. But its also possibly you could've fried a resistor.
    08-30-2013 08:37 PM
  11. edwark's Avatar
    Took this to a phone repair shop & he told me he will sort any phone but this one! Think HTC need a rethink on how this is manufactured.
    09-01-2013 10:25 AM

Similar Threads

  1. Here Map uses phone minutes?
    By Zoltan Ujhelyi in forum Nokia Lumia 521
    Replies: 11
    Last Post: 09-02-2013, 12:26 PM
  2. pop3 emails on wp8-help
    By umang_k91 in forum Windows Phone 8
    Replies: 14
    Last Post: 09-01-2013, 10:48 PM
  3. Dropped phone
    By calfee20 in forum Nokia Lumia 521
    Replies: 6
    Last Post: 08-30-2013, 09:41 AM
  4. Facebook sync issues in People hub
    By Guzzler3 in forum Windows Phone 8
    Replies: 3
    Last Post: 08-29-2013, 03:41 PM
  5. Replies: 2
    Last Post: 08-29-2013, 02:51 PM
LINK TO POST COPIED TO CLIPBOARD