1. Silent Night's Avatar
    For the last week or so when I try to browse the web or anything on my M8 it will load super slow when I'm using WiFi. It used to work fine on WiFi. It currently works fine on cellular data outside of the house, it's actually faster. The internet on any other device in the house works like normal with fast speeds.

    I've noticed that on WiFi the only site that seems to load fast is Bing. I decided to write down how fast a few sites load.
    On WiFi:
    Bing: 1 second
    Google: 1 minute and 2 seconds
    YouTube: 1 minute and 39 seconds
    Windows Central: 23 seconds

    On Data:
    Bing: 1 second
    Google: 2 seconds
    YouTube: 4 seconds
    Windows Central: 5 seconds

    As you can see there is a big problem here. Any help would be appreciated. I ran the speed tests through Internet Explorer on my M8 with Windows Phone 8.1
    11-05-2015 04:47 PM

Similar Threads

  1. Limited WiFi Connection
    By orangesplease in forum Microsoft Surface Pro 4
    Replies: 2
    Last Post: 11-06-2015, 12:04 AM
  2. Take a look at Windows Hello in action on the Lumia 950 XL
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-05-2015, 04:42 PM
  3. Messaging + Skype scores minor update on Windows 10 Mobile, desktop
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-05-2015, 04:30 PM
  4. LG's super-light Windows 10 notebooks on sale now at Microsoft Store
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-05-2015, 04:30 PM
  5. Battleborn gets hit with a delay, will now be released on May 3, 2016
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 11-05-2015, 04:11 PM
LINK TO POST COPIED TO CLIPBOARD