1. propeller10's Avatar
    The box was already open and the security seal was missing, the outer cover on the phone was taken out and the sim card was already installed. I have bought many phones before but not like this. What's going on?
    12-08-2011 09:50 AM
  2. kevm14's Avatar
    Mine came like this. Many others did as well. It bothered me a little but there didn't seem to be any damage.
    12-08-2011 09:51 AM
  3. propeller10's Avatar
    Mine came like this. Many others did as well. It bothered me a little but there didn't seem to be any damage.
    yeah. I expect my phones to be untouched when i buy them brand new. No damage here as well. But I do not see the point in opening the box just to install the sim card.
    12-08-2011 09:54 AM
  4. kevm14's Avatar
    Much worse than that, the phone was sitting 180 flipped (top to bottom) in its unattached rear cover, which made me cringe thinking about rough treatment in shipping. Everyone should check their antenna contacts to make sure they aren't bent and are properly contacting the case in the appropriate places. This may help some folks with really bad reception issues.
    12-08-2011 10:08 AM
  5. pecuevasb's Avatar
    My TITAN's box also came with the seal slashed and the "TXTING N' DRIVING IT CAN WAIT" film partially removed. The reason is because AT&T inserts a new SIM card into the phone.
    12-08-2011 11:12 AM
  6. jenashley's Avatar
    Mine wasn't that bad. The SIM card was in there, but it was put in right, the back cover was snapped on right and the "TXTING N' DRIVING" thing was slipped back on the phone just right. The phone was also facing the right direction in the box. Maybe 'cause mine was Premier?

    I understand the warehouse may be busy, but it's like they don't understand that these are expensive devices and it'd be best if they get delivered in the best state possible.
    12-08-2011 11:16 AM
  7. pecuevasb's Avatar
    They must have worn gloves, because I didn't see any fingerprints on the screen from releasing the back cover and erroneously inserting the SIM card.
    12-08-2011 11:19 AM
  8. Rocket_Girl's Avatar
    Mine was open as well. Not great, but OK when devices are all new and hard to come by. Absolutely NOT ok once returns are out there. Have never seen this with other devices on other carrier. Is this an at&t thing, or things more specific Titan thing? When I returned one to the store still in shipping box, they opened it and didn't seem surprised to find the Titan package already unsealed.
    12-08-2011 11:36 AM
  9. Reflexx's Avatar
    This is likely the result of a bunch of non-techie customers who clogged up customer service with calls about their new phones not working because they failed to put in SIM cards. Sucks.
    12-08-2011 02:00 PM
  10. daylater's Avatar
    same issue, thought it was a refurb or something before i realized they had just installed a sim card (Which i removed and replaced with the one from my focus anyway...)

    Odd, but not worth getting upset over.

    The power button on the other hand is driving me insane!!!
    12-08-2011 02:06 PM
  11. DrKofi's Avatar
    Same thing here, but didn't make a big deal out of it since it's working perfectly and it didn't have any marks at all. :)
    12-08-2011 04:38 PM
LINK TO POST COPIED TO CLIPBOARD