1. Farshadatis's Avatar
    Recently I got Lumia 635 and tried to pair it with Band, Before that I had Lumia 920.
    I cant see notifications, cortana, calls tiles on the band or even on health app.
    My Bluetooth is on, but when I go to the settings it says paired with band and every time i click on it, it connects for few seconds and then disconnects,
    Is there a hardware limitation on 635 or there is other problem?
    06-12-2015 12:22 PM
  2. bksalt's Avatar
    I have been using the band with my lumia 635 for months now and never a glitch, has worked seamlessly for me better than I ever expected, if you can take it to a Microsoft store and have them check it out or call Lumia customer support they are great. Some thing must be wrong with either the band or the phone or the way you set up your Microsoft account, are you able to see every thing in the Microsoft Health site?
    06-12-2015 09:28 PM
  3. chickentikka's Avatar
    I had the same problem with my 930. Unpair, reset the band and delete the Bluetooth connection. And start the connection again I found the help on MS forum and worked a treat.
    06-13-2015 12:02 PM
  4. Farshadatis's Avatar
    I upgraded to Win10 and now everything works, the only guess I have is because of Cyan rom.
    06-13-2015 03:46 PM
  5. Mark Chesney's Avatar
    I couldn't get my 635 to pair with my band at all - it wouldn't even show up under bluetooth. I noticed the 635's wifi was acting strange, going in and out when looking for bluetooth devices, so I disabled it. Then all of a sudden the band showed up for pairing under bluetooth!
    06-20-2015 04:44 PM

Similar Threads

  1. Replies: 1
    Last Post: 10-21-2015, 09:56 AM
  2. Microsoft Store Band + Yurbuds deal
    By Indistinguishable in forum Microsoft Band & Band 2
    Replies: 1
    Last Post: 06-17-2015, 01:21 AM
  3. Clearing SMS off band
    By MassDeduction in forum Microsoft Band & Band 2
    Replies: 2
    Last Post: 06-12-2015, 11:21 AM
  4. Surface Pro 3 beats iPad Air 2 and numerous Android tablets in performance test
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 06-12-2015, 11:11 AM
  5. Replies: 0
    Last Post: 06-12-2015, 09:00 AM
LINK TO POST COPIED TO CLIPBOARD