1. Alchemy Metalist's Avatar
    Not sure where to post my question, but I'll post it here since this is a popular thread. I have a 950 XL dual-sim (international version Middle East), and a while ago I got into the insider program and updated my phone to 10586.71 which was the latest version at the time for the slow ring, but ever since I stopped getting any updates what so ever. I even tried shifting to fast ring and the remaining Insider options but nothing worked. Even tried getting out of the program and checking for an update but without luck. Finally I uninstalled the Insider Preview and still, no update was thrown my way. I've been stuck at .71 for over a month now without an update. Any solutions?
    03-05-2016 02:14 PM
  2. Guytronic's Avatar
    Not sure what would be going on with no update after trying what you have already done.

    wp_ss_20160305_0002.png

    Did you try the Insider Release Preview option?
    You should be able to download and update from check for updates on your phone from the Preview option with Insider.
    Be sure to go to phone update again and see if it updates.
    03-05-2016 02:29 PM
  3. Alchemy Metalist's Avatar
    Not sure what would be going on with no update after trying what you have already done.

    Click image for larger version. 

Name:	wp_ss_20160305_0002.png 
Views:	17 
Size:	157.9 KB 
ID:	123289

    Did you try the Insider Release Preview option?
    You should be able to download and update from check for updates on your phone from the Preview option with Insider.
    Be sure to go to phone update again and see if it updates.
    I literally tried every single option in the Insider program multiple times with no luck...
    Last edited by Guytronic; 03-05-2016 at 03:50 PM.
    Guytronic likes this.
    03-05-2016 03:08 PM
  4. Guytronic's Avatar
    I literally tried every single option in the Insider program multiple times with no luck...
    Sorry about this...
    Are you on a Wi-Fi connection or data only by any chance?
    03-05-2016 03:52 PM
  5. Alchemy Metalist's Avatar
    Sorry about this...
    Are you on a Wi-Fi connection or data only by any chance?
    Tried both while searching for an update...
    03-05-2016 04:42 PM
  6. Guytronic's Avatar
    Is the Wi-Fi connection on a home, school or work router?
    03-05-2016 05:25 PM
  7. Alchemy Metalist's Avatar
    Is the Wi-Fi connection on a home, school or work router?
    Tried home and work Wi-Fis. No luck so far.
    03-05-2016 06:04 PM
  8. Mad Cabbie's Avatar
    I know this is going to sound 'daft' but have you soft reset? Are your date and time correct?? As I said, sounds silly, but I couldn't download anything, store or otherwise. After a while scratching my head, and getting nothing but splinters, I noticed the time was out by one hour!
    Guytronic and Laura Knotek like this.
    03-05-2016 06:09 PM
  9. Guytronic's Avatar
    Tried home and work Wi-Fis. No luck so far.
    The reason I was asking is sometimes Wi-Fi networks won't provision devices properly.
    In the past my Windows phones had problems seeing the mobile phone store at home.

    The occasional home router reset took care of it.
    I thought perhaps you may of been having a similar problem.
    Laura Knotek likes this.
    03-05-2016 06:14 PM
  10. Alchemy Metalist's Avatar
    I know this is going to sound 'daft' but have you soft reset? Are your date and time correct?? As I said, sounds silly, but I couldn't download anything, store or otherwise. After a while scratching my head, and getting nothing but splinters, I noticed the time was out by one hour!
    Well, I've been stuck with .71 for more than a month now and I'm pretty sure I've been through multiple soft resets even though the intention wasn't to resolve this particular issue. But a soft reset is a soft resent regardless of the motive. Moreover, my date and time settings are accurate (automatically adjusted via network carrier).
    03-06-2016 03:52 AM
  11. Alchemy Metalist's Avatar
    Anyone with similar issues?
    03-09-2016 12:44 PM
  12. Zulfigar's Avatar
    Oddly, no. You're in a rare case, and sadly, the only option I see left is to use the Windows Device Recovery Tool and go from there. I say sadly, because it reverts everything back ti factory defaults, and not every app saves everything to the cloud.

    Good luck though!
    Guytronic likes this.
    03-09-2016 12:51 PM
  13. Mr Hyde's Avatar
    Anyone with similar issues?
    Similar, yes. I just posted a thread about being stuck at .122. Multiple soft resets, nothing. Multiple hard resets some with restore from backup and some with my restore, still nothing. The only option that I can think of that I have not yet tried is using the recovery tool.

    My phone works with minimal problems and decent battery life so its not really a pressing issue. I was thinking I may just wait until .164 (or whatever the next production build) is listed in the recovery tool and just deal with it then.
    03-10-2016 08:18 AM

Similar Threads

  1. Is there no predictive texting on the Lumia 950????
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 04-07-2016, 06:23 AM
  2. Wechat Video Problem on 950XL
    By Red River in forum Microsoft Lumia 950 XL
    Replies: 3
    Last Post: 03-10-2016, 08:05 PM
  3. Is it me or is there no sound notification that you receive an email?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 03-05-2016, 02:21 PM
  4. New Machine added to Window Insiders but No builds?
    By gibbyhome in forum Windows 10 Insider Preview
    Replies: 0
    Last Post: 03-05-2016, 11:44 AM
LINK TO POST COPIED TO CLIPBOARD