1. PGrey's Avatar
    Is anyone else seeing this with the 218 build?

    While I can connect, it's flaky as all-get-out, even copying over 1.5GB of photos took 6.5 minutes, and it must've taken at least 1-2 minutes, just to enumerate my 150-ish photos in my Camera_Roll folder.
    The same 950XL, before the 218 update, was lightning fast over USB, the same exact USB cable. I suppose something could've happened to my USB cable since then, or the connector, maybe...
    Same USB 3.0 hub, same USB 3.0 connection to my MB too, before anyone asks. I've been able to push some crazy fast speeds with an external SSD over the same exact hub connection, 200+, which doesn't exactly work out to 6.5 minutes to copy 1.5GB of pics...

    My phone enumeration even crashed Win10 Explorer (the process) twice, trying to simply enumerate my 150-ish photos, that was interesting, it got really un-responsive, and then boom, explorer process died, and then Windows promptly re-started it (the process).
    It's weird, I haven't seen too many things crash Explorer (but quite a few more than in Win7, no question). My thread isn't about that though, different OS (more or less) and different forum for sure, just putting it in here since I thought it was interesting and somewhat pertinent.

    I'm curious to hear, and hopeful it's not my USB port shorting out or something...
    Last edited by PGrey; 04-18-2016 at 01:44 AM. Reason: added content
    04-18-2016 01:40 AM
  2. Mesbah's Avatar
    Some programs like uTorrent if not customized, take whole WiFi & Ethernet bandwidth with highest priority leaving no line for other apps. So try to transfer pics making sure which consumes your bandwidth.
    04-18-2016 01:51 AM
  3. PGrey's Avatar
    Some programs like uTorrent if not customized, take whole WiFi & Ethernet bandwidth with highest priority leaving no line for other apps. So try to transfer pics making sure which consumes your bandwidth.
    I'm USB only, my WiFi is off, when seeing this. In fact Bluetooth is disabled, the only thing enabled is cellular data.

    The odd thing is, I moved a bunch of pics off the same phone last week, and it took a few seconds, not multiple minutes, and not 3 explorer crashes to finally actually be able to select all the pics, in order to even copy them.
    Obviously, something is timing out light crazy, or causing tons of spurious interrupts, which I suppose could be my USB port or similar, but I'm hoping not...
    Also, I don't have any torrent type apps installed, the closest thing would be Groove, which is completely disabled, in terms of background processing.
    04-18-2016 02:02 AM
  4. Joe920's Avatar
    Interesting, I just ran into super slow USB yesterday on build 218. I was trying to copy some photos folders from my PC to the 950XL DS, main storage. I tried to copy something like six photos folders at once containing 1.4GB worth of data, but my Win10 PC would show the copy dialog and the first filename and get stuck. Doing the folders one at a time did work, but not particularly quickly. It also struggled with some pictures that simply failed to copy. Weird.

    I ended up having to unplug the phone a few times because there was just no way out of the stuck copy dialog.

    I recall a few months back I copied videos to the phone, and I was blown away by the transfer speed. Not sure what's different.
    04-18-2016 11:32 AM
  5. PGrey's Avatar
    This is very similar to what I was seeing, just since the .218 update. Before that, I was getting absolutely screaming speeds at file transfers; now I'm lucky if it can even enumerate a large number of files/folders...
    04-20-2016 04:21 AM
  6. Joe920's Avatar
    This is very similar to what I was seeing, just since the .218 update. Before that, I was getting absolutely screaming speeds at file transfers; now I'm lucky if it can even enumerate a large number of files/folders...
    Did this ever improve for you? I'm still on 218 and it's just painfully slow and unreliable. Listing a long list of folders inside a large 'Music' folder takes forever (minutes?), and copying files often fails with a 'device stopped responding' error. I wonder if it's firmware or OS build related.
    05-06-2016 03:45 PM
  7. PGrey's Avatar
    Nope, I'm running 242 now, same deal. I wish I could roll back, without a reset.
    USB is the worst of it on 242 though, it's much more stable than 218, so that's a plus!

    I had to reset my wife's One M8 the other day, EPIC fail on the recovery (I did two backups, both right before the reset) about all that came back was the home screen and colors, all the rest was wiped. I couldn't even get it to sync the texting history, and I had to re-create the hotmail account to populate those pieces.
    I.E. Until I hear about this being fixed, I'm going to do EVERYTHING possible to avoid a reset...
    05-06-2016 05:08 PM
  8. Joe920's Avatar
    Nope, I'm running 242 now, same deal. I wish I could roll back, without a reset.
    USB is the worst of it on 242 though, it's much more stable than 218, so that's a plus!
    Kind of the same here, apart from the USB issue it seems well-behaved, so I'm not too inclined to try any other builds any time soon.
    05-06-2016 08:55 PM
  9. Joe920's Avatar
    I wonder if today's update fixes it. One of the fixes is "Improvements to the reliability of USB-C connections."

    Fingers crossed!
    05-10-2016 05:25 PM
  10. Joe920's Avatar
    Well, this seems fixed on my 950XL with Production Build 10586.318. I just transferred 2GB to the phone's main memory in under a minute. Fast enough for me!
    05-19-2016 01:27 PM

Similar Threads

  1. My phone didn't restore datas after hard reset build 14322
    By danghung in forum Windows 10 Mobile Insider Preview
    Replies: 3
    Last Post: 04-18-2016, 09:47 PM
  2. Replies: 1
    Last Post: 04-17-2016, 07:36 PM
  3. On my Lumia 950 XL, when I use the VPN, why am I unable to stay connect to FB Messenger?
    By Windows Central Question in forum Microsoft Lumia 950 XL
    Replies: 1
    Last Post: 04-17-2016, 05:50 PM
  4. How do I get live TV on my PC?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-17-2016, 02:34 PM
LINK TO POST COPIED TO CLIPBOARD