1. konga056's Avatar
    I can't seem to enable hibernate on the surface book. I've tried powercfg -h on as well as enabling it via the registry but it still wont let me select it as an option in power controls. Any ideas on how to fix?
    10-30-2016 09:25 PM
  2. xandros9's Avatar
    10-30-2016 09:30 PM
  3. konga056's Avatar
    I tried that and the only option I can select is just sleep.
    10-30-2016 09:34 PM
  4. zerospace-net's Avatar
    This is odd, considering that hibernate is enabled by default on the Surface Book. Did you buy your machine new? Is this a recent development? Is it a corporate machine?
    10-31-2016 10:31 AM
  5. worwig's Avatar
    Do you have plenty of storage space on drive C?
    I needs to create a large files to save the machine state to. If there isn't room for the file, you can't use hibernate.
    10-31-2016 10:46 AM
  6. konga056's Avatar
    This is a brand new surface book so there is nothing installed yet. I've also tried resetting it and only just installing windows updates and still nothing.
    10-31-2016 12:31 PM
  7. zerospace-net's Avatar
    Return/exchange it -- that's not normal.
    Laura Knotek likes this.
    11-01-2016 12:04 PM
  8. worwig's Avatar
    From what you say, I assume you did the “Powercfg /hibernate on” command in an elevated command prompt.
    11-02-2016 10:16 AM
  9. zerospace-net's Avatar
    From what you say, I assume you did the “Powercfg /hibernate on” command in an elevated command prompt.
    Hibernate should be on/enabled by default on a brand new out of the box Surface Book ... something's off here, and if it were me, I'd return the unit and/or exchange it.
    11-02-2016 10:40 AM
  10. adesonic's Avatar
    I do not appear to have a hibernate option - only sleep - having said that, I read somewhere that enabling hibernate on an SSD equipped PC is a bad move as it just adds to the number of read write cycles the SSD has to perform (which are finite)
    11-06-2016 06:57 AM
  11. zerospace-net's Avatar
    I do not appear to have a hibernate option - only sleep - having said that, I read somewhere that enabling hibernate on an SSD equipped PC is a bad move as it just adds to the number of read write cycles the SSD has to perform (which are finite)
    Do you have a Surface Book? There SHOULD be a hibernate option, as the default setting from Microsoft is to sleep and then hibernate after 2 hours. It's been this way since at least the Surface Pro 3.

    Regarding read/writes and flash memory: While true (somewhat), the likelihood that you'll exceed that during the device's useful lifespan is pretty much BS. Have you killed an SD card due to read/writes or a flash drive? I've got memory cards and flash drives that are so old and so well used it's not even funny (one is powering my NAS as I type this, and that flash drive is probably 4 years old and has been in constant use for 2 years). All of these have read/write limits -- they're all solid state memory/storage. Unless you enjoy going thru a full boot sequence every time you need to use your machine (because allowing it only to sleep will drain the battery faster, thus harming your overall battery life over time -- more charge/discharge cycles), hibernate is a good option.

    Oh, and FYI, Windows 10 actually stores OS/session data to the drive no matter what -- unless you do two button shutdowns all the time, it's re-loading from a semi-saved state whether you do full shutdowns or use hibernate. So there's that, too. By not using hibernate, you're really not saving anything, including the SSD.
    11-07-2016 10:40 AM
  12. adesonic's Avatar
    That is useful info about the ssd, thanks. In answer to you other questions I definitely do have a surface book (using it now) and cannot find a hibernate option unless I am looking in the wrong place
    11-07-2016 01:16 PM
  13. Machoua's Avatar
    Had the exact same problem. Nothing did it for me. Went to command, regedit, and then changed the hiberfile.sys to 75% and it came back. Tried powercfg /on and off, did nothing. I forget which forum or post I found the instructions, but theres a fix.
    11-12-2016 09:23 PM
  14. zerospace-net's Avatar
    Had the exact same problem. Nothing did it for me. Went to command, regedit, and then changed the hiberfile.sys to 75% and it came back. Tried powercfg /on and off, did nothing. I forget which forum or post I found the instructions, but theres a fix.
    If this is a windows bug, Microsoft should know how to fix it... especially if it is happening on a brand new Surface Book (and it shouldn't).
    11-14-2016 12:13 PM

Similar Threads

  1. Is Microsoft trying to be unpredictable?
    By Satish Singh in forum Windows 10 Mobile
    Replies: 4
    Last Post: 10-31-2016, 08:22 AM
  2. How to send saved videos on Nokia Lumia 635
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 10-30-2016, 03:17 PM
  3. WWE 2K17 Achievement Guide: How to win every Achievement on Xbox One
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-30-2016, 03:11 PM
  4. Replies: 3
    Last Post: 10-30-2016, 01:58 PM
LINK TO POST COPIED TO CLIPBOARD