1. Great deal's Avatar
    Okay so i tried installing the new firmware and it failed.

    Refreshed SP2 and tried again - found 23 new updates, worked BUT wifi adapter stopped working after update!!!
    Refreshed again and tried again - same issue.

    Factory reset - found 23 updates and currently updating - will let you know if it works or if MS have screwed it up.
    12-10-2013 07:10 PM
  2. jamojamo's Avatar
    Okay so i tried installing the new firmware and it failed.

    Refreshed SP2 and tried again - found 23 new updates, worked BUT wifi adapter stopped working after update!!!
    Refreshed again and tried again - same issue.

    Factory reset - found 23 updates and currently updating - will let you know if it works or if MS have screwed it up.
    My firmware update is also showing failed. Would be interested in your results.

    Sent from my Nexus 7 using Tapatalk 4
    12-10-2013 07:19 PM
  3. Great deal's Avatar
    12-10-2013 07:21 PM
  4. Great deal's Avatar
    Ok it worked! - there was no wire less as previously - and I just restarted the SP2 as in below and it worked :) now to reinstall EVERYTHING :/


    http://answers.microsoft.com/en-us/s...f4cd442?page=1
    1jaxstate1 likes this.
    12-10-2013 07:29 PM
  5. zariman's Avatar
    Mine is hanging up on the "Getting devices ready" screen after the tablet restarted. It's been on that screen for over half an hour now. This can't be normal can it?
    12-10-2013 08:52 PM
  6. Great deal's Avatar
    WARNING - this is a known issue - if you factory reset and update firmware your cover may not work - Surface Pro 2 - Surface cover telemetry driver / blank screen - Microsoft Community
    12-10-2013 09:46 PM
  7. dave_456's Avatar
    I had this exact problem, I did a factory reset then tried to install firmware updates- the Surface Cover Telemetry driver failed to install - this was solved by downloading the driver bundle from Microsoft and installing the telemetry driver by right clicking and choosing install on the actual driver file. I also had the problem of the WiFi driver failing to install - my recollection is I that I disabled the entry in the device panel and re enabled and that fixed it.

    Both have worked perfectly since.

    Hope that helps.
    Great deal likes this.
    12-11-2013 01:25 AM
  8. sjgore's Avatar
    It failed here too, but when I check for Windows updates again, it says there aren't any.

    Anybody know how to manually install it, or force it to try again? (without a factory reset)
    12-11-2013 03:26 AM
  9. sjgore's Avatar
    From here (as posted by "Great deal" above): System Firmware Update - 12/10/13 fails to install - Microsoft Community

    If your driver versions match below (mine do, even though the update shows as failed), then it looks like the firmware update was successful:

    Surface Pro 2:
    • Intel HD Graphics (v10.18.10.3345)
    • Improved system stability, including minimizing full screen games.
    • Color fidelity improvements for all applications. Enhanced audio experience when connected to a Display Port 1.2 device.
    • Marvell AVASTAR WiFi and Bluetooth Driver (v14.69.24049.160)
    • Wi-Fi driver update for an improved Wireless Display experience and connectivity with Wireless Access Points.
    • Surface Type Cover 2 Firmware Update Device (v2.0.266.0)
    • Surface Touch Cover 2 Firmware Update Device (v1.0.280.0)
    • Optimized two finger track pad use.
    • Surface Pro UEFI (v 2.04.0250)
    • Surface Pro System Aggregator Firmware (2.03.0650)
    • Surface Pro Embedded Controller Firmware (23.07.50)
    • Improved Surface Cover Interaction including power-saving sleep functionality.
    12-11-2013 04:09 AM
  10. SillyFlamingo's Avatar
    The internet is full of people complaining about this. One advice was to check antivirus/security-programs first before trying "bigger" solutions like reset and reinstalling everything. So I deinstalled my GData Total Protection 2014 - and internet was back again, wireless and lan. Since I felt uncomfy without protection I downloaded the latest version of the GData software and installed it again. The wifi-connection still works. I have no idea why but I'm glad that I didn't have to go back to factory reset. Seems to be a complex windows 8/8.1 problem because there are so many different solutions. It's good to have a pc with win 7 in case windows 8 is .... again.
    12-11-2013 04:10 AM
  11. Lumia 920's Avatar
    Is the December drivers pack available to download on MSFT store ?
    I would like to install this update manually
    Thanks
    Last edited by Lumia 920; 12-11-2013 at 05:06 AM.
    12-11-2013 04:50 AM
  12. Great deal's Avatar
    Finally sorted it all, did factory reset while type cover attached - did update then reboot to get wireless working - still unknown adaptor in other settings tho
    12-11-2013 10:00 AM
  13. jamojamo's Avatar
    I had to do a factory reset as well. Lots of people experiencing this issue. Unfortunately for me, I am back on old drivers for Video, Bluetooth/Wifi and Touch Cover 2. I also have the Telemetry issue. Hopefully this will get sorted out and a fix will be issued. I am leery about trying the workarounds because I've got to get some work done and also enjoy the device. Constantly updating and reinstalling drains the joy out of the day quickly!
    Great deal likes this.
    12-12-2013 05:52 AM

Similar Threads

  1. WIndows Phone - Preview for Developers and OEM Firmware Updates
    By GameOver69 in forum Nokia Lumia 1020
    Replies: 12
    Last Post: 12-13-2013, 05:39 PM
  2. [Win8.1 Game and Free Phone Game] North Pole Invasion
    By GlowPuff in forum App Spotlight
    Replies: 1
    Last Post: 12-10-2013, 07:47 PM
  3. [New Game] Tower Defense
    By kxalv in forum App Spotlight
    Replies: 1
    Last Post: 12-10-2013, 07:46 PM
  4. Post GDR3 update
    By tk-093 in forum Nokia Lumia 928
    Replies: 2
    Last Post: 12-10-2013, 06:25 PM
  5. Should Socl and Photosynth merge into a photo social networking app?
    By 12Danny123 in forum Microsoft News & Rumors
    Replies: 4
    Last Post: 12-10-2013, 04:32 PM
LINK TO POST COPIED TO CLIPBOARD