1. runamuck83's Avatar
    so, I got my shiny new Surface RT - fired it up. All good...

    It said I needed to do 15 updates to the stock apps. Ok, fine...

    So, it froze on 3 of them, and now they're freaking missing and I can't get them back!

    The News, People, and Photos app - all gone!

    What do I do?
    10-26-2012 09:52 AM
  2. illidanx's Avatar
    i think hitting the reset button to wipe everything might work.
    10-26-2012 09:54 AM
  3. runamuck83's Avatar
    Where might that button be?
    10-26-2012 09:56 AM
  4. runamuck83's Avatar
    OK, I'm trying a "Refresh". let's see what happens.
    10-26-2012 09:59 AM
  5. runamuck83's Avatar
    That didn't work - back to doing a total Reset of the thing!
    10-26-2012 10:18 AM
  6. theefman's Avatar
    Have you tried going into the store, bringing up the app bar and going to the My Apps section? Should be able to reinstall from there.
    10-26-2012 10:22 AM
  7. runamuck83's Avatar
    Have you tried going into the store, bringing up the app bar and going to the My Apps section? Should be able to reinstall from there.
    Yes, I tried that. When I search for it it says "You own this app" like it thinks it's already installed, yet I can't find it anywhere on the system. It's like it's stuck in limbo.

    I was only about 10 mins into using it so a total reset doesn't lose too much - but hopefully this doesn't happen again.
    10-26-2012 10:26 AM
  8. DougB541#CB's Avatar
    Someone reported this when first firing up the surface....i think it was anandtech review actually.
    10-26-2012 10:29 AM
  9. runamuck83's Avatar
    Have you tried going into the store, bringing up the app bar and going to the My Apps section? Should be able to reinstall from there.
    Yes, I tried that. When I search for it it says "You own this app" like it thinks it's already installed, yet I can't find it anywhere on the system. It's like it's stuck in limbo.

    I was only about 10 mins into using it so a total reset doesn't lose too much - but hopefully this doesn't happen again.
    10-26-2012 10:41 AM
  10. VagrantWade's Avatar
    Yes, I tried that. When I search for it it says "You own this app" like it thinks it's already installed, yet I can't find it anywhere on the system. It's like it's stuck in limbo.

    I was only about 10 mins into using it so a total reset doesn't lose too much - but hopefully this doesn't happen again.

    It's because the Windows store is getting hammered. I had the same problem with the Windows store on my PCs despite not having it at all for the past few months. The app downloads were also slow.
    10-26-2012 10:45 AM
LINK TO POST COPIED TO CLIPBOARD