1. hysonmb's Avatar
    Suddenly today, the GPS on my Lumia 1020 stopped working.
    I've tried everything short of going back to factory with the phone. I really hope it's not a hardware issue. I really like my 1020 but I've had a series of issues since July, right after the warranty expired, and it's getting frustrating.
    Are there any potential fixes for a non-responsive GPS?
    08-29-2014 08:57 PM
  2. jeetu4444's Avatar
    Is yr location on on the phone
    08-30-2014 08:19 AM
  3. hysonmb's Avatar
    Yes, the location is on. It gets a little more odd too.
    The phone actually does capture my location when I launch an navigation app but it cannot track me after that. It also still captures the location accurately when I take pictures.
    08-30-2014 11:16 PM
  4. hysonmb's Avatar
    I restored it to factory with the Nokia recovery tool and the GPS still isn't working. I guess it's a hardware problem. This sucks, I use my GPS all the time!
    08-31-2014 06:30 AM
  5. Alex Castillo's Avatar
    I experience the same issue after upgrading to Cyan (WP 8.1), I used a lot the GPS with no problems before the upgrade, but as reported, even with location turned on, no battery saving enabled, any GPS app works for one moment, then if you move it does not "follows" and you get the gps signal some minutes later. I have tested it on my car and when I start the navigation I have the right location, but a few minutes after I start driving the phone looses the gps signal and the speed information and location get stopped, without doing anything and still driving, the phone recovers the signal and shows the updated location but only for a few minutes. This keep repeating all the time. I think it was the WP 8.1 upgrade that created the problem
    10-03-2014 03:28 PM
  6. Jaco Schutte's Avatar
    Hi, did you get this fixed or found a solution, I recently updated my 920 with Cyan to 8.1 GDR1 Developer Preview and am now experiencing the same GPS issue? So very frustrating -___-
    10-21-2014 01:49 PM
  7. hysonmb's Avatar
    It's been a while, but, I did eventually fix this.
    I opened the phone and after pulling a few things apart, I noticed that the GPS antenna was loose. It wasn't properly seated in the connector that attaches to the front of the board. I pushed it in with a pair of tweezers and a dab of superglue. So far, it's been working.
    12-19-2014 04:31 PM
  8. davissiew's Avatar
    hi..could u elaborate a little more? as i had the same issue, and i took the parts apart, bend the gps antenna at the board towards outward hoping it would touch the case's zinc connector when clipped the board back, but no result still..
    11-30-2015 09:25 AM

Similar Threads

  1. How to install .xap files on Lumia 925?
    By DamjanPetkovic in forum Nokia Lumia 925
    Replies: 4
    Last Post: 12-07-2014, 09:45 AM
  2. Lumia 1520 Cyan on Straight Talk
    By james7679 in forum Carrier Discussion Lounge
    Replies: 4
    Last Post: 09-24-2014, 09:54 AM
  3. Stop the Music when using a GPS Navigation in-car Bluetooth?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-29-2014, 10:30 PM
  4. Need some help with Lumia 930
    By Toan Le in forum Ask a Question
    Replies: 0
    Last Post: 08-29-2014, 08:42 PM
  5. AT&T Lumia 925
    By winphoneaddict in forum Nokia Lumia 925
    Replies: 2
    Last Post: 08-29-2014, 06:28 PM
LINK TO POST COPIED TO CLIPBOARD