04-29-2012 08:33 AM
56 123
tools
  1. wesker's Avatar
    04-21-2012 06:22 AM
  2. wesker's Avatar
    Update.

    I dropped by the Rogers store and got a refund on my Lumia.

    The rep said he's seen a few encountering this issue. So, any of you who just purchased one, I'd let it fully drain and see if the issue occurs or not.
    04-23-2012 02:19 PM
  3. iphone4convert's Avatar
    Darn it! I after reading this post, I let my battery completely drain deliberately. It froze-up on the screen I was looking at and then shut down. I put it on the charger and in about a minute or two, it came back on like nothing happened. I am pissed-off! I wanted to be able to exchange my black lumia for the cyan one and since my 30 days have passed, this was the only way I could think of making this happen. Damn you Nokia for making a good product!
    04-25-2012 08:48 AM
  4. invertme's Avatar
    I'm having the exact same issue with a Rogers Lumia 900.

    I've owned multiple iPhones and Android devices. Never had this issue.

    What a joke.

    I'm going to try leaving it plugged in overnight and see what happens.
    No offense but Android and iPhones are riddled with their own issues. Your response is pretty short sighted.
    04-25-2012 12:56 PM
  5. DarthJeter's Avatar
    My 900 just started doing this today. I've tried everything from booting with the charger plugged in/not plugged in, and with the SIM card in and not in. I'm going to let it charge overnight, and if it doesn't boot in the morning, I'll be heading to the store...and maybe trade in the cyan for the white!
    04-26-2012 11:18 PM
  6. txaggies07's Avatar
    Mine did this a little over a day ago. I am not sure if I will return or exchange. My other Windows Phones always say Goodbye when they run out of juice. This one just went white and froze a bit. I have tried about every thing I could find on how to fix this.
    04-29-2012 08:33 AM
56 123
LINK TO POST COPIED TO CLIPBOARD