11-20-2013 12:16 AM
47 12
tools
  1. Blumby's Avatar
    I believe the answer is to use the Network App, add an APN, and enter the following settings:

    Internet APN
    Access point name = fast.tmobile.com

    MMS APN
    MMS Access point name = epc.tmobile.com
    Proxy Address = 216.155.165.50
    Proxy port = 8080
    MMSC address = http://mms.msg.eng.t-mobile.com/mms/wapenc

    Leave all other fields blank. Hope this works for everyone.
    05-30-2013 04:50 PM
  2. karessae's Avatar
    Does anyone know the exact settings for APN and MMS for Nokia Lumia 900? I can't get LTE and MMS to work together.
    05-31-2013 10:30 AM
  3. NinjaX's Avatar
    Just download Nokia Acess Point and it configures all the APN settings automatically for your carrier.
    05-31-2013 10:44 AM
  4. Blumby's Avatar
    I have contacted T-mobile several times in regards to this issue and they just keep giving me a run around. It seems that maybe we are limited to HSPA+. If you go to the ##3282# menu and enable the 3G only setting then the 4G and MMS work together but no LTE.
    05-31-2013 01:10 PM
  5. karessae's Avatar
    Yeah they're usually no help.
    06-02-2013 06:12 PM
  6. slotti's Avatar
    Just download Nokia Acess Point and it configures all the APN settings automatically for your carrier.
    Just be aware that if you have an unlocked ATT Lumia 900 you will loose the capability of using internet sharing!!!
    06-04-2013 08:24 PM
  7. paula christen's Avatar
    I live in 55406 and i tried all the apn changes and i would be able to send one pix message and no data, sometimes wouldn't even be able to send one px mess. the ONLY solution i found that worked was forcing back to 4g per "Slotti's" instructions above. thank you slotti.
    (unlocked att lumia 900 using prepay t-mobile)
    06-08-2013 02:04 PM
  8. karessae's Avatar
    Which 3G option is it?
    06-11-2013 06:48 PM
  9. slotti's Avatar
    Can you clarify what you mean by "which 3g option"?
    06-15-2013 07:28 PM
  10. doglogh's Avatar
    Can you clarify what you mean by "which 3g option"?
    There is only one 3g option. When you enter ##3283# the field test menu will popup. Ignore all those options and click the three dots on the bottom right corner to bring up the menu.
    Click "Settings"- Network Type will be set to 2G in the next screen. Change it to 3G and Data and mms will work.
    Last edited by doglogh; 06-20-2013 at 02:07 PM.
    06-20-2013 01:49 PM
  11. karessae's Avatar
    Thanks! Worked for me!
    06-23-2013 03:29 PM
  12. Peppy431's Avatar
    It is possible to use LTE with internet sharing, but you have to pay $15/mos for the Smartphone Mobile HotSpot service. The trick is to enable internet sharing while phone is using Edge or 3G connection or you'll get the AT&T message. I'm able to do this by immediately turning on internet sharing after I power up the phone as it doesn't immediately connect to LTE. First it connects to Edge, then 3G, then LTE. It takes about a minute which is plenty of time for me to enable internet sharing. You could also accomplish this by using the ##3282# method, selecting 3G only, enable internet sharing, then switch it to automatic. When it connects to LTE, internet sharing stays on.

    If you do this without adding the mobile hotspot service you'll be directed to a t-mobile page when you try to access the internet on your tethered device.
    06-26-2013 03:53 PM
  13. solomon chasteen's Avatar
    if you use the nokia network selector app. you can add both internet and MSS APN. however I still am unsuccessful at getting the MMS to work under the LTE unless I power cycle the phone and then there is a small window for the upload or download while the phone decides which network 2G,3G, LTE it wants to settle on.
    06-27-2013 11:54 AM
  14. solomon chasteen's Avatar
    Everyone please listen. If you have a unlocked Nokia lumina 900 and T-mobile service you will have data and MMS problems when TMO go to LTE. DO NOT FRET. Here is the solution. 1st down load the Nokia network setup app. 2 load the following APN in both the internet APN and the MMS APN locations fast.t-mobile.com 3 on the MMS apn there is a setting for MMSC Server you must add the following http://mms.msg.eng.t-mobile.com/mms/wapenc DO not use epc.tmobile.com as the MMS apn it will not work since the device is now on LTE.
    06-27-2013 12:30 PM
  15. Peter Kuznicki's Avatar
    Configured apn and mms apn with fast.t-mobile.com and the mmsc address and I'm still unable to send and receive picture msg on T-mobile LTE :( .. please advice
    07-10-2013 11:43 PM
  16. Peter Kuznicki's Avatar
    It worked after rebooting my phone.

    Thanks for the help!
    07-11-2013 12:00 AM
  17. Agent-P's Avatar
    Everyone please listen. If you have a unlocked Nokia lumina 900 and T-mobile service you will have data and MMS problems when TMO go to LTE. DO NOT FRET. Here is the solution. 1st down load the Nokia network setup app. 2 load the following APN in both the internet APN and the MMS APN locations fast.t-mobile.com 3 on the MMS apn there is a setting for MMSC Server you must add the following http://mms.msg.eng.t-mobile.com/mms/wapenc DO not use epc.tmobile.com as the MMS apn it will not work since the device is now on LTE.
    Configured apn and mms apn with fast.t-mobile.com and the mmsc address and I'm still unable to send and receive picture msg on T-mobile LTE :( .. please advice
    In both the internet and MMS APN settings, did you guys only change the settings that were mentioned and leave all the other options blank?

    EDIT: For anyone that comes across this thread via search results (as I did), I now have data and MMS both working with T-Mobile LTE on my Rogers 920. My settings are as follows:

    Under the settings>cellular menu I have LTE selected as my highest connection speed and under the option for Network Selection I changed it from Automatic to T-Mobile.

    Internet APN Settings
    APN: fast.t-mobile.com
    IP Type: IPv4
    (all other fields were left blank)

    MMS APN Settings
    APN: fast.t-mobile.com
    MMSC (url): http://mms.msg.eng.t-mobile.com/mms/wapenc
    MMSC port: 80
    Maximum MMS size: 1048
    IP type: IPv4
    (all other fields left blank)

    After changing these settings, restart to apply.

    I'm sure it's possible I could get some better speeds by tweaking some of these settings, but I'm happy with the performance now and I don't want to unintentionally break anything because it took me a while to find a combination of settings that worked for both data and MMS on LTE. I'll update the post in a week or so to confirm if these settings are still working or not.

    Update (4 August): Settings are still working for me. A friend of mine said his stopped working, but I'm still fine. So YMMV with these settings.
    Last edited by Agent-P; 08-04-2013 at 04:14 PM.
    nicolaai823 likes this.
    07-28-2013 06:20 AM
  18. C_fauxnom's Avatar
    I have a similar problem, but my phone will not allow for me to enter in the proxy address as you have it- it says I cannot have non-latin characters (namely the "-" in "t-mobile".

    What is the work around for this issue?
    08-13-2013 04:32 PM
  19. Lufri's Avatar
    absolutely non of those options are working for me, any other ideas?
    08-27-2013 07:53 PM
  20. roastbeefalo's Avatar
    Hello, I have the Nokia Lumia 900 phone from AT&T, AT&T unlocked it, and I moved over to T-mobile and was not able to send MMS photo text messages. I used the app Network Setup by Nokia for my Lumia 900 and it works for me to send MMS with photos. I just ran the app, it said my settings have been updated, and now it works.
    10-11-2013 03:22 PM
  21. roastbeefalo's Avatar
    Anyone on this thread having problems with Lumia 900 getting MMS messages on t-mobile? Do you know what APN settings to use in the Network Setup app?
    11-19-2013 02:35 PM
  22. slotti's Avatar
    Anyone on this thread having problems with Lumia 900 getting MMS messages on t-mobile? Do you know what APN settings to use in the Network Setup app?
    it's a hit and miss. If you have LTE in your area, you won't be able to get mms out of the box, since they use different apns for LTE and mms.
    Download the Nokia Network app, which will allow for separate apns.
    disclaimer: you will loose the option to share your internet on ATT unlocked devices on the T-mob network.
    You might also have to force 4g on your phone (I cannot receive mms while connected through lte).
    11-20-2013 12:16 AM
47 12

Similar Threads

  1. Lumia 900 on T-Mobile
    By Steven Powell in forum Nokia Lumia 900
    Replies: 7
    Last Post: 05-23-2013, 01:57 PM
  2. Rogers 920 on T-Mobile Showing LTE!!!
    By metalchick719 in forum Nokia Lumia 920
    Replies: 0
    Last Post: 05-18-2013, 10:37 PM
  3. ATT Lumia 900 on eBay for $749
    By baseballbert in forum Nokia Lumia 900
    Replies: 11
    Last Post: 03-25-2012, 06:46 PM
  4. Replies: 0
    Last Post: 01-18-2012, 08:47 PM
  5. Lumia 700 on T-Mobile site
    By KingCrimson in forum Nokia Lumia 710
    Replies: 1
    Last Post: 12-29-2011, 07:32 AM
LINK TO POST COPIED TO CLIPBOARD