1. djncanada1's Avatar
    Hi,

    I have an unlocked Lumia 920, was unlocked by Rogers last night.

    Last night, I installed my Telus micro SIM and got a LTE signal.

    Today, I purchased an additional micro SIM and installed in Lumia 920.

    I have moved SIM's between Samsug Galaxy SIII and Lumia 920, always get LTE on Samsung, 4G on the Lumia 920.

    I called Telus, I am connected to LTE service.

    Any suggestions?
    12-09-2012 04:10 PM
  2. djncanada1's Avatar
    Hi,

    Just an update. I really feel like a knob..

    When I fired up IE and looked to download something..LTE shows up.

    Could someone verify that Lumia 920 normally uses 4G mode until a data activity starts and then moves to LTE? If yes, this is brilliant!!!

    Dave
    12-09-2012 08:21 PM
  3. EG8196's Avatar
    Hi,

    Just an update. I really feel like a knob..

    When I fired up IE and looked to download something..LTE shows up.

    Could someone verify that Lumia 920 normally uses 4G mode until a data activity starts and then moves to LTE? If yes, this is brilliant!!!

    Dave
    No, mine is always LTE, unless no LTE signal.
    If no LTE signal, it will be 3G until a data activity starts and then moves to 4G
    12-09-2012 08:45 PM

Similar Threads

  1. Rogers Lumia 920 Signal issues.
    By MikeLynch001 in forum Nokia Lumia 920
    Replies: 7
    Last Post: 12-09-2012, 11:50 AM
  2. got a lumia 920! one issue
    By graigsmith in forum Windows Phone 8
    Replies: 1
    Last Post: 11-10-2012, 12:41 AM
  3. Rogers' Lumia 920
    By miki20021 in forum Nokia Lumia 920
    Replies: 4
    Last Post: 11-07-2012, 10:25 AM
  4. Replies: 15
    Last Post: 11-01-2012, 03:44 AM
LINK TO POST COPIED TO CLIPBOARD