1. fardream's Avatar
    We know it's an ATT issue, but why windows phone or Lumia cannot figure out it's not in Glen Echo? They put a GPS chip in it and I think after sometime the phone should be able to figure out its location. iPhone doesn't have this problem.
    Andyshine77 likes this.
    02-21-2013 11:58 PM
  2. Laura Knotek's Avatar
    It's AT&T. Some Androids on AT&T have had the same issue (not Glen Echo, but another incorrect location). http://forums.androidcentral.com/t-a...ease-help.html
    02-22-2013 12:04 AM
  3. fardream's Avatar
    It's AT&T. Some Androids on AT&T have had the same issue (not Glen Echo, but another incorrect location). http://forums.androidcentral.com/t-a...ease-help.html
    My question is - since they have a GPS chip in the phone, they should be able to figure out the right location even when ATT is wrong
    02-22-2013 12:10 AM
  4. Andyshine77's Avatar
    Wow I thought it was a Weather Flow app issue. My 900 never had this problem BTW.
    02-22-2013 12:10 AM
  5. fardream's Avatar
    Wow I thought it was a Weather Flow app issue. My 900 never had this problem BTW.
    No idea if it only happens recently. My old Focus S never had this issue either. It's very annoying
    02-22-2013 12:19 AM
  6. Arsenic17's Avatar
    The glen echo issue only seems to happen to me when I am in an area with no GPS reception for a while and it doesn't always happen. Maybe 5% of the time I am at work.
    02-22-2013 12:21 AM
  7. Laura Knotek's Avatar
    No idea if it only happens recently. My old Focus S never had this issue either. It's very annoying
    I had my 900 show that I was in Akron, OH even when I was in Cleveland, OH one time probably around May 2012. It was an AT&T bug.

    Incidentally, I have not seen any issues with GPS location and Lumia Windows Phones (WP7 or WP8) on any network beside AT&T. VZW, T-Mobile, and other carriers in other countries don't have that bug, from what I've seen.
    02-22-2013 12:27 AM
  8. Andyshine77's Avatar
    Glen Echo park, MD is 505 miles from my location, Akron isn't all that far from Cleveland. The GPS is much less accurate and more inconstant than it was on my 900.
    02-22-2013 12:37 AM
  9. Nakazul's Avatar
    Your phone is thirsty :-)
    02-25-2013 05:13 PM
  10. WPenvy's Avatar
    I'm am getting absolutely *&^&^%( sick of this issue. Can't glance and go at Amazing Weather HD because it says i'm in Maryland....

    I live in Orlando, Florida. 875 mile drive away..... No. Just.... No.

    And i just got my 920 back from Nokia, so i know it's nothing to do with them.
    02-28-2013 03:12 PM
  11. Laura Knotek's Avatar
    It's AT&T. If you had any other carrier that issue would not exist.
    02-28-2013 03:16 PM
  12. Squatting Hen's Avatar
    Dude, I know. I am 2,751 miles away. I am a bit sick of this too.
    02-28-2013 03:18 PM
  13. WPKiva's Avatar
    My phone had this problem after installing Maluuba. I rebooted my phone, then turned location off and on and rebooted it again. It is now finding my correct location again. Not sure which step fixed it, but it works correctly now.
    02-28-2013 04:36 PM
  14. gbbg's Avatar
    I got Maryland-ed today. At 14.09 today, my phone just died on me with battery about 50%. When I had to soft-reset it, live tiles weren't updating and I just noticed that my location reverted to Maryland and the maps doesn't identify my location.
    And Here drive+ puts me right me in the middle of Potomac river.
    Wi-fi turned off.
    http://sdrv.ms/XGiZiH
    02-28-2013 08:19 PM
  15. Nakazul's Avatar
    I have uninstalled all Nokia maps and weather apps. In fact all location apps are now uninstalled and that solved the problem.

    I have given up on GPS on WP. Because even if it works it doesn't really work. Its inaccurate as can be. In fact I may have given up on WP. To bad there is no value in WP phones so I can't sell it and buy something else. 😓
    03-05-2013 08:37 AM
  16. Nimdock's Avatar
    This happened to me a couple of times (Glen Echo). Once last Saturday morning and again on Sunday morning. I don't think it's the OS but AT&T. Anyway, I just let it be and both days it had fixed itself after a bit of time passed. Has been OK since.
    03-05-2013 09:04 AM
  17. WPenvy's Avatar
    Just a heads up, but early last week (last monday or tuesday) i uninstalled a bunch of apps (mostly geolocation apps) that i really don't use often and disabled the "keep wifi on" setting. My phone hasn't had a freeze/unresponsive/appears-turned-off episode since.... or put me in the middle of that river in Glen Echo

    Before it would happen at least every other day or up to twice a day with the freezing, or a few times a week with the Glen Echo thing...

    Give it a try unchecking the "keep wifi on..." setting, and/or uninstalling a few location apps

    The only apps i have in the background are:
    Amazing Weather HD
    Markets & Me +

    and then while i'm driving i'll turn on:
    HERE Drive+ Beta

    Or when i'm running:
    Runtastic PRO
    03-19-2013 03:23 PM

Similar Threads

  1. why my lumia 920 cannot see HD movie ?
    By WuhJett in forum Nokia Lumia 920
    Replies: 0
    Last Post: 01-31-2013, 12:10 AM
  2. Replies: 0
    Last Post: 11-29-2012, 12:58 AM
  3. Lumia 920 Glass ding out of box
    By EG8196 in forum Nokia Lumia 920
    Replies: 1
    Last Post: 11-27-2012, 09:05 PM
  4. Replies: 0
    Last Post: 11-16-2012, 02:58 PM
LINK TO POST COPIED TO CLIPBOARD