1. denzilla's Avatar
    Lately, I can't purchase anything from the app store. I get this generic error "We're having trouble charging this to your phone bill, most likely because you've lost your cellular connection" crap. I used to only have problems with this when connected to my microcell, but now I get the error 100% of the time no matter where I'm at. Please note that I am running GDR3, but I'm pretty sure I've bought apps post GDR3 and I had the microcell issue GDR2 back to original firmware.
    12-01-2013 10:40 PM
  2. Laura Knotek's Avatar
    Have you tried using WiFi instead of the mobile network?
    12-01-2013 10:43 PM
  3. denzilla's Avatar
    Have you tried using WiFi instead of the mobile network?
    Yes, forgot to mention that in original post, sorry.
    12-01-2013 11:23 PM
  4. denzilla's Avatar
    Small update: I added a CC to my phone and I can purchase apps again. Still don't know why I can't purchase stuff using ATT account.
    12-03-2013 03:26 PM
  5. Reflexx's Avatar
    It might be a security measure. I couldn't purchase apps on my phone for a while because I asked AT&T to disable it when my son started buying games.
    12-03-2013 03:46 PM

Similar Threads

  1. App Download Cap Increased!!! YAYYYYY!!!
    By luk3ja in forum Windows Phone 8
    Replies: 13
    Last Post: 02-02-2014, 10:03 AM
  2. cant switch accounts on gmail in ie metro
    By username55 in forum Microsoft Surface Pro 2
    Replies: 2
    Last Post: 12-02-2013, 03:53 PM
  3. Moving from iCloud to Outlook.com on Windows RT 8.1
    By mcraine in forum Microsoft News & Rumors
    Replies: 3
    Last Post: 12-02-2013, 10:36 AM
  4. Gdr2, future apps, gdr3, windows OS
    By huevobatido in forum Windows Phone 8
    Replies: 1
    Last Post: 12-01-2013, 10:57 PM
  5. Replies: 0
    Last Post: 12-01-2013, 05:56 PM
LINK TO POST COPIED TO CLIPBOARD