1. ocdi's Avatar
    My Lumia 925 just updated to Cyan, which is awesome. Only problem is my battery saver app doesn't appear to be working. I can pin it as a tile but it is greyed out as if disabled. Pressing on the settings does nothing.

    wp_ss_20140726_0001.png

    Any ideas why it would be completely broken? I considered using the recovery tool to format and re-install but the tool appears to only have 8.0 available. Is that the best bet - format, reinstall and re-upgrade?
    07-25-2014 10:35 PM
  2. rdubmu's Avatar
    I would first try a soft reset (power the phone down, then power it back up), then do a hard reset, if that doesn't work I would try the recovery tool if it is possible to revert.
    07-25-2014 11:44 PM
  3. ocdi's Avatar
    I tried many soft reboots, tried a hard reboot (holding vol down + power) and still no joy. Have tried using the Reset phone option on the device, figured that might be better than the downgrade / upgrade process using the recovery tool. Now have a blank phone and battery saver is loading. :-) Was hoping to avoid doing that as I need to re-setup everything again.
    07-26-2014 12:12 AM

Similar Threads

  1. Nokia Software Recovery Tool Not Detecting Phone
    By TITANWULF in forum Windows Phone 8.1 Preview for Developers
    Replies: 24
    Last Post: 09-20-2015, 07:01 PM
  2. My take on the Lumia 1020 and going back to WP8 from 8.1
    By RaRa85 in forum Nokia Lumia 1020
    Replies: 7
    Last Post: 08-27-2014, 07:50 AM
  3. Live Lockscreen Screenshot and Background sharing Thread
    By Radecke in forum Windows Phone 8.1 Preview for Developers
    Replies: 13
    Last Post: 07-26-2014, 09:02 AM
  4. Live lock screen app: Pro's and cons
    By Neelim Shyam in forum Microsoft News & Rumors
    Replies: 17
    Last Post: 07-26-2014, 03:53 AM
LINK TO POST COPIED TO CLIPBOARD