1. junjunoori's Avatar
    I have a Lumia 820. My network suddenly disconnects even though there is signal. I have to manually go to settings and select network or if I dial any number the network comes back. My brother bought Lumia 520 and even he faces the same issue. Does it happen to you all. How to overcome this issue. Please help me. I have attached the screenshot.
    Attached Thumbnails wp_ss_20130820_0002-1-.png  
    08-22-2013 02:16 AM
  2. Muessig's Avatar
    Have you tried to contact your network provider for any information they can give you to solve this problem? If it's happening across multiple devices I'd point to them rather than the phone, but you could try a soft reset (hold down the volume down button and the power button for 10-15 seconds or until you feel a vibration) and see if that helps anything.
    08-22-2013 05:31 AM
  3. junjunoori's Avatar
    Have you tried to contact your network provider for any information they can give you to solve this problem? If it's happening across multiple devices I'd point to them rather than the phone, but you could try a soft reset (hold down the volume down button and the power button for 10-15 seconds or until you feel a vibration) and see if that helps anything.
    I have changed to another network recently thinking that it might be the issue with network provider and would solve the issue, but its repeating even in this network. And also me and my brother are on different network.He also faces the same issue. Should I contact nokia service center?
    08-22-2013 07:23 AM
  4. Boris Lozac's Avatar
    Stupid question but did you two fit the sim card properly?
    08-22-2013 07:25 AM
  5. pankaj981's Avatar
    Set network to automatic and set highest connection speed to whatever available highest on the phone and reboot
    08-22-2013 07:25 AM

Similar Threads

  1. Halo: Spartan Assault Issue
    By HM02 in forum General Phone Discussion
    Replies: 8
    Last Post: 04-17-2015, 09:37 PM
  2. Help with the "Rooms" feature
    By danj210 in forum Other Operating Systems
    Replies: 2
    Last Post: 08-23-2013, 03:15 PM
  3. Help! How do I insert images into forum posts?
    By AllanUSC in forum Site Feedback & Help
    Replies: 3
    Last Post: 08-23-2013, 09:32 AM
  4. [Free Game] CastleMine Deluxe - WP8
    By Stiv in forum App Spotlight
    Replies: 3
    Last Post: 08-22-2013, 04:20 AM
  5. Lumia 920 Issues..
    By GiftedSoul in forum Windows Phones
    Replies: 3
    Last Post: 08-21-2013, 08:56 PM
LINK TO POST COPIED TO CLIPBOARD