1. malih's Avatar
    I've been wanting to do a hard reset because of several issues, but the earlier WP8.1 release was unable to backup to the cloud succesfully.
    Yesterday I updated my WP8.1 with the latest update, and finally able to backup to the cloud succesfully.

    So I finally did a hard reset earlier today for my 620, and I connected to WiFi and login to MS Account to restore, no issues, that is until Restoring backup.
    The restore process is stuck at 21%, and has been there for about an hour.
    There's an alert that constantly pops up every few minutes and ask whether I want to stop restore or keep going.

    Can anyone offer an insight whether I should leave it or stop restore, and maybe how to do a faster restore.

    Last edited by malih; 05-15-2014 at 06:33 AM.
    05-15-2014 06:16 AM
  2. praveen9663's Avatar
    If you allowed "Downloaded Apps" to restore then it will take time......
    05-15-2014 06:48 AM
  3. anon(8657436)'s Avatar
    Just log on to onedrive.com and look at the left side and click on the button "Devices". If you can see one or more backups there, you can safely stop restoring and hard reset again and try to restore this time. The speed usually has to do with the amount of media on the device and it is always better to remove your SD card during resets.
    malih likes this.
    05-15-2014 06:53 AM
  4. anon(8657436)'s Avatar
    The download apps only begins after this process ends and when they are downloading you can use your phone as normal. So that's not the reason.
    05-15-2014 06:54 AM
  5. malih's Avatar
    Thank you Ashhar Hasan.
    I re-restored after removing SD Card, and the process went smoothly.
    I'm not sure whether the issue is actually caused by SD Card, but I have restored successfully and that's what matters.
    05-15-2014 08:14 AM
  6. anon(8657436)'s Avatar
    It may not be the SD Card. Most probably it was a random error.
    But once I had this problem where my screen did not display anything apart from windows and nokia logo at startup. I hard reset using the "key combination" and my SD Card's Images and Music was wiped completely. So I guess, you're lucky.
    malih likes this.
    05-15-2014 08:38 AM
  7. anon(8657436)'s Avatar
    It may not be the SD Card. Most probably it was a random error.
    But once I had this problem where my screen did not display anything apart from windows and nokia logo at startup. I hard reset using the "key combination" and my SD Card's Images and Music was wiped completely. So I guess, you're lucky.
    05-15-2014 08:38 AM
  8. mayblast's Avatar
    I am having this same issue - though mine is stuck at 25%.
    Most if not all my stuff is in SD card. What you are saying I can stop restoring, turn the phone off, remove the SD and re-try the hard reset?
    05-21-2014 03:18 AM
  9. mayblast's Avatar
    No, removing SD card before hard reset did nothing to me, still stuck at 25% wiithout explanations. How reliable system this MS backup is, wow :/
    05-21-2014 03:56 AM
  10. ttsoldier's Avatar
    mine is stuck at 21% now. no sd card. I hit stop restore and went ahead....
    There is nothing there -_-

    I'm gonna reset and try again :(
    07-06-2014 11:57 AM
  11. ttsoldier's Avatar
    After about 3 more hard resets, it finally restored -_-
    07-06-2014 02:59 PM
  12. SwizzleSoftware's Avatar
    I'm also getting this...get stuck at random points...21%, 25%, 85%. I have now tried about 10 times and I cant get the restore working. Seriously, cant believe it could be so hard to do this? Does anyone have any suggestions, tried the SD Card stuff, but no luck?
    07-16-2014 12:59 AM
  13. JimiDiGriz's Avatar
    I've also got this problem. If I wait will it kick back in if I leave it at 21%? Bit wary about stopping and resetting again.
    08-06-2014 07:45 AM
  14. ikazpk's Avatar
    I was on WP 8.1 Developers Preview & wasn't able 2 install Update 1 bcaz of error... Read somewhere that u can reset the phone & then try again 2 get the Update 1....so I did & now I've Update 1 but when I try 2 restore the backup, it just gets stuck at 25%... Tried about 10 times with no luck... Really really pissed off as I can't get my data back on the phone.... The more I've kept myself loyal 2 Windows Phone from WP7 times, with the hopes that it will come on par with other OS soon, the more it gets annoying...
    08-11-2014 06:19 AM
  15. ZYANCIB's Avatar
    Happened for me too! Soft reset phone, took SD card out, turned back on, hard reset. Restore finished!
    09-21-2014 05:22 PM
  16. Vikram Murkute's Avatar
    Mine was stuck at 21% too.. first time around since I was not around the phone, I guess it timed out and restored partially.. However then I did a hard reset the second time and was monitoring the progress actively.

    Each time it asked me for 'stop restore' or 'keep going', I kept going and voila! all my backed stuff was restored to the T!

    When is comes to microsoft, I guess patience pays :)
    04-12-2015 04:13 AM
  17. salal_87's Avatar
    i had same issue...tried alot of reset, sd card removal...finally solved by removing sim...
    iohanna likes this.
    04-13-2015 10:17 AM
  18. Amol Ashtekar's Avatar
    I believe it's to do with restore verifying the account identity. once past this verification it progresses very well.
    05-06-2015 02:38 PM
  19. mistersniffles33's Avatar
    so do i just take the battery out to stop the restoring? Or is there another way? because i cant see one other than that or saying continue on without finishing the restore. And how do i soft ad hard reset the phone?
    Last edited by mistersniffles33; 06-07-2015 at 11:36 PM. Reason: needed to add some more
    06-07-2015 11:28 PM
  20. Byron Holmes's Avatar
    Removing the SD and the SIM worked for me as well.

    Actually, since I did it in that order, I don't know if removing the SD was part of my solution.

    In my area, AT&T reception is terrible and I suspect that somehow during the restore process the phone was trying to utilize the cellular connection.

    I have an AT&T MicroCell that will allow me to get a cellular signal after the phone is restored.
    07-11-2016 07:36 AM
  21. xeg12's Avatar
    I have hard reset my windows mobile 10 phone and the restore gets to 93% then stops! So I suspect the earlier suggestion of account verification is not the issue here.
    Can't decide whether to keep trying. I am unsure about removing the SD card as most of my programs are installed on there.
    11-08-2016 06:04 AM

Similar Threads

  1. Replies: 5
    Last Post: 05-17-2014, 05:15 PM
  2. is at&t still offering a refurbished 925 for 79.99?
    By RavenSword in forum Windows Phones
    Replies: 9
    Last Post: 05-15-2014, 06:37 PM
  3. Why doesn't the AT&T 925 go on sale for $199???
    By RapidTurtle in forum Windows Phones
    Replies: 3
    Last Post: 05-14-2014, 06:28 PM
  4. AT&T will now let you order online and pick up in-store
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 05-12-2014, 10:50 AM
  5. Unlocked HTC 8X (TMobile) cannot send/receive MMS on AT&T
    By Papias in forum Carrier Discussion Lounge
    Replies: 2
    Last Post: 05-11-2014, 12:33 AM